Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-04-2014, 08:09 AM   #1
LQ Newbie
Registered: Jun 2014
Posts: 9

Rep: Reputation: Disabled
Thumbs up ssh connection problem

Hi everyone,

I faced a problem regarding ssh connection refused while connecting to remote machine, the error is here....

ssh: connect to host port 22: Connection refused
Old 07-04-2014, 09:28 AM   #2
Registered: Jun 2014
Location: Narnia
Distribution: Crunchbang, Arch Linux ARM, Xubuntu
Posts: 43

Rep: Reputation: 0
Try to make sure that ssh is enabled on both devices you are trying to use. If that doesnt help, then make sure you have all the information entered correctly
Old 07-04-2014, 09:37 AM   #3
LQ Guru
Registered: May 2005
Location: boston, usa
Distribution: fedora-35
Posts: 5,320

Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
run the ssh server as sshd -d -d -d
and run the client as ssh -v -v -v user@host
and report your findings.
Old 07-05-2014, 05:22 AM   #4
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 787
Blog Entries: 6

Rep: Reputation: 75
go to machine and execute this
netstat -tanup |grep sshd

if nothing then you need to start the sshd service
Old 07-16-2014, 08:37 AM   #5
LQ Newbie
Registered: Jun 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled

I didnot find any solution from your replies make sure cau u give any better solution for my thread.
Old 07-16-2014, 09:20 AM   #6
Registered: Jun 2012
Location: Topeka, KS
Distribution: Mostly AWS
Posts: 71
Blog Entries: 31

Rep: Reputation: Disabled
You have not provided a whole lot of information for us to help you. The connection is refused. It could be refused because you have: entered the wrong IP address, the SSH service is not running, the port number is wrong, firewalls could block all incoming connections, the public keys on the client could no longer be correct. The list of possible problems goes on and on. What have you tried? And what have you checked?
Old 07-16-2014, 07:15 PM   #7
Fred Caro
Senior Member
Registered: May 2007
Posts: 1,007

Rep: Reputation: 167Reputation: 167
if this is 'ssh me@' then it is a local connection but if you want remote without a dns address that seems more difficult.

Old 07-16-2014, 11:43 PM   #8
Tim Abracadabra
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Originally Posted by sekhar.hai View Post

I didnot find any solution from your replies make sure cau u give any better solution for my thread.
One thought, What is the IP address of your system?

If they (SSH host and your system) are on different subnets (subnet > router > other subnet), then you may need a static route to the router for that subnet where the destination host resides.

Ran into that before. For info try man route.

Hope that helps,

Last edited by Tim Abracadabra; 07-16-2014 at 11:50 PM. Reason: Replace . w/?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH connection problem ssiddall Linux - Networking 8 10-30-2012 07:04 AM
ssh connection problem. windstory Linux - Newbie 2 01-02-2009 06:25 PM
A problem with ssh connection lawrence_lee_lee Linux - Software 5 05-16-2008 08:14 AM
Ssh connection Problem ??? ce_emre Linux - Networking 2 10-11-2006 07:22 AM
ssh connection problem klemen Linux - Networking 2 06-19-2005 04:01 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration