LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2004, 04:16 PM   #16
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30

Try to check this out, type:

cat /etc/ssh/sshd_config | grep Subsystem

It should read:

Subsystem sftp /usr/libexec/openssh/sftp-server

If the line is commented out with a # in front of it, then open the file (/etc/ssh/sshd_config) up with a text editor remove the #, then save it.

I forget how to restart all the daemons, so I would just reboot after that. Let me know how this turns out.
 
Old 08-01-2004, 04:19 PM   #17
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
I should say that the output could be slightly different, the key is whether or not the line is commented out. The config file probably knows exactly where the sftp binary is.
 
Old 08-01-2004, 04:28 PM   #18
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Subsystem sftp /usr/libexec/openssh/sftp-server

This LINE is not commented out in the sshd_config file

What are the permissions supposed to be on the file sftp-server.
this file is owned by "root" and belongs to group "root" Is this a problem?
 
Old 08-01-2004, 06:00 PM   #19
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
The above posts show that I am trying to ftp from my XP box to Redhat box using psftp and it is hanging up when I enter the passwrod

OK I did this from my redhad box I type sftp 192.168.1.114

after the login sequence it asks for the password, when I type the password it says
"received message too long 538976288"
 
Old 08-01-2004, 10:04 PM   #20
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Sorry lyar, but I had a party to go to, and I'm a little busy for the rest of the evening. I did find this, and I think this may be the problem. It may be a difference in the protocols, whether you're using ssh1 or ssh2. Here, check out the faq for openSSH
http://www.snailbook.com/faq/
Sorry, but I was almost sure that the other post was the solution. This faq specifically talks about the response you are getting.
 
Old 08-01-2004, 11:22 PM   #21
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Try scp instead of sftp ?
 
Old 08-02-2004, 11:30 AM   #22
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Hope the party was all-right...

I will try all the suggestions I get, but thanks for all the help w/ this
 
Old 08-02-2004, 07:32 PM   #23
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
What's the news on this, did that page help at all?
 
Old 08-02-2004, 07:36 PM   #24
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Actually I am about to read it....I read part of the link at work today, but I am about to try it...

Thanks
 
Old 08-02-2004, 07:41 PM   #25
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
If it isn't a problem between the ssh2 and ssh1 protocol, then I'll have to look into that some more. Problem is that I'm in the middle of working on a new installation, so I don't have much time.
 
Old 08-02-2004, 09:14 PM   #26
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
Have not tried this yet...

could be an incompatibility issue as mentioned. I am going to get the latest OpenSSH for my windows box.

I need to verify which version of ssh I have on my Linux box. Don;t know how to do this quite yet...

I thought there was an rpm command something like

"rpm -a ssh" which should tell me which rpm I have
 
Old 08-02-2004, 10:21 PM   #27
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
"File transfer could not be started or exited unexpectedly. sftp-server is not in the path on the server side"


In reference to the statement above from Openssh, it seems like that sftp-server IS NOT in the path when I log in as myself so

since /usr/local/bin is in the path (.bash_profile) then I copied the file sftp-server to /usr/local/bin/

Still did not work...the same error occurred!

Thanks for all the help again
 
Old 08-02-2004, 10:58 PM   #28
lyar1031
Member
 
Registered: Jul 2004
Posts: 54

Original Poster
Rep: Reputation: 15
put "/usr/libexec/openssh/ in the path...None worked still the same error

However, look at this link:

http://www.linuxquestions.org/questi...highlight=sftp

it is the same problem that I have. Furthermore in the link that "statmobile" sent http://www.snailbook.com/faq/

the same problem is mentioned in the section that talks about "received message too long"

The article states that server puts some text in the login script. However, I do not know how to modify the login script to eliminate this problem

Thanks
 
Old 08-02-2004, 11:08 PM   #29
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally posted by lyar1031
I need to verify which version of ssh I have on my Linux box. Don;t know how to do this quite yet...
I thought there was an rpm command something like
"rpm -a ssh" which should tell me which rpm I have
-qa will list every package,then just grep for ssh.

rpm -qa | grep ssh
 
Old 08-09-2004, 07:20 PM   #30
statmobile
Member
 
Registered: Aug 2003
Location: Chapel Hill, NC
Distribution: Gentoo, Windows 95 2000 & XP
Posts: 160

Rep: Reputation: 30
Hey lyar, any I just read your post. For some reason I was unsubscribed from the discussion. Have you gotten it up and working yet?

I just came accross something on the net, and I wanted to relay it to you. It looks like the post you just referred to is discussing the problem as well:
http://www.openssh.org/faq.html#2.9

as for figuring out which protocol your server is running, I believe you can find it in the
/etc/ssh/sshd_config
file. Maybe it will say here whether or not you block the SSH1 protocol.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 03:50 AM
[SSH] Issue logging in [SSH & Permissions] MD3 Linux - Networking 11 12-10-2006 10:25 AM
Mac OS X ssh client / linux sshd : ssh hangs/disconnects Apollo77 Linux - Networking 1 05-24-2006 12:53 PM
I turned off SSH, but I cant get it back! How do you start SSH on boot? nmoog Slackware 2 02-08-2004 06:18 PM
ssh issue: /usr/bin/ssh -x -oFallBackToRsh no -l WeNdeL Linux - Software 1 03-04-2003 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration