LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2013, 06:12 AM   #1
fwaheed1979
LQ Newbie
 
Registered: Feb 2013
Posts: 10
Blog Entries: 1

Rep: Reputation: Disabled
squid service not starting


service squid start
Starting squid: .................... [FAILED]


Feb 25 16:11:19 localhost squid[3773]: Squid Parent: child process 3789 exited with status 1
Feb 25 16:11:22 localhost squid[3773]: Squid Parent: child process 3795 started
Feb 25 16:11:23 localhost (squid): #011Failed to verify one of the swap directories, Check cache.log#012#011for details. Run 'squid -z' to create swap directories#012#011if needed, or if running Squid for the first time.
Feb 25 16:11:23 localhost kernel: type=1400 audit(1361790683.301:11760): avc: denied { getattr } for pid=3795 comm="squid" path="/cache" dev=sda2 ino=2 scontext=unconfined_u:system_r:squid_t:s0 tcontext=system_ubject_r:etc_runtime_t:s0 tclass=dir
Feb 25 16:11:23 localhost squid[3773]: Squid Parent: child process 3795 exited with status 1
Feb 25 16:11:26 localhost squid[3773]: Squid Parent: child process 3802 started
Feb 25 16:11:26 localhost (squid): #011Failed to verify one of the swap directories, Check cache.log#012#011for details. Run 'squid -z' to create swap directories#012#011if needed, or if running Squid for the first time.
Feb 25 16:11:26 localhost kernel: type=1400 audit(1361790686.632:11761): avc: denied { getattr } for pid=3802 comm="squid" path="/cache" dev=sda2 ino=2 scontext=unconfined_u:system_r:squid_t:s0 tcontext=system_ubject_r:etc_runtime_t:s0 tclass=dir
Feb 25 16:11:26 localhost squid[3773]: Squid Parent: child process 3802 exited with status 1
Feb 25 16:11:26 localhost squid[3773]: Exiting due to repeated, frequent failures

help me
 
Old 02-25-2013, 06:30 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
You don't acknowledge those error messages at all... did you even search for them? You'd have quite possibly ended up here if you had... http://www.linuxquestions.org/questi...roblem-762265/

A please / thank you would be recommended next time too btw.
 
Old 02-25-2013, 06:32 AM   #3
fwaheed1979
LQ Newbie
 
Registered: Feb 2013
Posts: 10
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
service squid start
Starting squid: .................... [FAILED]


Feb 25 16:11:19 localhost squid[3773]: Squid Parent: child process 3789 exited with status 1
Feb 25 16:11:22 localhost squid[3773]: Squid Parent: child process 3795 started
Feb 25 16:11:23 localhost (squid): #011Failed to verify one of the swap directories, Check cache.log#012#011for details. Run 'squid -z' to create swap directories#012#011if needed, or if running Squid for the first time.
Feb 25 16:11:23 localhost kernel: type=1400 audit(1361790683.301:11760): avc: denied { getattr } for pid=3795 comm="squid" path="/cache" dev=sda2 ino=2 scontext=unconfined_u:system_r:squid_t:s0 tcontext=system_ubject_r:etc_runtime_t:s0 tclass=dir
Feb 25 16:11:23 localhost squid[3773]: Squid Parent: child process 3795 exited with status 1
Feb 25 16:11:26 localhost squid[3773]: Squid Parent: child process 3802 started
Feb 25 16:11:26 localhost (squid): #011Failed to verify one of the swap directories, Check cache.log#012#011for details. Run 'squid -z' to create swap directories#012#011if needed, or if running Squid for the first time.
Feb 25 16:11:26 localhost kernel: type=1400 audit(1361790686.632:11761): avc: denied { getattr } for pid=3802 comm="squid" path="/cache" dev=sda2 ino=2 scontext=unconfined_u:system_r:squid_t:s0 tcontext=system_ubject_r:etc_runtime_t:s0 tclass=dir
Feb 25 16:11:26 localhost squid[3773]: Squid Parent: child process 3802 exited with status 1
Feb 25 16:11:26 localhost squid[3773]: Exiting due to repeated, frequent failures
 
Old 02-25-2013, 06:38 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
why did you post that?
 
Old 02-25-2013, 06:42 AM   #5
fwaheed1979
LQ Newbie
 
Registered: Feb 2013
Posts: 10
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by acid_kewpie View Post
why did you post that?
every time i am going to start squid service but it shows fail can you help me?
 
Old 02-25-2013, 06:55 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
I already have. Please actually read the responses you get.
 
1 members found this post helpful.
Old 02-25-2013, 09:00 AM   #7
sangfroid
LQ Newbie
 
Registered: Mar 2012
Posts: 10

Rep: Reputation: Disabled
Your SeLinux is screwing up here... If you disable it, then it will be all ok.

See http://www.crypt.gen.nz/selinux/disable_selinux.html for how to disable it.
 
Old 02-25-2013, 09:58 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,317

Rep: Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470
Quote:
Originally Posted by fwaheed1979 View Post
every time i am going to start squid service but it shows fail can you help me?
Well, the system tried to help you. Did you actually READ what you posted??? Did you not post this?
Quote:
Originally Posted by fwaheed1979
Feb 25 16:11:23 localhost (squid): #011Failed to verify one of the swap directories, Check cache.log#012#011for details. Run 'squid -z' to create swap directories#012#011if needed, or if running Squid for the first time.
See the part that's bolded?? Where the system TELLS YOU what command to run? Did you RUN IT? Have you tried "restart" instead of "start"?
 
Old 02-25-2013, 11:15 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by TB0ne View Post
Well, the system tried to help you. Did you actually READ what you posted??? Did you not post this?

See the part that's bolded?? Where the system TELLS YOU what command to run? Did you RUN IT? Have you tried "restart" instead of "start"?
Nrrg, well ... it doesn't actually. It's SELinux.
 
Old 02-25-2013, 11:42 AM   #10
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,317

Rep: Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470
Quote:
Originally Posted by acid_kewpie View Post
Nrrg, well ... it doesn't actually. It's SELinux.
Perhaps, but it could also be the directory is missing (the -z creates it), or a permissions issue. Running with the "-z" as suggested will either fix it, or give output indicating a permissions issue.

But the OP never indicates what version/distro of Linux, whether SElinux is enabled or not, any sort of permissions, or whether squid was ever working or if this is a new installation. Hard to say.
 
Old 02-25-2013, 02:14 PM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by TB0ne View Post
Perhaps, but it could also be the directory is missing (the -z creates it), or a permissions issue. Running with the "-z" as suggested will either fix it, or give output indicating a permissions issue.

But the OP never indicates what version/distro of Linux, whether SElinux is enabled or not, any sort of permissions, or whether squid was ever working or if this is a new installation. Hard to say.
Ahh come on now... did you even read the error message? There's a Violation right there! It's *very* easy to say
 
Old 02-25-2013, 11:23 PM   #12
fwaheed1979
LQ Newbie
 
Registered: Feb 2013
Posts: 10
Blog Entries: 1

Original Poster
Rep: Reputation: Disabled
well i already disable SELINUX but result is same and also try restart
and im fresh 1st time using linux version fedora12
 
Old 02-26-2013, 03:14 AM   #13
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
No, that's not true, the result can NOT be the same if you've disabled it. That's impossible.

And... Fedora 12????? That went out of support ages ago. do NOT use it under and circumstances. If this is a preopr server then use CentOS 6

once again, how about a please / thank you??
 
Old 02-26-2013, 10:38 AM   #14
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,317

Rep: Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470Reputation: 4470
Quote:
Originally Posted by fwaheed1979 View Post
well i already disable SELINUX but result is same and also try restart
and im fresh 1st time using linux version fedora12
AGAIN...have you tried running the command that the system told you to run????
 
Old 02-26-2013, 11:26 PM   #15
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: centos
Posts: 178

Rep: Reputation: 13
I once encounter similar situation with fc17 , its not necessary to disable SELINUX
its definitely a permission issue ... check to make sure the swap directories are owned by squid user
(chown squid:squid /var/spool/squid)...!!googd luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid service starting problem katariya.subhash Linux - Newbie 3 07-02-2010 02:59 AM
installing squid : service squid start --> error jonaskellens Linux - Software 2 09-05-2008 04:06 AM
starting squid service failed on redhat9 timdog28 Linux - Server 7 02-25-2007 05:00 PM
I can't "service squid start" , and chkconfig squid on not working Niceman2005 Linux - Software 0 11-10-2004 09:18 PM
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 07:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration