LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   specifying e2fsck path for linux-utils (https://www.linuxquestions.org/questions/linux-newbie-8/specifying-e2fsck-path-for-linux-utils-948823/)

Eerie 06-06-2012 10:49 AM

specifying e2fsck path for linux-utils
 
hey
after crashing my slackware 13.37 system i cant logon as fsck looks for /sbin/e2fsck on the wrong partition.

could someone kindly tell me where to specify the path?

Didier Spaier 06-06-2012 11:38 AM

I don't know.

But e2fsck as well as cfdisk and fdisk are available on the Slackware installation media, with their respective manuals.

Just boot it, change you keyboard layout if needed, login as root (just hit enter) and you can rescue your system. For instance you can use aforementioned apps and mount Slackware-1337's partitions. e.g.:
Code:

mkdir /slackware-13.37
mount -t auto /dev/sda1 /slackware-13.37

replace /dev/sda1 by the device name of your slackware-13.37 root partition.

EDIT Or boot directly your system from the install media as indicated on the greeting screen. Chances are that e2fsck will run automatically then.

Eerie 06-06-2012 11:53 AM

thanks but thats what ive been doing already using
hugesmp.s root=/dev/sda1 rdinit= ro

Didier Spaier 06-06-2012 11:55 AM

Did you try to run e2fsck on /dev/sda1 from the install media as well?

Eerie 06-06-2012 12:12 PM

i just did it but the problem remains "/sbin/e2fsck: no such file or directory on sdd1"

you see, it's quoting the wrong drive. of course theres no e2fsck on any partition other than root.

let me clarify also:
e2fsck runs but when i start my systen it gives me the error that it cant be found (as its looking on the wrong drive)

Eerie 06-06-2012 12:49 PM

ok i solved this by adjusting the path of / in /etc/fstab

Didier Spaier 06-06-2012 12:56 PM

Good. Having read "man fsck" which says :
Code:

If  no  filesystems are specified on the command line, and the -A option is not specified, fsck will default to
      checking filesystems in /etc/fstab serially.

I wanted to advise you to check /etc/fstab.

Too late, again ;)


All times are GMT -5. The time now is 04:38 AM.