LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-22-2017, 11:37 AM   #1
mindsc4pe
LQ Newbie
 
Registered: Dec 2014
Posts: 4

Rep: Reputation: Disabled
Specific Software trying to use Lib SSL 0.9.8


I am trying to run this software on my Ubuntu 16 Shell and this is the error I keep running into.

error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

I followed instructions on this page. https://tinyurl.com/y8owldef

I am getting an error installing the libssl

https://tinyurl.com/y8owldef

"Preparing to unpack libssl0.9.8_amd64.deb ...
Unpacking libssl0.9.8-dbg:amd64 (0.9.8o-7ubuntu3.2.14.04.1) over (0.9.8o-7ubuntu3.2.14.04.1) ...
dpkg: dependency problems prevent configuration of libssl0.9.8-dbg:amd64:
libssl0.9.8-dbg:amd64 depends on libssl0.9.8 (= 0.9.8o-7ubuntu3.2.14.04.1); however:
Version of libssl0.9.8:amd64 on system is 0.9.8o-7ubuntu4.

dpkg: error processing package libssl0.9.8-dbg:amd64 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libssl0.9.8-dbg:amd64"
 
Old 06-23-2017, 04:19 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,918

Rep: Reputation: 176Reputation: 176
Time to find a newer version of the software you are trying to install that requires you to compromise the security of your system to use it by installing a vulnerable system library.
 
Old 06-25-2017, 04:14 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
Are you sure you copied the output correctly. First is says preparing...lissl, then it says unpacking libssl-dbg. Those are two different packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How make a type specific LIB and ELF usef62 Programming 3 07-29-2014 11:29 PM
Unable to load config info from /usr/lib/ssl/openssl.cnf namit Linux - Security 2 09-08-2007 06:07 PM
Apache using SSL on specific directory only ? hendrixx Linux - Security 6 05-04-2006 01:00 PM
apache: ssl only for specific pages wwnexc Linux - Software 2 11-23-2005 08:29 PM
Apache + SSL + Upgrading OpenSSL shared lib TruckStuff Linux - Security 2 07-06-2005 05:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration