Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-14-2011, 03:12 AM   #1
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Speakers work, headphones don't

Hi All;

Also posted on openSUSE forum. Hope this is the correct subforum. As the title says, I get sound from my speakers but not from my headphones. All mixer settings are at 100% and the speakers are muted when the headphones are plugged in.

root@laptop= /home/tom # lspci
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

root@laptop= /home/tom # uname -a
Linux laptop #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux
root@laptop= /home/tom # rpm -qa "*alsa*"

root@laptop= /home/tom # rpm -qa "*pulse*"

root@laptop= /home/tom # rpm -q libasound2

root@laptop= /home/tom # cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-hda-intel
# u1Nb.Nz15uUWYSoD:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

links to sound configuration

Dell Studio 1745 laptop

Thanks for any replies, Tom
Old 01-14-2011, 08:33 PM   #2
Registered: Aug 2010
Location: Idaho
Distribution: Arch, Ubuntu, Fedora
Posts: 114
Blog Entries: 2

Rep: Reputation: 10
Do the headphones work elsewhere? mp3 player, other computer, etc
Do you get any sound through the headphones by moving the connection in/out/side-to-side?
where are you plugging the headphones into? the speakers themselves or the MOBO/case?
1 members found this post helpful.
Old 01-14-2011, 09:32 PM   #3
Senior Member
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,528
Blog Entries: 3

Rep: Reputation: 440Reputation: 440Reputation: 440Reputation: 440Reputation: 440
in your mixer make sure they are enabled if you want speakers and head phones at the same time also set up your sound mixer for that. Now if you never did this and it is from the original install. you should go delete your /etc/asound.state file and reboot this will actually make alsa and the system load that hda card. and re-write the /etc/asound.state file.
when you install the system it has a default guess method. and that card has caused troubles during installs. Now you will see a few more things in your mixer. especially if you have a laptop.
then open your alsa mixer make sure it is enabled and then check pulse. pulse just reads alsa. this has been my fix on many of the computers. and it is well documented.

Last edited by Drakeo; 01-14-2011 at 09:34 PM.
1 members found this post helpful.
Old 01-20-2011, 01:47 AM   #4
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Original Poster
Rep: Reputation: 34
Thanks for the replies. I know the headphones work after plugging them into my wifes' desktop. Also checked the mixer and alsa settings and nothing set to mute and all full volume.

I only noticed this behaviour recently as previously I used my laptop mostly in afternoon and early evening and used the internal speakers. Now I'm reverting to working late at night when the wife is sleeping so tried to use the headphones.

A couple of people on the openSUSE forum said to use the script to obtain information about sound system. Trouble is that alsa did not install that script during installation and haven't been able to find where to get it. Any ideas?

Sometime later this week I'll be installing some other distro and will test it on that.

Thanks, Tom


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
plugging in headphones or speakers doesn't disable my laptop's built in speakers moljac024 Linux - Software 14 07-13-2017 08:01 AM
No audio from internal speakers but headphones work matt1123 Linux - Hardware 5 10-17-2010 02:38 PM
Headphones Don't Override Speakers tsunamikitsune Ubuntu 1 04-11-2007 10:35 PM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 08:55 AM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 01:48 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration