LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sound recording software can't pick up voice speak through internal microphone (https://www.linuxquestions.org/questions/linux-newbie-8/sound-recording-software-cant-pick-up-voice-speak-through-internal-microphone-4175653939/)

raymond0517 05-15-2019 06:49 AM

sound recording software can't pick up voice speak through internal microphone
 
2 Attachment(s)
I am using UBUNTU 18.04.2 LTS

I tried using either arecord or audio-recorder software to record voice either through internal built-in mic or with an external mic plugged into the mic jack on my laptop,

however, I failed to record any voice.
when I play the audio file created using VLC media player, I heard no voice, complete quietness.

I did the following diagnostic to try to resolve issue, but to no avail.

1)

alsamixer program gives the output as shown in the attached file "alsamixer output display.png"

2)

In pavucontrol program,
menu item "configuration" shows "Built-in Audio", profile "Analog Stereo Duplex"

menu item "Input Devices" display the output as in the attachment file "pavucontrol menu item Input devices display content.png"

Please note the last bar is a fluctuating bar, shrinking and expanding as I speak to the internal microphone.

This indicates that the software pavucontrol can pick up sound received through internal mic.


---------

However, the arecord and audio-recorder program fail to record my voice through the internal mic, despite pavucontrol shows that sound being picked up by the software.

Can someone help ?

Thanks

Raymond

fatmac 05-15-2019 10:34 AM

Maybe take a look at audacity, I use it for recording, using a USB mic, but it should be fine with a built-in, or 3.5mm(?) audio jack mic too.

https://www.audacityteam.org/

raymond0517 05-15-2019 05:09 PM

I tried using audacity,
it still record no voice,
the pavucontrol program, under the Input devices tab,
it is using : Built-in Audio analog stereo
Port : internal microphone,

and a changing volume bar increase or decrease as I speak to the mic.

If the hardware is at fault, it should not reflect the sensing of different loudness of sound waves,

Really not sure what went wrong.

Yesterday, I kept trying with different option in pavucontrol,

somehow for some settings I have set (which I don't remember how), suddenly the voice recording is successful, in arecord or audio-recorder program,
but subsequent recording again result in complete silence.

Not sure what is wrong ?

raymond0517 05-15-2019 05:49 PM

I tried to recall what I did yesterday,
and this is what I did few minutes ago, not understand why, but it works now.

I changed the setting of configuration tab for Built-in Audio to "Analog Stereo Input" profile instead of "Analog Stereo Duplex".

Then I use arecord to try to record a voice recording.

As this profile doesn't support Analog Stereo output,
I change the profile back to "Analog Stereo Duplex"

And this time aplay manage to play the voice recording.

Strangely, leaving the profile as "Analog Stereo Duplex",
I tried to record voice again using arecord,
and it works,

not sure why toggle from Duplex to Input then back to Duplex profile solve the problem.

Anyway it works now. Thanks.


All times are GMT -5. The time now is 05:20 PM.