-   Linux - Newbie (
-   -   sound problem (

anz 01-26-2005 10:57 PM

sound problem
I was playing xine, xmms, mplayer with complete satisfaction in Fedora Core 2. For some unknown reasons suddenly i there is no sound from my comp. I checked the cables and also tried the following thing..
rm -f /etc/sysconfig/hwconf
rm -f /etc/modprobe.conf
service kudzu restart

then the soundcard is autodetected... but still no sound.. the mixer settings r ok...
what can be the problem?

adz 01-27-2005 04:56 AM

Is there another OS on that computer on which you can test the sound?

walker 01-27-2005 08:17 AM

It's always possibile try on the same machine if sounds work with a bootable like knoppix.
Than if it works looking at which module knoppix use i.e. snd_via82xxx or whatsoever then let fedore use that module instead that ones used by default.

anz 01-28-2005 09:11 AM

sound available on other OS
the sound is compleatly ok on other OS.. i tried Yoper GNU/Linux..
There was no problem with Fedora also.. but it happened suddenly..

is there a was to find out if any program is blocking my soundcard.. cuz once i got such an error from xmms.. though no other sound program was running..

please suggest a way to attack this problem.

walker 01-28-2005 11:14 AM

Hi anz,
let me understand.
What do you mean with first sound was working and suddenly....

Every program (xmms,xine,mplayer) was working first??

And now no one of the above programs works anymore??

Or only xmms stop working as I can understand from your last post??

If sound doesn't work with any of the progams mentioned and you haven't installed nothing new (i.e. upgraded kde,kernel or whatsoever) maybe it's your system that for unknown reasons doesn't load the correct sound module for your card.

Don't ask me why,but try the things I've suggested in the post before.

Boot with a live cd don't touch your hard disk.You should try now if it works!

If with a bootable like knoppix that has maybe the better hardware recognition tool sound won't play it's an hardware problem. (i.e. if you have a separeted sound board it could be broken, in the same way something could be broken in the integrated audio chip if you've got on board audio).

If it works with a bootable How I have said in the post before open "K menu | System | Info Center " to detect which sound module is in use by live cd copy the name of the module on a sheet than reboot the system on your hard disk and using the sound card configuration wizard choose as default the driver (module) you've written on the sheet.

If only xmms is not working (i.e. try to play an .mp3 file if the status bar in xmms goes ahead but you couldn't hear sound) first check xmms imput plug-in "right click on xmms window | Options | Preferences | Audio I/O Plugins" maybe someone is disabled or always if only xmms doesn't work try with right click on "K menu | Menu Editor | Multimedia | Xmms " and read what's written in the line "Command" if it's like this "soundwrapper xmms" erase soundwrapper (if this is the case this start command is the trouble) and leave only "xmms %U".

If you're looking for someone with a magic wand as maybe appears by your latest post be aware.

We are only people like you maybe with a little bit knowledge more than you but not wizards!

We can only suggest you some way to solve your problem but you have to find which is the right way to solve it!

We are trying to help you but you should help yourself no one, I think, have the right solution for you simply because we can't sit at your pc.

You have said that xmms gives you an error but you don't post it!

How can we help you??
I've tried with this post but as I said you should find by yourself the solution following our suggestions.

There's no other way!!

adz 01-28-2005 04:44 PM

Can you post the output of lsmod and lspci?

webboss 01-29-2005 12:05 AM

try this
try sndconfig on the command prompt to configure socund card.

try installing newer version of xmms.

try playing mpg321 <mp3 file> on command prompt itself.

Good luck,

anz 01-29-2005 02:51 AM

Module Size Used by
snd_mixer_oss 13824 2
snd_cmipci 27444 3
snd_pcm 68872 1 snd_cmipci
snd_page_alloc 7940 1 snd_pcm
snd_opl3_lib 7424 1 snd_cmipci
snd_timer 17156 2 snd_pcm,snd_opl3_lib
snd_hwdep 6276 1 snd_opl3_lib
gameport 3328 1 snd_cmipci
snd_mpu401_uart 4864 1 snd_cmipci
snd_rawmidi 17184 1 snd_mpu401_uart
snd_seq_device 6152 2 snd_opl3_lib,snd_rawmidi
snd 38372 11 snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_se q_device
soundcore 6112 3 snd
autofs4 10624 0
8139too 17792 0
mii 3584 1 8139too
floppy 47440 0
sg 27552 0
scsi_mod 91344 1 sg
microcode 4768 0
reiserfs 187604 1
nls_utf8 1536 3
nls_cp437 5376 3
vfat 10496 3
fat 33472 1 vfat
dm_mod 33184 0
uhci_hcd 23708 0
button 4504 0
battery 6924 0
asus_acpi 8472 0
ac 3340 0
ipv6 184288 6
ext3 102376 1
jbd 40216 1 ext3

00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host Bridge (MCH) (rev 02)
00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 04)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 04)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 04)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 04)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 04)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
02:0a.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

anz 01-29-2005 03:08 AM

walker, thanx a lot... i think i was a little confusing.. and trust me.. i really try to do whatever possible to solve problems... not only mine but i help others also if possible.. but this time i am perplexed... everytime the C-Media CM8738 driver is used for my soundcard.. so i dont think really rthat there is a better driver.. but i will follow what u have said.. and i am short of words in thanking you.. because u r the ones who really spend ur valuable time so that others can live happily... thanx again. :)

everything were working properly.. and nothing is working now. there is no sound from my PC.. not a mp problem or something like that.. i will try the knoppix thing.. but i have to get a copy of that.. meanwhile i tried Yoper Linux instead of knoppix. yoper produced sound with no problem. So the soundcard is okay..

i forgot the error from xmms... but its not that only xmms is not working...
it said some program may be blocking my soundcard.. but i remember that.. at that time i was not running any other application that could produce sound. So i thought that if i can find out if any program is blocking my soundcard.. and that program is getting loaded always.. then i could solve the problem.. but i dont know how to find if a program is blocking my soundcard.

but i can see that the kernel modules are there.. :(
may be i will have to reinstall the whole system (oh no!)..
may be i did something which caused this .. but i am not sure what i did..

adz 01-29-2005 04:12 AM

You didn't happen to install/run any KDE/GNOME based programs did you? Could you post the output of ps -A (verifying beforehand that the sound still doesn't work)?

Also, what audio output plugins/drivers are you using in XMMS, Mplayer etc? By this I'm asking are you using OSS output, ALSA, or some sort of sound server.

anz 01-29-2005 07:14 PM

1 ? 00:00:04 init
2 ? 00:00:00 ksoftirqd/0
3 ? 00:00:00 events/0
4 ? 00:00:00 kblockd/0
6 ? 00:00:00 khelper
5 ? 00:00:00 khubd
7 ? 00:00:00 pdflush
8 ? 00:00:00 pdflush
10 ? 00:00:00 aio/0
9 ? 00:00:00 kswapd0
120 ? 00:00:00 kseriod
159 ? 00:00:00 kjournald
1055 ? 00:00:00 reiserfs/0
1458 ? 00:00:00 syslogd
1462 ? 00:00:00 klogd
1483 ? 00:00:00 portmap
1571 ? 00:00:00 acpid
1593 ? 00:00:00 vsftpd
1603 ? 00:00:00 gpm
1614 ? 00:00:00 crond
1637 ? 00:00:00 xfs
1647 ? 00:00:00 anacron
1656 ? 00:00:00 atd
1675 ? 00:00:00 dbus-daemon-1
1686 ? 00:00:00 rhnsd
1699 ? 00:00:00 mdadm
1710 tty1 00:00:00 mingetty
1711 tty2 00:00:00 mingetty
1717 tty3 00:00:00 mingetty
1723 tty4 00:00:00 mingetty
1737 tty5 00:00:00 mingetty
1743 tty6 00:00:00 mingetty
1744 ? 00:00:00 gdm-binary
1937 ? 00:00:00 gdm-binary
1948 ? 00:00:10 X
1978 ? 00:00:00 gnome-session
2030 ? 00:00:00 ssh-agent
2034 ? 00:00:02 gconfd-2
2037 ? 00:00:00 gnome-keyring-d
2039 ? 00:00:00 bonobo-activati
2041 ? 00:00:00 metacity
2043 ? 00:00:00 gnome-settings-
2113 ? 00:00:00 xscreensaver
2137 ? 00:00:01 gnome-panel
2139 ? 00:00:01 nautilus
2141 ? 00:00:00 magicdev
2143 ? 00:00:00 eggcups
2145 ? 00:00:00 pam-panel-icon
2147 ? 00:00:02 rhn-applet-gui
2148 ? 00:00:00 pam_timestamp_c
2151 ? 00:00:00 gnome-vfs-daemo
2184 ? 00:00:00 mapping-daemon
2186 ? 00:00:00 wnck-applet
2188 ? 00:00:00 clock-applet
2190 ? 00:00:00 mixer_applet2
2199 ? 00:00:00 notification-ar
2201 ? 00:00:00 drivemount_appl
2226 ? 00:00:00 crclient
2229 ? 00:00:00 firefox
2240 ? 00:00:00
2245 ? 00:00:06 firefox-bin
2315 ? 00:00:01 gnome-terminal
2318 ? 00:00:00 gnome-pty-helpe
2319 pts/2 00:00:00 bash
2344 pts/2 00:00:00 ps

And yes sound still does not work... i did install some GNOME/KDE based applications.. they were running smoothely too.. like Kafeeine, Gxine.

gstreamer-properties say im using ALSA, also OSS is available.. when i click on the test sound button.. no sound is generated.. though when the situations were normal.. i could hear a long beep.

proxyghost 01-29-2005 07:25 PM

This may sound stupid but I missed this 3 times before I found it.

I had a similar issue earlier today when I updated gstreamer. Something caused the option Analog / Digital Output Jack to be checked on mute in Volume Control. i unmuted this and everything was back to normal. This was at the end of a very long list of options in Volume Control.

I hope this is of help. Though it is probably not.

anz 01-31-2005 09:25 AM

mixer settings are ok..
none is muted!
And i tried this in single user mode
#mplayer file.mp3
could not hear any sound..
does this have anything to do??

adz 02-01-2005 02:50 AM

Could you post the output of mplayer when you do this?

anz 02-08-2005 01:39 AM

got it.. thanx all..
hey.. i fixed the sound problem.. amazing isnt it? lolz!
well my modprobe.conf reads like this now .. and it solved the problem

alias eth0 8139too
alias usb-controller uhci-hcd
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias snd-card-0 snd-cmipci
alias sound-slot-0 snd-cmipci
# --- END: Generated by ALSACONF, do not edit. ---

the sound-slot-0 line was missing previously.. thanx for all ur supprt!

PS: so is it that kudzu did not detect the 'sount-slot 0' thing...
is it a bug of some kind?? i copied the line from yoper distributoin of GNU/Linux

All times are GMT -5. The time now is 02:45 PM.