LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2004, 08:00 PM   #1
blackgenesis
LQ Newbie
 
Registered: Dec 2004
Distribution: slackware
Posts: 4

Rep: Reputation: 0
Question sound not working under slackware install


Hi, I've just installed slackware 10. I haven't been able to get the sound to work, and I know practically NOTHING about linux. I don't know where to start. Here is some things I think may be useful:

root@slackware:~# lspci -v
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
Flags: bus master, 66Mhz, fast devsel, latency 0
Memory at d0000000 (32-bit, prefetchable) [size=64M]
Capabilities: [40] AGP version 3.0
Capabilities: [60] #08 [2001]

00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
Subsystem: nVidia Corporation: Unknown device 0c17
Flags: 66Mhz, fast devsel

00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
Subsystem: nVidia Corporation: Unknown device 0c17
Flags: 66Mhz, fast devsel

00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
Subsystem: nVidia Corporation: Unknown device 0c17
Flags: 66Mhz, fast devsel

00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
Subsystem: nVidia Corporation: Unknown device 0c17
Flags: 66Mhz, fast devsel

00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
Subsystem: nVidia Corporation: Unknown device 0c17
Flags: 66Mhz, fast devsel

00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
Subsystem: Giga-byte Technology: Unknown device 0c11
Flags: bus master, 66Mhz, fast devsel, latency 0
Capabilities: [48] #08 [01e1]

00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
Subsystem: Giga-byte Technology: Unknown device 0c11
Flags: 66Mhz, fast devsel, IRQ 5
I/O ports at c000 [size=32]
Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology: Unknown device 5004
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
Memory at d8002000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
Subsystem: Giga-byte Technology: Unknown device 5004
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
Memory at d8003000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2

00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 20 [EHCI])
Subsystem: Giga-byte Technology: Unknown device 5004
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 9
Memory at d8004000 (32-bit, non-prefetchable) [size=256]
Capabilities: [44] #0a [2080]
Capabilities: [80] Power Management version 2

00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
Subsystem: Giga-byte Technology: Unknown device a002
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 5
I/O ports at b000 [size=256]
I/O ports at b400 [size=128]
Memory at d8000000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2

00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
I/O behind bridge: 00009000-00009fff
Memory behind bridge: d7000000-d7ffffff
Prefetchable memory behind bridge: d4000000-d4ffffff

00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2) (prog-if 8a [Master SecP PriP])
Subsystem: Giga-byte Technology: Unknown device 5002
Flags: bus master, 66Mhz, fast devsel, latency 0
I/O ports at f000 [size=16]
Capabilities: [44] Power Management version 2

00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 32
Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
I/O behind bridge: 0000a000-0000afff
Memory behind bridge: d5000000-d6ffffff
Prefetchable memory behind bridge: b0000000-cfffffff

01:08.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
Subsystem: LeadTek Research Inc. WinFast TV 2000
Flags: bus master, medium devsel, latency 32, IRQ 11
Memory at d4000000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2

01:08.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
Subsystem: LeadTek Research Inc.: Unknown device 6606
Flags: bus master, medium devsel, latency 32, IRQ 11
Memory at d4001000 (32-bit, prefetchable) [size=4K]
Capabilities: [44] Vital Product Data
Capabilities: [4c] Power Management version 2

01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Giga-byte Technology: Unknown device e000
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at 9000 [size=256]
Memory at d7000000 (32-bit, non-prefetchable) [size=256]

02:00.0 VGA compatible controller: ATI Technologies Inc RV350 AP [Radeon 9600] (prog-if 00 [VGA])
Subsystem: Unknown device 18bc:0190
Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 10
Memory at b0000000 (32-bit, prefetchable) [size=256M]
I/O ports at a000 [size=256]
Memory at d6000000 (32-bit, non-prefetchable) [size=64K]
Expansion ROM at <unassigned> [disabled] [size=128K]
Capabilities: [58] AGP version 3.0
Capabilities: [50] Power Management version 2

02:00.1 Display controller: ATI Technologies Inc RV350 AP [Radeon 9600] (Secondary)
Subsystem: Unknown device 18bc:0191
Flags: bus master, 66Mhz, medium devsel, latency 32
Memory at c0000000 (32-bit, prefetchable) [size=256M]
Memory at d6010000 (32-bit, non-prefetchable) [size=64K]
Capabilities: [50] Power Management version 2

knoppix doesn't get the sound working either. The brooktree devices are my TV tuner card. Please let me know if you need me to run some commands or whatever to give more details about this problem. My sound card is onboard nforce2 ac'97.
 
Old 12-21-2004, 08:23 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Which kernel are you using, did you download and
install the nForce drivers from the nVidia site?


Cheers,
Tink
 
Old 12-21-2004, 10:23 PM   #3
DeadPenguin
Member
 
Registered: Nov 2004
Location: Delaware
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
First off Welcome. It's nice to have another slacker around.

I will preface this with. I am still very new to linux.

Did you try alsaconf ?

This is the site I use to get my slack boxes up and running. (thanks Shilo)
http://shilo.is-a-geek.com/slack/

Good luck.
Blair
 
Old 01-04-2005, 06:58 AM   #4
blackgenesis
LQ Newbie
 
Registered: Dec 2004
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Hi, got caught up at work, hadn't been able to get on here. I now have two weeks off to get this thing going, amongst other things.

Kernel version is 2.4.26. I did manage to download drivers from nvidia's website and compile a driver module, which modprobe can't seem to find:

> root@slackware:~/nvdriver/nforce/nvaudio# cp nvaudio.o nvaudio.original
> root@slackware:~/nvdriver/nforce/nvaudio# gzip nvaudio.o
> root@slackware:~/nvdriver/nforce/nvaudio# modprove ./nvaudio
> -bash: modprove: command not found
> root@slackware:~/nvdriver/nforce/nvaudio# modprobe ./nvaudio
> modprobe: Can't locate module ./nvaudio
> root@slackware:~/nvdriver/nforce/nvaudio# ls
> Makefile _ _ _nvaudio.original _nvhw.c _nvioctl.h _nvrec.c _nvspdif.c
> nvwavout.c _tp*
> chaninfo.h _ _nvcrush.c _ _ _ _ nvhw.h _nvmain.c _ nvrec.h _nvspdif.h
> nvwavout.h _trpr.o
> nvaudio.o.gz _nvcrush.o _ _ _ _ nvhw.o _nvmain.o _ nvrec.o _nvspdif.o
> nvwavout.o
> root@slackware:~/nvdriver/nforce/nvaudio# modprobe ./nvaudio.o.gz
> modprobe: Can't locate module ./nvaudio.o.gz
> root@slackware:~/nvdriver/nforce/nvaudio#

Insmod however produces different results:

> root@slackware:~/nvdriver/nforce/nvaudio# insmod nvaudio.o
> nvaudio.o: unresolved symbol ac97_probe_codec
> nvaudio.o: unresolved symbol ac97_set_dac_rate
> nvaudio.o: unresolved symbol ac97_set_adc_rate

And alsamixer brings up some options for my brooktree TV tuner card:

Card: Brooktree Bt878 ?
? Chip: Bt87x ?
? Item: FM

Any ideas?
 
Old 01-05-2005, 12:56 AM   #5
blackgenesis
LQ Newbie
 
Registered: Dec 2004
Distribution: slackware
Posts: 4

Original Poster
Rep: Reputation: 0
Cool

don't worry about this - I solved it. Did a reinstallation of linux, after doing some extensive reading - and sound is now fine. cheers dudes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 Module snd-intel8x0, sound not working! naimslim89 Linux - Hardware 3 08-21-2005 03:13 AM
sound not working slackware blitzX Linux - Laptop and Netbook 10 04-25-2005 01:33 PM
Sound not working on a7n8x motherboard, slackware orbitalnerd Linux - Hardware 9 02-13-2004 12:53 PM
Sound not working in Slackware iqbala Linux - Newbie 6 01-06-2004 03:16 PM
Sound not working in Slackware 9.1 rsamurti Slackware - Installation 6 12-19-2003 07:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration