LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-23-2017, 01:11 PM   #1
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 617

Rep: Reputation: 34
Sound is not playing


Hi I have upgraded to Fedora 25 and my sound is not playing , below are some details

[root@noentry ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
[root@noentry ~]# lsmod | grep snd
snd_hda_codec_realtek 86016 1
snd_hda_codec_generic 73728 1 snd_hda_codec_realtek
snd_hda_intel 36864 7
snd_hda_codec 126976 3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core 81920 4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep 16384 1 snd_hda_codec
snd_seq 69632 0
snd_seq_device 16384 1 snd_seq
snd_pcm 118784 3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer 32768 2 snd_seq,snd_pcm
snd 86016 23 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_hda_codec_generic,snd_seq_device,snd_hda _codec_realtek,snd_pcm
soundcore 16384 1 snd
[root@noentry ~]# lspci -v | grep -A11 -i "audio"
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
Subsystem: Intel Corporation Device d606
Flags: bus master, fast devsel, latency 0, IRQ 29
Memory at 901c0000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [130] Root Complex Link
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

[root@noentry ~]#


Thanks and Best Regards
 
Old 02-23-2017, 01:20 PM   #2
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 617

Original Poster
Rep: Reputation: 34
I found below command in the web and I am not sure if this will help

[root@noentry ~]# wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh --upload
--2017-02-23 18:16:47-- http://www.alsa-project.org/alsa-info.sh
Resolving www.alsa-project.org (www.alsa-project.org)... 77.48.224.243
Connecting to www.alsa-project.org (www.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://git.alsa-project.org/?p=alsa-...o/alsa-info.sh [following]
--2017-02-23 18:16:48-- http://git.alsa-project.org/?p=alsa-...o/alsa-info.sh
Resolving git.alsa-project.org (git.alsa-project.org)... 77.48.224.243
Connecting to git.alsa-project.org (git.alsa-project.org)|77.48.224.243|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/x-sh]
Saving to: ‘alsa-info.sh’

alsa-info.sh [ <=> ] 28.03K 76.7KB/s in 0.4s

2017-02-23 18:16:49 (76.7 KB/s) - ‘alsa-info.sh’ saved [28707]

pcilib: sysfs_read_vpd: read failed: Input/output error
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=a8...209afb77a4733f

Please inform the person helping you.

[root@noentry ~]#

Last edited by procfs; 02-23-2017 at 01:23 PM.
 
Old 02-23-2017, 01:59 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,714

Rep: Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091
Quote:
Originally Posted by procfs View Post
Hi I have upgraded to Fedora 25 and my sound is not playing , below are some details
Code:
[root@noentry ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
You've been asked several times in the past to put CODE tags around such things when posting them. You were also warned several times to NOT LOG IN AS ROOT, but you appear to be doing that too. If you're not going to take advice from us, then why ask questions here????

While the aplay information is good, you omit anything from the log files, dmesg, or other sources, and don't even tell us what kind of hardware (laptop? desktop? external/internal speakers?) you're using. If it was working with another version of Fedora and now isn't, have you checked to see if it's muted?? You don't tell us what desktop environment you're in, but check the mixer/channels, and adjust things. How are you testing this?
 
Old 02-23-2017, 07:52 PM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,613
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
$ cat /proc/asound/cards

$ alsamixer -c 0

$ speaker-test -c 2 -l 1

$ groups

The user needs to be in the audio group.
The sound device needs to be un-muted (defaults to muted)
And you need to select which soundcard to use. Everything has a soundcard on it now, and device 0 is by default the default. Which could be your webcam and only has sound input.

$ pavucontrol

If using pulseaudio you can use that application to select your soundcard and adjust the mixer settings. Otherwise you might need a .asoundrc configuration file to change your default soundcard.
 
1 members found this post helpful.
Old 02-24-2017, 12:04 PM   #5
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 617

Original Poster
Rep: Reputation: 34
Hi Shadow_7, thanks for the reply please see below output

Code:
[root@noentry ~]# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x901c0000 irq 29


$ alsamixer -c 0 - a mixer comes up

$ groups
xxxx audio


$ speaker-test -c 2 -l 1

speaker-test 1.1.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.964049

But sound is not coming

This is an onboard sound card on a desktop!

Dmesg | grep audio out put as below

Code:
dmesg | grep audio
[    9.099921] snd_hda_codec_realtek hdaudioC0D2: ALC888: SKU not ready 0x411111f0
[    9.100293] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC888: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    9.100295] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    9.100297] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    9.100299] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[    9.100300] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[    9.100302] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x19
[    9.100304] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x18
[    9.100305] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
Thanks and Best Regards

Last edited by procfs; 02-24-2017 at 12:38 PM.
 
Old 02-24-2017, 12:50 PM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,714

Rep: Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091
Quote:
Originally Posted by procfs View Post
Hi Shadow_7, thanks for the reply please see below output

But sound is not coming This is an onboard sound card on a desktop!
Thank you so much for acknowledging the questions I asked too, procfs. So now that we know it's a desktop, you still haven't told us if you bothered to check to see if it was muted or not, as was suggested to you.

AGAIN: Have you checked the mixer to see if things were muted????
 
1 members found this post helpful.
Old 02-24-2017, 12:58 PM   #7
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Xubuntu
Posts: 5,112

Rep: Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706Reputation: 1706
Unless Fedora has changed a lot since I last saw it, if you use the default Gnome there should be a sound control applet in the menu (under System preferences, or something like that). That will enable you to set the preferred devices for output and input and to set the volume. If you don't have it, install pavucontrol and run that command in a terminal.
 
1 members found this post helpful.
Old 02-24-2017, 01:02 PM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,714

Rep: Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091
Quote:
Originally Posted by DavidMcCann View Post
Unless Fedora has changed a lot since I last saw it, if you use the default Gnome there should be a sound control applet in the menu (under System preferences, or something like that). That will enable you to set the preferred devices for output and input and to set the volume. If you don't have it, install pavucontrol and run that command in a terminal.
Yep...suggested that to the OP in post #3, the first reply. He apparently ignored that.
 
Old 02-24-2017, 01:26 PM   #9
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: CentOS at the time of this writing, but some others over the years too...
Posts: 2,027

Rep: Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924
Quote:
Originally Posted by procfs View Post
Hi Shadow_7, thanks for the reply please see below output

Code:
[root@noentry ~]# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x901c0000 irq 29


$ alsamixer -c 0 - a mixer comes up

$ groups
xxxx audio


$ speaker-test -c 2 -l 1

speaker-test 1.1.1

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 10.964049

But sound is not coming

This is an onboard sound card on a desktop!

Dmesg | grep audio out put as below

Code:
dmesg | grep audio
[    9.099921] snd_hda_codec_realtek hdaudioC0D2: ALC888: SKU not ready 0x411111f0
[    9.100293] snd_hda_codec_realtek hdaudioC0D2: autoconfig for ALC888: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[    9.100295] snd_hda_codec_realtek hdaudioC0D2:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    9.100297] snd_hda_codec_realtek hdaudioC0D2:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    9.100299] snd_hda_codec_realtek hdaudioC0D2:    mono: mono_out=0x0
[    9.100300] snd_hda_codec_realtek hdaudioC0D2:    inputs:
[    9.100302] snd_hda_codec_realtek hdaudioC0D2:      Front Mic=0x19
[    9.100304] snd_hda_codec_realtek hdaudioC0D2:      Rear Mic=0x18
[    9.100305] snd_hda_codec_realtek hdaudioC0D2:      Line=0x1a
Thanks and Best Regards
While I have to agree with TB0ne, in that your first step is to make sure the sound is not muted, the following line in your dmesg output, caught my eye;

Code:
[    9.099921] snd_hda_codec_realtek hdaudioC0D2: ALC888: SKU not ready 0x411111f0
A quick Google search of the above, turned up lot of similar results, with the same issues, being no sound.

Have you read any of them?

As from the little I have read of these results, it looks like there could be a clue there.
 
Old 02-24-2017, 01:35 PM   #10
rtmistler
Moderator
 
Registered: Mar 2011
Location: MA, USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 7,214
Blog Entries: 12

Rep: Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656
I agree with the thoughts to check the state of mute and other alsa settings. It has been a while for me with alsa. I formerly used amixer but cannot locate any of the scripts I used to ensure all resource were not on mute and also that all resource volume levels were "max" or "100", I think it was 100. I did a brief recheck of the amixer command and if you issue it with no arguments it tells you back the settings. The benefit of this is that it gives you the resources which you can then "set" controls for. The recommended controls would be "mute off" and "volume 100".
 
1 members found this post helpful.
Old 02-24-2017, 02:13 PM   #11
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 617

Original Poster
Rep: Reputation: 34
Thank you all for the replays, yes going through the google! why I posted this since I need a quick fix to go through some interview related videos!

All controls on alsamixer is at 100%, hope this means its not muted!

Best Regards

Last edited by procfs; 02-24-2017 at 02:20 PM.
 
Old 02-24-2017, 02:23 PM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,714

Rep: Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091Reputation: 5091
Quote:
Originally Posted by procfs View Post
Thank you all for the replays, yes going through the google! why I posted this since I need a quick fix to go through some interview related videos!
If you need a quick fix, it's probably best to actually answer the questions you were asked, instead of ignoring them until later. You still haven't said what desktop GUI you're using, but do you honestly not know, after eleven years...
Quote:
All controls on alsamixer is at 100%, hope this means its not muted!
...how to check to see if your sound is muted??? All that means is that the levels are at 100%. They can be all the way up AND muted. If you're not familiar with the GUI mixer (probably be something VERY obvious...like a speaker icon with a line through it), then run "alsamixer" from the command-line, press F5 for "All" and look for things with an "MM" at the bottom of the bar.
 
1 members found this post helpful.
Old 02-24-2017, 02:49 PM   #13
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: CentOS at the time of this writing, but some others over the years too...
Posts: 2,027

Rep: Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924Reputation: 924
Quote:
Originally Posted by procfs View Post
Thank you all for the replays, yes going through the google! why I posted this since I need a quick fix to go through some interview related videos!

All controls on alsamixer is at 100%, hope this means its not muted!

Best Regards
What does "going through the google!" mean?? Have you checked what TB0ne has asked?? As there is no way to help you until you provide the requested info.
 
Old 02-24-2017, 02:56 PM   #14
rtmistler
Moderator
 
Registered: Mar 2011
Location: MA, USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 7,214
Blog Entries: 12

Rep: Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656Reputation: 2656
Quote:
Originally Posted by procfs View Post
All controls on alsamixer is at 100%, hope this means its not muted!
It does not. It means the volume controls are at 100%. The mute property is a separate attribute setting.

As before, recommend you check the mute setting.

Also please let us know if sound ever worked on this system.

@jsbjsb001: "going through the google" I believe is their way of stating that they tried a web search using the Google search engine. It is also possible that this is a colloquialism and was meant to indicate that they performed a web search, regardless of whatever search engine they chose to use.

Last edited by rtmistler; 02-24-2017 at 02:58 PM.
 
1 members found this post helpful.
Old 02-24-2017, 02:57 PM   #15
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 617

Original Poster
Rep: Reputation: 34
I am sorry for the trouble, in my frustration was trying to go about doing everything than just simply following instructions. Surround was muted. thank you all for the help and understanding, it was my mistake!

Thanks you and best regards

Last edited by procfs; 02-24-2017 at 03:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
loud sound occurs when exiting pages or windows that have sound playing already zorb Fedora 1 11-27-2009 06:32 PM
lenny sound issue - sound skips when playing file muxman Debian 0 05-06-2009 07:29 PM
Microphone Working, Sound playing back, Sound Not Recording (Gentoo 2.6.29) kingzog Linux - Software 3 04-23-2009 10:09 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 04:23 PM
Sound outputing when mic is used, but no output when playing a sound file medo Linux - Hardware 0 04-17-2004 08:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration