-   Linux - Newbie (
-   -   Sound Heard in external headphones but not in internal speakers of laptop (

@skm3nt 08-20-2010 06:56 AM

Sound Heard in external headphones but not in internal speakers of laptop
Hello everyone, I am new to fedora 13.
My problem is that I can not hear any sound from my laptop's internal speakers (that works f9 in windows--so no h/w probs!) but when I connect external headphones, everything is heard!

I have tried several commands from various internet sources since past one week. I would like to list a few of them:

580 rpm -ivh

581 yum install vlc

583 yum install pavucontrol

584 /sbin/lspci

585 /sbin/lsusb

586 /sbin/dmesg

587 lspci | grep audio

592 rpm -Uvh adobe-release-i386-1.0-1.noarch.rpm

595 lspci | grep Audio

596 cat /proc/asound/card0/codec#* | grep Codec

597 yum --enablerepo=rawhide update alsa*

598 yum update alsa*

599 yum --enablerepo=rawhide update alsa*

600 wget ""

617 tar -xjf alsa-driver-1.0.9rc4a.tar.bz2

628 cd alsa-lib-1.0.9rc4

629 ./configure

630 make && make install

652 cp -r /home/Avantika/Downloads/alsa-lib-1.0.9rc4 /usr/src/alsa

654 cd alsa-driver-1.0.9rc4a

655 ./configure --with-cards=intel8x0 --with-sequencer=yes ; make ; make install

662 chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi

663 modinfo soundcore

664 yum list | grep alsa

665 yum install alsa*

667 yum install alsa-kernel

668 yum install bluez-utils-alsa-3.32-1.fc9.x86_64

669 yum install alsa-plugins-pulseaudio.i386 1.0.17-1.fc10

670 rpm -qf /lib/modules/

671 yum install pavucontrol

673 yum install xine-lib-extras-freeworld

674 yum install @sound-and-video

675 yum install phonon-backend-gstreamer

676 yum install gstreamer-plugins-ugly

679 yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

smod |grep snd

snd_hda_codec_intelhdmi 16015 1

snd_hda_codec_idt 53499 1

snd_hda_intel 24152 4

snd_hda_codec 73671 3 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel

snd_hwdep 6222 1 snd_hda_codec

snd_seq 50941 0

snd_seq_device 5895 1 snd_seq

snd_pcm 76131 3 snd_hda_intel,snd_hda_codec

snd_timer 19234 2 snd_seq,snd_pcm

snd 60573 16 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_devi ce,snd_pcm,snd_timer

soundcore 6198 1 snd

snd_page_alloc 7221 2 snd_hda_intel,snd_pcm

[root@localhost Avantika]# cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel

HDA Intel at 0x9c800000 irq 33

[root@localhost Avantika]# ps -ef |grep pulseaudio

Avantika 2122 1 1 Aug19 ? 00:03:51 /usr/bin/pulseaudio --start --log-target=syslog

root 10363 10298 0 05:01 pts/0 00:00:00 grep pulseaudio

[root@localhost Avantika]# cat /proc/asound/cards

0 [Intel ]: HDA-Intel - HDA Intel

HDA Intel at 0x9c800000 irq 33

[root@localhost Avantika]# ps -ef |grep pulseaudio

Avantika 2122 1 1 Aug19 ? 00:05:24 /usr/bin/pulseaudio --start --log-target=syslog

root 10805 10298 0 05:37 pts/0 00:00:00 grep pulseaudio

I don't understand many of the commands that I have run, but that has somehow helped me to run media files and hear sound on HEADPHONES....

I have checked and think nothing is muted (using instructions from forums....)

I will be very thankful if someone can help me solve this problem.....

spoovy 08-20-2010 04:21 PM

if it were me, i'd erase pulseaudio, as that always caused me weird problems in fedora. Try


su -c "yum erase pulseaudio"
Also I assume you have tried all the mixer option? Try running






or whatever relevant is installed, and fiddle with all the dials. you may have speakers on mute or something.

@skm3nt 08-20-2010 11:11 PM

I got a suggestion:

Have you tried to go to System -> Preferences -> Sound -> Output
Here you should see a menu named 'Connector:' Where you can choose your output, choose Analog Speakers for the sound to be played on your laptops internel speakers...

and that solved my problem!!

I would like to ask you whether pulse audio is a software(application) or driver kind of thing? Do vlc, rythembox music player, movie player and pulse audio are same category things and would be ok if I keep one of them?

I have one more problem as well if you would like to see if you could help me:

And thank you for showing interest in my problem :-)

spoovy 08-21-2010 04:02 AM

Pulseaudio is a sound server - it kind of sits between the sound software and the hardware, the idea being that you can have multiple sound sources (such as vlc, rhythmbox etc) playing at the same time, and control the volume of them all individually. Rather than the old way, which would be to mingle all the sound sources, and have one "master" control to control the volume out. The only GUI you will see for puleaudio would be a mixer settings GUI.

It's been notoriously troublesome though, and many many people think it just adds further complexity and problems. It's very common for people to remove it altogether. Linux audio is a nightmare in my opinion; it's too complicated by far.

Withg regard to your second problem. Try the following commands to give you some more information -


service -status-all

chkconfig -list

The following command will find the httpd config file, which you should review for any obvious errors (for example lack of a valid IP address and name for your webserver) -


rpm -qc httpd
Also make sure you have the following packages installed -


yum install httpd httpd-manual httpd-devel

EDIT - I notice that httpd is in /usr/sbin, so maybe it is only controllable as root? (the sbin dir is for root-only programs, it is not in a normal users $PATH). Try the following, as root user -


chkconfig httpd on

service httpd start

The service needs a valid IP address and name or will fail, so make sure you add a ServerName entry to the configuration file as well. Then restart the service.

@skm3nt 08-22-2010 05:47 AM

1 Attachment(s)
service -status-all --> unrecognized service
chkconfig -list --> list is unrecognized option

The packages you mentioned are already installed. I don't understand the contents of the conf file, I am attaching it here...

Status is still the same-->httpd dead but subsys locked

spoovy 08-23-2010 03:41 AM

Are you running those first commands as root? Try with a double hyphen ie


chkconfig --list
and check their man pages.

Have you checked that you have a valid IP address and server name?

@skm3nt 08-24-2010 12:58 AM

Where to check for a valid IP address and server name?

spoovy 08-25-2010 03:14 AM

Blimey mate i'm trying to help out here, but you gotta meet me halfway! Have you read up on how to use Apache?

@skm3nt 08-28-2010 07:26 PM

i'll do so asap n get back :)

All times are GMT -5. The time now is 10:30 PM.