LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sound card working;now not working (https://www.linuxquestions.org/questions/linux-newbie-8/sound-card-working%3Bnow-not-working-404462/)

spx2 01-17-2006 09:23 AM

sound card working;now not working
 
yesterday my soundcard worked perfectly
im using vector linux
i could listen to the radio just fine
now i booted and i find out that xmms
tells me something new

Couldnt open audio
Please check that:
Your soundcard is configured properly
You have the correct output plugin selected
No other program is blocking the soundcard

Now so that you guys dont think i didnt research
the problem just a little bit well i did
i got on irc on efnet i talked with some rookies
found out that lsof is a goot tool for finding
wich programs use wich devices
so i downloaded built this lsof thing
and made lsof /dev/dsp
lsof /dev/audio
i did not get anything
im starting to think this linux is a bad joke...sometimes
sometimes...it works normally...

spx2 01-17-2006 11:57 AM

sound card problem
 
xmms is saying that the soundcard is in use by something else
it was working perfectly yesterday
how can i fix this ?

spx2 01-17-2006 01:45 PM

i put some commands output maybe this might help

Code:

[root@vector/dev/snd]# aplay 
ALSA lib confmisc.c:560:(snd_determine_driver) could not open control for card 0
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load_for_all_cards returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM default definition (id: default, value: cards.pcm.default)
aplay: main:533: audio open error: Invalid argument
[root@vector/dev/snd]# aplay -l
**** List of PLAYBACK Hardware Devices ****
aplay: device_list:226: control open (0): No such file or directory
[root@vector/dev/snd]#



it may probably seem to you strange that i am posting
too many posts in so short time.
the fact is im just using linux there is nothing else
i am doing and i want some satisfaction from it.

spx2 01-17-2006 01:46 PM

i put some commands output maybe this might help

Code:

[root@vector/dev/snd]# aplay 
ALSA lib confmisc.c:560:(snd_determine_driver) could not open control for card 0
ALSA lib conf.c:2686:(snd_config_hooks_call) function snd_config_hook_load_for_all_cards returned error: No such file or directory
ALSA lib pcm.c:1959:(snd_pcm_open_conf) Invalid type for PCM default definition (id: default, value: cards.pcm.default)
aplay: main:533: audio open error: Invalid argument
[root@vector/dev/snd]# aplay -l
**** List of PLAYBACK Hardware Devices ****
aplay: device_list:226: control open (0): No such file or directory
[root@vector/dev/snd]#



it may probably seem to you strange that i am posting
too many posts in so short time.
the fact is im just using linux there is nothing else
i am doing and i want some satisfaction from it.

also these may be useful

Code:

[root@vector/]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.8.
Compiled on Jan 20 2005 for kernel 2.4.29.
[root@vector/]# amixer info
amixer: Control device default open error: No such file or directory
[root@vector/]# mplayer /home/spx2/FARSA_BANCA_ROMANA_DE_SPERMA.mp3
MPlayer 1.0pre6-3.3.4 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Duron Spitfire (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cp          udetection.

Playing /home/spx2/FARSA_BANCA_ROMANA_DE_SPERMA.mp3.
Audio file detected.
====================================================================          ======
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
mpg123: Can't rewind stream by 190 bits!
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 8000->176400 (64.0 kbit          )
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3          )
====================================================================          ======
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16b          it...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16b          it...
Video: no video
Starting playback...
A:  15.5 (15.5)  0.9%                                               
A:  15.9 (15.8)  0.9%                                               
A:  16.3 (16.2)  0.9%                                               
A:  20.2 (20.2)  0.9%                                               

MPlayer interrupted by signal 2 in module: play_audio


spx2 01-17-2006 01:48 PM

i must mention that with mplayer i can hear mp3's and stuff but
only if i get the volume to maximum and i hear just a little
if i approach my ears to the speakers...it has very low volume


All times are GMT -5. The time now is 02:35 AM.