LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2016, 05:02 PM   #1
Axon9000
LQ Newbie
 
Registered: May 2016
Distribution: Ubuntu and Mint Mate
Posts: 8

Rep: Reputation: Disabled
Red face Sound Card not being detected on Ubuntu


Recently, I installed Ubuntu onto my brand new desktop, it's worked great so far and I haven't had any problems (crashes and the like) Well that is to say, except for one... There is no sound. I'm not completely sure why, but when I go into sound settings it doesn't detect a sound card. I've tried all the mainstream solutions, and none of them seemed to do anything useful, asking for help here was kind of my last resort.

If theirs anyone who perhaps knows a solution to my problem, and how I can get Ubuntu to recognize my sound card, it would be appreciated. Thanks in advance.
 
Old 11-19-2016, 05:22 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by Axon9000 View Post
Recently, I installed Ubuntu onto my brand new desktop, it's worked great so far and I haven't had any problems (crashes and the like) Well that is to say, except for one... There is no sound. I'm not completely sure why, but when I go into sound settings it doesn't detect a sound card. I've tried all the mainstream solutions, and none of them seemed to do anything useful, asking for help here was kind of my last resort.

If theirs anyone who perhaps knows a solution to my problem, and how I can get Ubuntu to recognize my sound card, it would be appreciated. Thanks in advance.
Hi brother (or sister)...

I'm not sure if I can help but my initial guess here is that the driver is either missing (not released yet) or not loading correctly. If you would, please follow the instructions here and either post the results or provide a link to them. Thanks!

Regards...

Last edited by ardvark71; 11-19-2016 at 06:03 PM. Reason: Correction.
 
Old 11-19-2016, 05:46 PM   #3
Axon9000
LQ Newbie
 
Registered: May 2016
Distribution: Ubuntu and Mint Mate
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
Hi brother (or sister)...
Brother.



Thank you for your response; I followed the steps and got this link: http://www.alsa-project.org/db/?f=2f...8448ad6f4a776f
Again, Thank you, Brother/Sister.
 
Old 11-19-2016, 06:43 PM   #4
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by Axon9000 View Post
Thank you for your response; I followed the steps and got this link: http://www.alsa-project.org/db/?f=2f...8448ad6f4a776f
Again, Thank you, Brother/Sister.
Hi...

It's "brother," as well.

From what I've been reading (here and here,) you're not the only one to have this problem, although theirs were primarily with 14.04. While your device is already supposedly included in the kernel for your version of Ubuntu, if I'm reading the information correctly, the only thing I know to suggest at this point, is to follow the instructions on post #8 here or the official Ubuntu instructions here and see if that helps. If not, you can try upgrading to the newest stable kernel. I'm guessing it's this one.

Disclaimer: I can't guarantee any of the above will not cause unwanted changes or damage to your operating system (Ubuntu 16.04,) proceed at your own risk.

You can also wait to see if another member might have a better suggestion.

Regards...

Last edited by ardvark71; 11-19-2016 at 06:58 PM. Reason: Corrections/Added information and link.
 
Old 11-19-2016, 09:21 PM   #5
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,521

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Try
Code:
$ lspci -vv | grep -i -A 10 audio
and check which module is used (last line). Try to load that module.
 
Old 11-19-2016, 09:46 PM   #6
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by AwesomeMachine View Post
Try
Code:
$ lspci -vv | grep -i -A 10 audio
and check which module is used (last line). Try to load that module.
@Axon9000: If you get a result with AwesomeMachine's suggestion, you can try loading it with the modprobe command.

Regards...
 
Old 11-19-2016, 09:58 PM   #7
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,513

Rep: Reputation: Disabled
According to the paste posted earlier snd_hda_intel is loaded. HDMI sound is enabled. The analog part is not working. There are sub-drivers for snd_hda_intel not shown on lspci -k output. Here is the output from one of my boxes, similar hardware. Linky.
I honestly don't know why there is no analog sound. It seems snd_hda_intel has no sub-driver for chipset in use. Loading a newer kernel or newest out-of-kernel ALSA drivers is probably the solution.
 
Old 11-21-2016, 05:03 PM   #8
Axon9000
LQ Newbie
 
Registered: May 2016
Distribution: Ubuntu and Mint Mate
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ardvark71 View Post
the only thing I know to suggest at this point, is to follow the instructions on post #8 here or the official Ubuntu instructions here and see if that helps. If not, you can try upgrading to the newest stable kernel. I'm guessing it's this one.
Thanks for that, unfortunately the two tutorials you sent me did not work, I'll be working on upgrading the kernel next.

Quote:
Originally Posted by AwesomeMachine View Post
Try
Code:
$ lspci -vv | grep -i -A 10 audio
and check which module is used (last line). Try to load that module.
Quote:
Originally Posted by ardvark71 View Post
@Axon9000: If you get a result with AwesomeMachine's suggestion, you can try loading it with the modprobe command.

Regards...
OK, so I put the command in and got this: 00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)

DeviceName: Onboard Audio
Subsystem: Hewlett-Packard Company Sunrise Point-H HD Audio
Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 255
Region 0: Memory at df420000 (64-bit, non-prefetchable) [disabled] [size=16K]
Region 4: Memory at df400000 (64-bit, non-prefetchable) [disabled] [size=64K]
Capabilities: <access denied>
Kernel modules: snd_hda_intel

00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
Subsystem: Hewlett-Packard Company Sunrise Point-H SMBus


The interesting thing is that the access appears to be denied on the module; or maybe that's for something else I'm not sure. Anyway, I tried adding it with the modprobe command; however I was denied access.

$ sudo modprobe snd_hda_intel
modprobe: ERROR: could not insert 'snd_hda_intel': Required key not available


I guess the only thing I can try now is to update the kernel. Hopefully I don't break thing worse than they already are. Wish me luck!
 
Old 11-21-2016, 05:09 PM   #9
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, 22.04, Windows 8.1 and 10
Posts: 6,282
Blog Entries: 4

Rep: Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842Reputation: 842
Quote:
Originally Posted by Axon9000 View Post
The interesting thing is that the access appears to be denied on the module; or maybe that's for something else I'm not sure. Anyway, I tried adding it with the modprobe command; however I was denied access.

$ sudo modprobe snd_hda_intel
modprobe: ERROR: could not insert 'snd_hda_intel': Required key not available
Hi...

Do any of the suggestions here help?

Quote:
Originally Posted by Axon9000 View Post
I guess the only thing I can try now is to update the kernel. Hopefully I don't break thing worse than they already are. Wish me luck!
If you need to go this route, you have my best wishes and prayers.

Regards...
 
Old 11-21-2016, 06:04 PM   #10
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
$ cat /proc/asound/cards

It should list your "known" hardware there. Otherwise you're missing some stuff which might just be a package manager away. Also make sure it's not muted (alsamixer). And make sure snd-* modules are loaded (lsmod). And make sure the user is in the audio group (groups / id).
 
Old 11-21-2016, 06:15 PM   #11
Emerson
LQ Sage
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~amd64
Posts: 7,513

Rep: Reputation: Disabled
Look at OP's paste in an earlier post, there is no driver loaded for analog sound. Here is similar setup with analog loaded. See the difference?
 
Old 11-22-2016, 06:15 AM   #12
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
HDMI audio is not the default. The default being hw:0,0 in terms of alsa naming conventions. HDMI audio is often hw:0,3.

$ egrep -r -i hdmi /proc/asound/*

Where the .../card0/pcm3p/... would be card 0 device 3 aka hw:0,3. Or to over simplify it in a non-pulseaudio world.

FILE:.asoundrc
#----------
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 3

In pulseaudio it should be selectable in the pavucontrol program. Assuming that the rest of the bits are as they should be.
 
  


Reply

Tags
not working, problem, sound, soundcard, ubuntu.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound from radio to sound card's S/PDIF In isn't detected Mintonite Linux - General 1 03-17-2016 03:19 AM
change detected default sound card in ubuntu 10.10 linuxhippy Ubuntu 2 01-22-2011 09:29 PM
Sound card detected but not able to hear sound in Slackware 13.1 64 bit shravank87 Slackware - Installation 4 11-17-2010 03:39 PM
Integrated sound card not detected (ubuntu) Daravon Linux - Hardware 4 04-10-2010 09:59 AM
No Mixer Detected, Sound Card IS detected, No Sound? one.sick.tzim Linux - Software 3 03-11-2005 11:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration