LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-23-2002, 08:42 AM   #16
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0

I can't find a Plug n Play option to turn off in my BIOS unfortunately. I'll try that arts sound server tip.

thanks all.
 
Old 01-05-2003, 05:14 PM   #17
bpotts
LQ Newbie
 
Registered: Jan 2003
Distribution: Fedora Core 4
Posts: 2

Rep: Reputation: 0
Re: It does work...

The following worked for me on redhat 8.0! Thanks hammerstein02!!

Quote:
Originally posted by hammerstein02
[B]
cd /dev

ls -al ds*

This on my system returned

dsp
dsp0
dsp1
dsp2
dsp3
dsp4

dsp was linked to dsp0..

I then tried..

cat /dev/urandom > /dev/dsp1

(If this works.. there will be a lot of static)

Press CTRL+C to get out of it.

then type:

ln -sf /dev/dsp1 /dev/dsp
 
Old 01-16-2003, 03:07 AM   #18
i6x
LQ Newbie
 
Registered: Jan 2003
Posts: 1

Rep: Reputation: 0
Hmm.

Thnx guys. I had the same problem. I tried the PlugNPlay technique but that didnt work. In the end the trick from hammerstein02, worked. Thnx again.
 
Old 01-16-2003, 08:33 AM   #19
malcolm
LQ Newbie
 
Registered: Jan 2002
Location: newcastle u.k
Distribution: RH 8.0
Posts: 16

Rep: Reputation: 0
I have a similar problem to the originalposter , but in my case my soundblaster 128 is detected as an ensoniq card type es1370. I get perfectly good system sounds . but I have been totally unable to get any sound when a cd is played, although the cdplayer software starts up and plays ok.
using rh8.0 , gnome and I have the volume turned up.
Any ideas, is this a simple idiot problem or an interesting mystery.
 
Old 01-16-2003, 10:24 AM   #20
turnleyw
LQ Newbie
 
Registered: Jan 2003
Location: SF Bay Area
Distribution: Red Hat Linux 7.2 -> 8.0
Posts: 4

Rep: Reputation: 0
Getting sound to work using RH 8.0

i had the same exact problem. i found that i could get the card to work in rh7.3, using sndconfig. but you have to do that without xwindows, i.e. from a command line as root. I found that after upgrading from 7.3 to 8.0, the sound was as I configured it in 7.3. it was just turned off. i first tried to do a 'clean' 8.0 install (my /var was too full anyway), but i couldn't run sndcongfig!! i was getting command not found. so, i started over by reinstalling 7.3, running sndconfig, and then installing 8.0 as an update. this worked as I mentioned above.
now, if someone could tell me how to clean up GRUB. i also am dual-booting. i have 3 linux kernals listed in GRUB, and i'd like to clean up the partions also. all the books and doc's tell you how to upgrade, but there's nothing i can find that says what to do after the upgrade. thanks. Wlt.
 
Old 02-13-2003, 05:14 PM   #21
markdog12
LQ Newbie
 
Registered: Feb 2003
Distribution: RedHat 8.0
Posts: 5

Rep: Reputation: 0
I can't get my sound to work properly, i tried what hammerstein suggested, and it seemed to work, but after i rebooted, only my rear speakers have sound. In volume control, the only control that works is ogain, all others have no effect!!
 
Old 02-13-2003, 10:04 PM   #22
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Original Poster
Rep: Reputation: 0
turnleyw, I comment out the older kernels in /boot/grub/grub.conf, this way only the latest shows up in my boot screen.
 
Old 02-16-2003, 02:59 PM   #23
tomgun6
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Rep: Reputation: 0
Sound card detection problem

I have a sound blaster live!value which works fine in WinMe (dual boot sys). However, RH8.0 does not even detect the card!!! System Settings > SoundCard Detection says: "NO SOUNDCARDS WERE DETECTED!"
I am relatively new to linux admin. I have PnP OS set to NO in BIOS. Any suggestions? Hope I've given enough info.
 
Old 02-16-2003, 06:53 PM   #24
WheatPuppet
LQ Newbie
 
Registered: Feb 2003
Location: State, you ask? Denial.
Distribution: Mandrake 9.2
Posts: 23

Rep: Reputation: 15
That's interesting. I had the same problem and quickly discerned that it was because Linux didn't want to push digital out of my sound port, and I didn't know if it was possible for it to do so, so I plugged in some analog PC speakers and continued on my merry journey of bumbling about a foreign operating system and crashing into things like an old lady in a supermarket.

I did notice that I had an issue (possibly unrelated) with playing CD's with whatever the default CD music player was. I've not had time to mess with it because I've been having repeated troubles just getting past the login screen. That's another story, though.
 
Old 02-17-2003, 01:02 AM   #25
conrake
LQ Newbie
 
Registered: Jul 2002
Location: Midwest U.S.
Distribution: Redhat
Posts: 7

Rep: Reputation: 0
Re: It does work...

Quote:
Originally posted by hammerstein02

cd /dev
ls -al ds*
This on my system returned
dsp
dsp0
dsp1
dsp2
dsp3
dsp4

dsp was linked to dsp0..
I then tried..
cat /dev/urandom > /dev/dsp1
(If this works.. there will be a lot of static)
Press CTRL+C to get out of it.
then type:
ln -sf /dev/dsp1 /dev/dsp
This is what I found on a freshly loaded RH8 system:
[root@localhost dev]# ls ds* -l
crw------- 1 root root 14, 3 Aug 30 19:31 dsp
crw------- 1 root root 14, 19 Aug 30 19:31 dsp1
crw------- 1 root root 55, 0 Aug 30 19:31 dsp56k
[root@localhost dev]# cat urandom > dsp1

As you can see dsp is not linked to anything.
And searching for majors of 14 shows all audio devices:

[root@localhost dev]# ls -l | grep 14,
crw------- 1 root root 14, 4 Aug 30 19:31 audio
crw------- 1 root root 14, 20 Aug 30 19:31 audio1
crw------- 1 root root 14, 7 Aug 30 19:31 audioctl
crw------- 1 root root 14, 3 Aug 30 19:31 dsp
crw------- 1 root root 14, 19 Aug 30 19:31 dsp1
crw------- 1 root root 14, 2 Aug 30 19:31 midi00
crw------- 1 root root 14, 18 Aug 30 19:31 midi01
crw------- 1 root root 14, 34 Aug 30 19:31 midi02
crw------- 1 root root 14, 50 Aug 30 19:31 midi03
crw------- 1 root root 14, 0 Aug 30 19:31 mixer
crw------- 1 root root 14, 16 Aug 30 19:31 mixer1
crw------- 1 root root 14, 17 Aug 30 19:31 patmgr0
crw------- 1 root root 14, 33 Aug 30 19:31 patmgr1
crw------- 1 root root 14, 1 Aug 30 19:31 sequencer
crw------- 1 root root 14, 8 Aug 30 19:31 sequencer2
crw------- 1 root root 14, 6 Aug 30 19:31 sndstat

I do get sound now after 'mv dsp dsp0; ln -s dsp1 dsp' but does anyone know what RH8 incorrectly detected as the dsp device at major 14, minor 3?

I cannot write to the device with 'cat urandom > dsp0' but when I do a 'cat dsp0' now it continually shows info so I suspect it is the microphone.

What should the microphone device be called? I would like to link that device name to the dsp0 and test somehow if I can record from it.
 
Old 02-21-2003, 11:28 PM   #26
celticknight004
LQ Newbie
 
Registered: Feb 2003
Posts: 1

Rep: Reputation: 0
I have your answer. I have a gateway with the same problem. The problem is with the speakers. If you are using the Boston Acoustics, as I am, then you require digital output to the speakers. As of yet, I have not found an answer to this, as Creative Labs does not support Linux. I hook up a set of Dell speakers... works perfectly :-), but no subwoofer :-(. Hope it helps. If anyone figures out how to enable digital output on the Live card under red hat 8.0.. please let us know :-).
 
Old 02-23-2003, 03:50 PM   #27
dkinder45
LQ Newbie
 
Registered: Feb 2003
Posts: 1

Rep: Reputation: 0
I, too, had problems with this, and also hammerstein's trick seemed to work. However, I have to repeat it after every boot. Is there some way of adding it to a script, so that I do not have to enter it on each reboot? Thanks in advance, bear with me, another Linux newbie....
 
Old 03-06-2003, 01:04 PM   #28
jpb
LQ Newbie
 
Registered: Mar 2003
Posts: 1

Rep: Reputation: 0
I have two RH 8 systems that were having the same problem. Hammerstein02's procedure worked on the first. On the second one, when I do a (as root)

ls -al dsp*

it returns

dsp
dsp1
dsp56K

when I do a

cat uramdom > dsp (or cat urandom > dsp1)
is comes back:

dsp: no such device (or dsp1: no such device)

Any ideas?

Thanks,
jpb
 
Old 04-03-2003, 10:42 AM   #29
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
Just going around and posting solutions for people with similar problems that I once encountered. Here are the steps that I went through. Of course you can use the emu10k1 driver that's pre-compiled into the kernel - but what's the fun in that.

Drivers/tools installed(http://sourceforge.net/projects/emu10k1):

emu10k1-v0.20a.tar.bz2
emu-tools-0.9.4-1.i386.rpm

1) extract emu10k1-v0.20a.tar.bz2
cd to emu10k1-v0.20a
make
make install

2) Install emu-tools-0.9.4-1.i386.rpm or tarball(whichever you prefer.

3) edit /etc/modules.conf and add the line:
alias sound emu10k1

This is enough to get the driver working. The next steps only apply for advanced configurations like digital out(my speakers are boston BA790 spdif digital out). Now lets work on digital out and loading the proper scripts on startup.

4) cd /usr/local/etc. You should see:
emu10k1.conf
emu-script

5) edit emu10k1.conf and change <USE_DIGITAL_OUTPUT=no> to <USE_DIGITAL_OUTPUT=yes>.

6) Now add the proper lines to /etc/modules.conf so the script will load on startup and also save the mixer settings.

#Loads script on startup
post-install emu10k1 /usr/local/etc/emu-script
#Saves mixer levels
post-install emu10k1 /usr/local/etc/emu-script restore
pre-remove emu10k1 /usr/local/etc/emu-script save

Example of modules.conf file:

alias sound emu10k1
post-install emu10k1 /usr/local/etc/emu-script
post-install emu10k1 /usr/local/etc/emu-script restore
pre-remove emu10k1 /usr/local/etc/emu-script save

7) Enjoy!
 
Old 04-10-2003, 10:41 AM   #30
poison5151
Member
 
Registered: Mar 2003
Distribution: Red Hat 8.0
Posts: 60

Rep: Reputation: 15
I finally got mine working! KSCD still doesn't produce any sound but hey, I could care less. What you have to do is download the emu tools and then as root type:
emu-config -d
That's it! That got it working for me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
Sound Blaster Live! Not working in Redhat 9 newjuan Linux - General 1 04-27-2004 02:10 PM
Sound Blaster Live on RedHat brentos Linux - Hardware 4 02-18-2004 07:12 PM
Problems with Sound Blaster live in redhat 9 i 8 piglet Linux - Software 5 05-06-2003 10:31 PM
Sound blaster Live config with onboard sound card HChan Linux - Hardware 1 04-30-2003 02:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration