LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   someone please help me! i don't know what to try next (https://www.linuxquestions.org/questions/linux-newbie-8/someone-please-help-me-i-dont-know-what-to-try-next-31678/)

pjlm92 10-02-2002 05:28 AM

someone please help me! i don't know what to try next
 
right, basically i am trying to install redhat 8.0 on an old PR200, as most of you probably know by now.
anyway, i am having no luck.
system has CD drive, floppy, and a highpoint 133sb ide controller in it with an IBM 40GB drive on it.

i insert the CD, it boots, i try installing and it goes through presenting me with text on the screen. it recognises my ide controller, and even says what my ide hard drive is, and that it is DMA.

it then proceeds to tell me the IRQs of the two ide ports, and then tries to access the hard drive i think, and says


Code:

hdg: lost interrupt
(where hdg is my hard drive on the ide controller)

anyway, it displays this message about 5 times, then displays loads of info about the hard drive (size, cache etc) then says "hdg: lost interrupt" again.

then it queries the drive and shows loads of info, then starts loading anaconda.

i enter all my setup details and then get the the stage where i can tell it how to partition (fdisk, disk druid, autopartition). i have tried all three options and putting in info btw. having done this it tells me it is going to install, then tries to start formatting the partition, but tells me there has been an error and it can't proceed, and then restarts.

PLEASE someone help me, i have been trying to fix this for about 3 days with RH 7.3 now, searching the internet for solutions. it is fairly common with my controller i think, but i have found no solution.

if anyone could help me i would be hugely grateful

thanks everyone

Pete

*edit* i thought it might be short of power, but all it is powering is mobo, cd, hdd and fdd.

moses 10-02-2002 06:10 AM

I would bet money that the problem is in hard ware, not software. Those
errors about the hard drive indicate that you need a new disk or a new
cable to the disk. I would try replacing the old cable with a shielded cable,
since that's nothing in cost compared with a new HD. If that doesn't do it,
it's almost certainly your disk.

unSpawn 10-02-2002 06:28 AM

Did you try switching consoles with ALT+CTRL+F2 or F3? Might show some more error msgs's that could clarify stuff. You could also try to access the disks/cdr in PIO mode with hdparm if you suspect it's about DMA.

pjlm92 10-02-2002 08:50 AM

Quote:

Originally posted by moses
I would bet money that the problem is in hard ware, not software. Those
errors about the hard drive indicate that you need a new disk or a new
cable to the disk. I would try replacing the old cable with a shielded cable,
since that's nothing in cost compared with a new HD. If that doesn't do it,
it's almost certainly your disk.

tried replacing the cable, no help :(
i have also tried another hdd and that does not help either.



how do i use hdparm? do i just add it to the install command at the install screen?

neo77777 10-02-2002 09:00 AM

It's not cables, it is HighPoint 133 ATA adaptor, what is the chipset? I am not into RAID's configurations, but there are different chipsets HighPoint 372, 374, which one, and I hope RH8.0 comes with 2.4.19, right?

pjlm92 10-02-2002 09:06 AM

nothing happens when i press ctrl-alt-F2/F3 :( i have tried the jumpers on the hdd in all combinations listed on it.

hmm, this is very annoying and i have no idea what to do.

i know it is either the controller or the hdd thats the prob because i had linux running on it fine on an old 4gb hdd plugged into the mobo.

thing is now i plug this 40gb hdd into the mobo and take out the controller and the same thing happens! guess the hdd is the prob then....
how do i force it into PIO mode?

pjlm92 10-02-2002 09:07 AM

Quote:

Originally posted by neo77777
It's not cables, it is HighPoint 133 ATA adaptor, what is the chipset? I am not into RAID's configurations, but there are different chipsets HighPoint 372, 374, which one, and I hope RH8.0 comes with 2.4.19, right?
it is a highpoint 302 chipset. i think it is a well known prob having these errors, but no one seems to know what to do. i am afraid i have no idea what the kernal is

jglen490 10-02-2002 09:49 AM

Try ide=nodma at the install prompt. I picked that up in a search on "nodma". There may be other or better solutions, but give that a try.

pjlm92 10-02-2002 09:56 AM

Quote:

Originally posted by jglen490
Try ide=nodma at the install prompt. I picked that up in a search on "nodma". There may be other or better solutions, but give that a try.
will do , thanks

done that - nope, no help

unSpawn 10-02-2002 10:08 AM

"hdparm -d0 /dev/<drive>", "man hdparm" for more. Sorry about the F2/F3 thingie, forgot that would only work if you're *in* the installer.

neo77777 10-02-2002 11:04 AM

There is not much info on this chipset besides that kernel code doesn't support the second channel on that card http://www.redhat.com/apps/search/re...search:start=0
Kernel FYI is the core of your Operating System, it is a C code which makes your system tick. I guess you'd have to delve into more advance reading to get this problem squared away.
But if you have efforts and desire to learn what the heck linux is I suggest getting a book first, but you might say what book is good for if I don't have a working linux machine, and I see your point, well that's the wonderful side of linux, I am not kidding - it is wonderful, but for me as I consider myself a computer enthusiast who has patience and something else to get his/her system to work. Let's see if there is somebody else who has the same card as you do, and who has his/her system in a working condition, look there are almost 17000 registered members.

pjlm92 10-02-2002 02:22 PM

Quote:

Originally posted by unSpawn
"hdparm -d0 /dev/<drive>", "man hdparm" for more. Sorry about the F2/F3 thingie, forgot that would only work if you're *in* the installer.
doesn't work:mad:
grrrr, dunno what to do now

Linuxidiot 10-02-2002 02:25 PM

8.0 comes with 2.4.18.11 I believe but I just thought this might help dun know what to do about your prob :( good luck

pjlm92 10-02-2002 02:32 PM

Quote:

Originally posted by Linuxidiot
8.0 comes with 2.4.18.11 I believe but I just thought this might help dun know what to do about your prob :( good luck
cool, thanks. i have searched the internet for about a week now for a solution to this prob. so many people have a similar one but no one seems to know what to do. surely someone has a clue what is going on. :confused: :mad:

Faecal 10-02-2002 04:46 PM

This sounds like such a specific issue - if there really aren't any solutions on mailing lists you've seen from googling, I suggest you find the mailing list for the development of the relevant part of the kernel and enquire there. Don't ask me where/who, since I don't know, and I'm almost certain that I don't use google any better than you do :-)


All times are GMT -5. The time now is 05:26 PM.