LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Software installation problem - GLIB error? (https://www.linuxquestions.org/questions/linux-newbie-8/software-installation-problem-glib-error-689977/)

equazcion 12-11-2008 11:27 PM

Software installation problem - GLIB error?
 
This is my first attempt at installing software without Ubuntu's add/remove thingy. I'm using the instructions at https://help.ubuntu.com/community/CompilingEasyHowTo , which told me to install cvs, build-install, checkinstall, and subversion, all of which I did.

I'm now trying to install XMMS using their tar.gz archive.

I've got the package uncompressed, and I run ./configure. After some activity, I get the following message:

*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

I looked through Synaptic and found numerous references to glib, so I'm guessing it's already installed, just not configured properly... maybe... and now I'm stuck. Can anyone shed some light on this?

Thanks -

Junior Hacker 12-12-2008 01:04 AM

First of all, there appears to be allot of poor advice there. You don't need cvs and subversion to compile from code. If you intend on designing your own source code/software, then you might choose to install these packages, they are huge and take up unnecessary space.
Most tutorials will tell you to download the source code into your /home directory, not make some special directory that's not in your path and produces the error you have.

Try moving the un-tarred folder containing the source code into your /home directory and navigate there via command line and try again.

Or, you'll need to edit the /etc/profile to add the new directory to all user's path.

Junior Hacker 12-12-2008 01:31 AM

Sorry, that may have been wrong advice.
Do you have linux-kernel-headers matching your current running kernel installed?

Junior Hacker 12-12-2008 01:52 AM

The reason I asked for headers is to see if linux-libc-dev is installed. Also, make sure these two packages are installed, the linux-libc-dev may not be as important:

libgtkmm-dev
libguilegtk-1.2-dev

Duck2006 12-12-2008 07:09 AM

http://www.psychocats.net/ubuntu/ins...re#lastresorts

equazcion 12-12-2008 05:37 PM

Thanks Duck but that site doesn't say anything about what to do with tarballs. It just links to the site I linked to above.

Thanks Junior Hacker but I really don't know what headers you're talking about.

I'm about ready to throw Linux out the window. How people compare Ubuntu to Windows on the ease-of-use front is beyond me. What Windows does automatically for software installation and swap space alone would've taken care of my last 3 days of manual headaches with Ubuntu.

Sorry I just had to get that out. I appreciate the help, thanks.

wet-willy 12-12-2008 08:31 PM

In Ubuntu you have synaptic package manager, open it and select "installed" on the left hand side and scroll down the list to see if linux-kernel-headers is installed. linux-libc-dev I believe would automatically be installed when kernel headers are installed.

Before installing either headers or linux-libc-dev, install those other two packages I mentioned.
Because I googled your error last night and found a thread where others had the same issue installing XMMS and that was the cure.

Quote:

I'm about ready to throw Linux out the window. How people compare Ubuntu to Windows on the ease-of-use front is beyond me. What Windows does automatically for software installation and swap space alone would've taken care of my last 3 days of manual headaches with Ubuntu.
I hear you, and most other Linux users probably do also as we all had to start somewhere. My mother told me it took quite a while before I learned how to walk. But I stuck with it and now I can run also.

Duck2006 12-13-2008 04:27 AM

Is it not in repo's

Click System->Administration->Synaptic Package Manager
Click Search
Enter xmms
Check what you want there and click Apply

equazcion 12-13-2008 12:45 PM

wet-willy:

You say that before I install "linux-kernel-headers" and "linux-libc-dev", I should install the other 2 packages you mentioned. But I don't see that you've mentioned any other packages. Could you clarify that? Thanks.

I'm aware that anything has its learning curve. My point was that Linux has a much larger one than Windows, and anyone claiming it's just as easy is completely off their rocker.

Duck:

Thanks, I don't know what "repo's" means, but I'll try finding xmms in Synaptic and see what happens.

equazcion 12-13-2008 01:45 PM

Duck seems to have been correct, XMMS was available in Synaptic. Installed with no errors.

After installing it there I didn't see any new apps though. Apparently you also need to install a graphical "client" for it. Those are then available via add/remove. I installed one called "Esperanza", which seems to work ok.

Thanks for all the help everyone :)

equazcion 12-13-2008 02:19 PM

Yeah so now it doesn't seem I installed the right thing. I installed XMMS2 which seems to be the client/server thing, but what I wanted was XMMS, the Winamp-style player. I'm totally lost and have purchased dynamite with which to explode my Ubuntu CD, lest I am ever tempted to try it again.

Duck2006 12-13-2008 03:48 PM

Is this the one?

https://launchpad.net/ubuntu/hardy/i...070601-1build2

Or you should find xmms hear.

http://www.google.com/cse?cx=0122857...xmms&sa=Search

rpa 12-17-2008 06:11 AM

glib-config may not be required
 
I was getting a similar error message while trying to compile x-cd-roast alpha16 of FC6. After a little bit of searching, when I tried compiling with the flag "--enable-gtk2", it went through successfully.


All times are GMT -5. The time now is 09:24 AM.