LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Closed Thread
 
Search this Thread
Old 09-07-2011, 02:43 AM   #1
chetan rodrigues
LQ Newbie
 
Registered: Sep 2011
Posts: 7

Rep: Reputation: Disabled
Unhappy snort: error while loading shared libraries: libdnet.1: cannot open shared object fil


Hi sir , i need to install snort and work on it , but whenever i start to run it i will get this error-snort: error while loading shared libraries: libdnet.1: cannot open shared object file: No such file or directory thank you please help me to find a way to this problem
 
Old 09-07-2011, 02:53 AM   #2
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,096

Rep: Reputation: Disabled
Hi and welcome to LQ
Have you installed the libdnet and libdnet-dev packages? How are you installing snort? Did you install the "snort" package?
ciao,
jdk
 
1 members found this post helpful.
Old 09-07-2011, 03:17 AM   #3
chetan rodrigues
LQ Newbie
 
Registered: Sep 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thank you for your reply. yes sir i have installed both snort and libdnet package
 
Old 09-07-2011, 04:05 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2015, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,664

Rep: Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758Reputation: 2758
Some comments ..
The Ubuntu snort package is not built with libdnet.

About the Ubuntu libdnet :
Ubuntu uses a libdnet built from dnprogs → → libdnet-2.55
No libdnet.1 ! http://packages.ubuntu.com/natty/i386/libdnet/filelist
libdnet-2.55 http://packages.ubuntu.com/natty/libdnet

sudo apt-get install snort : Will provide snort-2.8.5.2 in Ubuntu 11.04.


Using a manually installed "libdnet-1.11" (Installed to /usr/local/) :
cd /usr/lib/
sudo ln -s /usr/local/lib/libdnet.1.0.1 libdnet.1

.

Last edited by knudfl; 09-07-2011 at 06:07 AM.
 
Old 09-07-2011, 04:50 AM   #5
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,096

Rep: Reputation: Disabled
@knudfl Yes, I was basing my comment on the error message of the extremely limited info supplied by the OP.
@Chetan,
Can you give us the command you used that generated the message you reported in your original post? You really need to be a bit more generous in providing information if you hope to solve your problem. As Knudfl suggested, why not simply install the Ubuntu snort package?
ciao,
jdk
 
Old 09-07-2011, 06:13 AM   #6
chetan rodrigues
LQ Newbie
 
Registered: Sep 2011
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thank you very much sir , i got cleared with that problem, but am having another problem . when i try to run snort in IDS mode it will show "ERROR: Failed to initialize dynamic preprocessor: SF_FTPTELNET version 1.2.12 (-1)
Fatal Error, Quitting.." . i have installed snort-2.9.1 version. please help me to clear this problem
 
Old 09-07-2011, 07:49 AM   #7
jdkaye
Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,096

Rep: Reputation: Disabled
Would you please mark this thread as [Solved] and post the solution so you can help others with the same problem. After that please start a new thread for your new problem. You will probably not get an answer if your new problem is buried at the end of your old one.
Thank you,
jdk
 
Old 12-24-2011, 03:12 PM   #8
eventvwr
LQ Newbie
 
Registered: Dec 2011
Location: UK
Distribution: Ubuntu 11.04 (Natty Narwhal)
Posts: 4

Rep: Reputation: Disabled
I found Snort to be a total PITA to install

I found this thread because I had the same error message. I later found a way to get past it by looking at a different post. For others with this issue who end up here this may help (not intended to be astroturfing)

http://www.linuxquestions.org/questi...3/#post4557734

++ edit ++
Knudfl said
>sudo apt-get install snort : Will provide snort-2.8.5.2 in Ubuntu 11.04.

May be worth knowing that the Snort people don't recommend installing old versions like that. They release new versions frequently and the current rules don't run on old versions

Last edited by eventvwr; 12-25-2011 at 08:08 AM. Reason: Added info about new versions vs old versions
 
Old 03-07-2014, 04:32 AM   #9
uta
LQ Newbie
 
Registered: Mar 2014
Posts: 2

Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
Some comments ..
The Ubuntu snort package is not built with libdnet.

About the Ubuntu libdnet :
Ubuntu uses a libdnet built from dnprogs → → libdnet-2.55
No libdnet.1 ! http://packages.ubuntu.com/natty/i386/libdnet/filelist
libdnet-2.55 http://packages.ubuntu.com/natty/libdnet

sudo apt-get install snort : Will provide snort-2.8.5.2 in Ubuntu 11.04.


Using a manually installed "libdnet-1.11" (Installed to /usr/local/) :
cd /usr/lib/
sudo ln -s /usr/local/lib/libdnet.1.0.1 libdnet.1

.

hi, knudfl. i hope you feeling good ryt now.

i got some problem with him. but how if i am using ubuntu 12.04?

thanks for replying
 
Old 03-07-2014, 11:06 AM   #10
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959
Please don't resurrect old threads. Let's it r.i.p. now.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error while loading shared libraries: libgda-4.0.so.4: cannot open shared object file mahesh1234 Linux - Newbie 2 10-23-2013 12:06 AM
honeyd: error while loading shared libraries: libdnet.1: cannot open shared object fi secbuddy Linux - Software 2 12-24-2011 03:01 PM
error while loading shared libraries: libtermcap.so.2: cannot open shared object file astroboy2000ir Linux - Software 3 12-08-2010 12:16 AM
error while loading shared libraries: libstdc++.so.5: cannot open shared object file: Franziss Linux - Newbie 10 06-28-2010 06:47 AM
error while loading shared libraries: libgvc.so.3: cannot open shared object file coolrock Slackware 6 01-17-2007 06:10 PM


All times are GMT -5. The time now is 12:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration