LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   smb service start fails (https://www.linuxquestions.org/questions/linux-newbie-8/smb-service-start-fails-885560/)

SriniKlr 06-10-2011 06:36 AM

smb service start fails
 
hi,

I am using the FC 14. When I try to start the smb service it fails. Following is the output of the terminal:

[root@srini samba]# service smb start
Starting SMB services: [FAILED]

this is what I get in the /var/log/messages when smb service fails:

*************************************************
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.398660, 0] lib/messages_local.c:112(messaging_tdb_init)
Jun 10 15:49:21 srini smbd[7712]: ERROR: Failed to initialise messages database: Permission denied
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.400377, 0] lib/messages.c:204(messaging_init)
Jun 10 15:49:21 srini smbd[7712]: messaging_tdb_init failed: NT_STATUS_ACCESS_DENIED
Jun 10 15:49:21 srini smbd[7712]: [2011/06/10 15:49:21.400736, 0] smbd/server.c:67(smbd_messaging_context)
Jun 10 15:49:21 srini smbd[7712]: Could not init smbd messaging context.

***************************************************

I did the testparm on my smb.conf files, didn't notice any error.

Please help !!!

divyashree 06-10-2011 06:55 AM

If you have selinux enabled, disable it try if it works.

SriniKlr 06-10-2011 07:55 AM

Quote:

Originally Posted by divyashree (Post 4381748)
If you have selinux enabled, disable it try if it works.

After disabling the Selinux it worked !!! thanks a lot for the reply.

I have other problem with the samba not sure I can continue here :confused: my apologies if it is a mistake;)

I get the following error when I try to get the list all the folder shared in my PC.

****************************************************
[root@srini srini]# smbclient -L 192.168.254.128
WARNING: The "share modes" option is deprecated
Enter srini's password:
session setup failed: NT_STATUS_LOGON_FAILURE
***************************************************

this is how my smb.conf looks like

smb.conf
*****************************************
; guest account = nobody
log file = /var/log/sambai/log.%m
lock directory = /var/lock/samba
share modes = yes
interfaces = 192.168.254.128/24
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
workgroup = corpusinc.corp
netbios name = SCS-12

[homes]
comment = Home Directories
browseable = no
read only = no
create mode = 0750

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes

[public]
comment = Public Stuff
path = /home/srini/Vmtools
public = yes
writable = yes
printable = no
***********************************************

thanks in advance.

divyashree 06-10-2011 11:12 PM

Quote:

Originally Posted by SriniKlr (Post 4381794)
After disabling the Selinux it worked !!! thanks a lot for the reply.

It worked, but its not a god practice to run smb by disabling selinux. Get the selinux contexts of samba and try to enable those.

divyashree 06-10-2011 11:49 PM

Quote:

Originally Posted by SriniKlr (Post 4381794)
After disabling the Selinux it worked !!! thanks a lot for the reply.

I have other problem with the samba not sure I can continue here :confused: my apologies if it is a mistake;)

I get the following error when I try to get the list all the folder shared in my PC.

****************************************************
[root@srini srini]# smbclient -L 192.168.254.128
WARNING: The "share modes" option is deprecated
Enter srini's password:
session setup failed: NT_STATUS_LOGON_FAILURE
***************************************************

this is how my smb.conf looks like

smb.conf
*****************************************
; guest account = nobody
log file = /var/log/sambai/log.%m
lock directory = /var/lock/samba
share modes = yes
interfaces = 192.168.254.128/24
encrypt passwords = yes
smb passwd file = /etc/smbpasswd
workgroup = corpusinc.corp
netbios name = SCS-12

[homes]
comment = Home Directories
browseable = no
read only = no
create mode = 0750

[tmp]
comment = Temporary file space
path = /tmp
read only = no
public = yes

[public]
comment = Public Stuff
path = /home/srini/Vmtools
public = yes
writable = yes
printable = no
***********************************************

thanks in advance.

There is no hosts allow or host deny option in your smb.conf file.


All times are GMT -5. The time now is 03:21 PM.