Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-19-2005, 04:43 AM   #1
Registered: Sep 2005
Posts: 225

Rep: Reputation: 15

i cant copy-paste windows files to linux. but reverse is happening. what i should do ?

my smb.conf
#======================= Global Settings =====================================
server string = Samba Server %v
printcap name = lpstat
load printers = yes
printing = cups
log file = /var/log/samba/log.%m
max log size = 50
password level = 8
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no

#============================ Share Definitions ==============================

# This one is useful for people to share files
comment = Temporary file space
path = /tmp/Public-For-Share
read only=no
public = yes
create mask = 0765
Old 10-19-2005, 05:24 AM   #2
Registered: Sep 2005
Posts: 225

Original Poster
Rep: Reputation: 15
i cant paste windows files to linux. but reverse is happening. what i should do ?

is it possible at all ?
Old 10-25-2005, 12:00 PM   #3
Registered: Aug 2003
Distribution: Arch Linux 0.7
Posts: 81

Rep: Reputation: 15
It certainly is possible..

Does the directory you mention in your share exist ?

Make sure the ownership on the temp dir is correct as well!
Old 10-25-2005, 12:32 PM   #4
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
i cant paste windows files to linux. but reverse is happening. what i should do ?

is it possible at all ?
Of course it is! I have mine setup to do that.

What is the file permissions on that /tmp/Public-For-Share folder and the files within it?

Isn't guest, by default, not allowed to modify files anyway?? I dont use the guest options in my shares, I share the files and give specifc users access to those shares. That umask option might be whats causing the problem though. Having 0765 gives world (or guest) only access to read those files, unless guest is the owner of them.
Old 10-25-2005, 08:49 PM   #5
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with (still off the hook)
Posts: 284

Rep: Reputation: 33
Try adding to the smb.conf the line:
write list = @group
Being group here a group on your system, check the permissions on the shared folder to see what kind of access has the authenticaded user.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
smb.conf example xox Linux - Networking 7 10-09-2010 02:04 AM
smb.conf nkeever Linux - Newbie 1 05-03-2005 09:35 AM
samba conf smb.conf regnier Mandriva 5 02-17-2005 04:27 AM
where is the smb.conf?? willigi Linux - Software 4 01-12-2005 10:48 AM
smb.conf youssefe2k Linux - Networking 1 01-25-2004 02:56 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration