LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-21-2017, 08:39 AM   #1
anas123
LQ Newbie
 
Registered: Jan 2017
Posts: 4

Rep: Reputation: Disabled
Slow Performence


Hello everyone i use the linux ubuntu 16.10 yakkate. I am Android developer so i have install android studio in ubuntu i still work perfectly but some time when i use my android device for testing purpose the during building gradle of android studio my 6 gb ram full consumed and system slow done some time full goes to dead lock like state. Please tell me if any one have solution of this problem

Thanks in advance
 
Old 02-21-2017, 08:58 AM   #2
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
I would suggest having a process/task manager such as top open when you connect the device and using that to see what process(es) are using high CPU/Memory. It isn't like we can just tell you what the problem maybe without anything to work with.
 
Old 02-21-2017, 09:10 AM   #3
snowday
Senior Member
 
Registered: Feb 2009
Posts: 4,667

Rep: Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409Reputation: 1409
I notice Android Studio recommends 8gb RAM, plus 1gb for the emulator:

https://developer.android.com/studio/index.html

Could the problem be as simple as, your 6gb is not enough RAM for good performance?
 
Old 02-21-2017, 09:26 AM   #4
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Originally Posted by snowpine View Post
I notice Android Studio recommends 8gb RAM, plus 1gb for the emulator:

https://developer.android.com/studio/index.html

Could the problem be as simple as, your 6gb is not enough RAM for good performance?
It could be it literally requires 8G of RAM, and it's pulling an additional 2G of Paging from SWAP. If you see high iowait while it loads, then that'd be the case.
 
Old 02-24-2017, 01:44 PM   #5
anas123
LQ Newbie
 
Registered: Jan 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
slow performance

well bro u say correct that the 8 gb ram are required it max but mini 3 gb so anyway in DOS the 6 gb ram is enough for android studio is work along 6 gb. Another thing i set the swap space 4 gb now it work better now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Beegle Board Performence Dave1024 Linux - Newbie 2 06-28-2010 07:43 AM
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 12:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
2 ethernet cards - performence help sorrow Linux - Newbie 1 03-14-2004 11:24 AM
RH8 vs. W2k - Slow, slow, slow zerojosh Linux - Software 2 06-30-2003 07:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration