-   Linux - Newbie (
-   -   Slackware8.1, KDE & serial mouse (

OOmiz 02-07-2003 03:20 AM

Slackware8.1, KDE & serial mouse
Iím running Slackware8.1 and I have 2 problems.


2. When I start KDE3.0 the mouse is only visible as long as I donít touch it. As soon as i move it goes invisible. (At least I think its still there)
Iím using a serial Microsoft 2 button mouse. And it works great with gpm. I also tried: "killall -9 gpm" in case it messed things up. But it didnít have any effect. Iím not totally sure what configs I have to edit, and what to write in them since Iím not sure if this is a mouse or a video problem (everything else looks nice when KDE is started). Please help me.

Mara 02-07-2003 04:14 AM

Heve you tried the mouse with any other window manager (GNOME, for example)? If the effect is the same, you should configure your X again (using xf86conf) and choose the right mouse.

OOmiz 02-07-2003 05:41 AM

I get the error running gnome too. I have used xf86conf and I did choose the right mouse. I have changed the XF86Config too.
I tried changing the protocol to "Microsoft". Then i changed the device to "/dev/gpmdata" and then "/dev/mouse"

After running the xf86conf again the mouse-pointer is visible all the time but now I canít move the mouse. So this must be some kind of mouse problem and not a video one (?).

Still... I canít figure out what to put in XF86Config.

Mara 02-07-2003 10:29 AM

If you're using XFree version 4+, you need to edit XFree86Config-4.
You should find something like this:

# **********************************************************************
# Pointer section
# **********************************************************************

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/mouse"
# Option "ZAxisMapping" "4 5"

OOmiz 02-09-2003 01:52 PM

Ok I have solved it:

I changed the device to "dev/ttyS0"

And it works great!

Texicle 02-10-2003 12:46 AM

If you want to, you can create a symlink to /dev/ttyS0.

ln -s /dev/ttyS0 /dev/mouse

It's up to you though. :)

All times are GMT -5. The time now is 06:59 PM.