-   Linux - Newbie (
-   -   slackware x configuration (

ericfx 07-21-2004 07:11 PM

slackware 10.0 x configuration
im sitting in /usr/X11R6/bin on my laptop but when i run "xorgconfig" nothing happens but "command not found". i installed fluxbox and x from the packages of slackware-current using pkgtool.

what am i doing wrong?


Komakino 07-21-2004 07:13 PM

Are you root? What happens if you just type startx? You're gonna have to give us more info...are you even using xorg or are you using XF86?

ericfx 07-21-2004 07:16 PM

yes i am logged in a root

i just download the x file out of /x on the packages mirror called x11-6.7.0-i486-4 and used pkgtool to install it

startx returns command not found


Komakino 07-21-2004 07:19 PM

Could be that they're not in your which case you'll need to add /usr/X11R6/bin to the PATH variable in /etc/profile (as root).

To run it from where you are you'll need to type:

Note the ./ in front of startx...that's because by default the current directory is not searched, it's a security precaution against bogus programs.

Sorry, or

as that was what you originally asked for anyway!! Still, you could try ./startx to see if it works.

ericfx 07-21-2004 07:26 PM

thanks i got access to the config file now

my new challenge is getting fluxbox to work when i type startx

Komakino 07-21-2004 07:31 PM


Originally posted by ericfx
thanks i got access to the config file now

my new challenge is getting fluxbox to work when i type startx

That's an easy one :D

In your home directory (you should not use root usually, hopefully you have a second user set up?) create (or edit, if it exists) the file .xinitrc - note that there is a DOT infront of the name (because the file is hidden). Inside this file add the line:

exec fluxbox
That's all you need.

If you don't have a non-root user, set one up now and only use root when you intend to make system-wide changes.

useradd username
where username is the name of the user you want to create. Then use

passwd username
as root, to set that user's initial password.

ericfx 07-21-2004 07:45 PM

i created the file .xinitrc in my /home/eric dir

i run startx and get "xauth" timeout in locking authority file /home/eric/.Xauthority"

whats the most likely problem?

Komakino 07-21-2004 07:51 PM

Does .Xauthority exist? If it does then try renaming it, if it doesn't then try creating an empty one!

Komakino 07-21-2004 07:53 PM

I found a post by someone with a similar problem - it turned out all their home directory and the files within were owned by root! Check that isn't the case with you.

Komakino 07-21-2004 07:55 PM

If none of that helps you then it could be a stale lock file, in which case you need to run xauth to try to break the stale lock. Try:

xauth -b -f /home/eric/.xauthority
I don't know if you need to be root or not, so try it as eric first and then as root if that makes no difference.

ericfx 07-21-2004 07:59 PM

how do i check to see if all my files are owned by root?

Komakino 07-21-2004 08:03 PM


ls -l
the third and fourth columns will both say 'root'. If that's the case change to be root and in eric's home directory type:

chown -R eric:users *

ericfx 07-21-2004 08:11 PM

.Xauthority and .xinitrc still say root and root in the 3rd and 4th column after issusing that command you gave me. it changed some of my tar files to my ownership but not the 2 listed files.

it says this when i run "startx" logged in as eric

hostname: Unknown host
xauth: timeout in locking authority file /home/eric/.Xauthority
xauth: timeout in locking authority file /home/eric/.Xauthority

followed by lots more text and it appears to be more errors.
i may try reinstalling and this time select X while installing, think that wouls help? maybe my config file is wrong?

Komakino 07-21-2004 08:13 PM

Try the command (chown) again but this time instead of * specify the actual names of the two files.
chown eric:users .Xauthority .xinitrc

Komakino 07-21-2004 08:14 PM

Once you've done that, do

chmod +rw .Xauthority .xinitrc
and now it's my bedtime, so good luck!

All times are GMT -5. The time now is 03:47 PM.