-   Linux - Newbie (
-   -   Slackware: screen full of '40's (

CrazyHorse 04-19-2004 01:09 AM

Slackware: screen full of '40's
I am a relative Linux newbie. I have an old ‘AST Bravo LC 5133’ running at 133 MHz with 31Mb RAM and 365Mb hard drive. I am attempting to set it up for my mother in law as a simple Linux based Word processor, email & internet surfing machine. After googling I found out that slackware was probably going to be the best distro for such an old computer. I read thoroughly thru the slackware website and found out that to get the simplest base system I would need the ‘A’ set of programs. I then ftp’ed them and then (tediously) unpacked them (with Winzip) individually into a directory which I then burned onto CD.
I tried an install and the boot and root disks worked fine. I went thru setup and everything
seemed to go fine, it even recognised the CD. The only thing that seemed off was that during the process of installing the base system off the CD it didn’t take very long for it to put it on the hard drive. I say this because the CD I made up was about 75 mb and it took the install program only seconds to install it. Also I asked for the beginner’s verbose install, which, from what I can gather, tells you exactly what is being installed in great detail, but there was none. After this it configured my system (again this took mere seconds) and then said I could reboot. After removing all disks from removable drives I rebooted and waited. I was greeted with a screen full of ‘40’s.
Thinking that maybe lilo hadn’t been installed I tried rebooting from the bootdisk which started off well but ended poorly with the last two lines:

Warning: unable to open an initial console
Kernel panic: No innit found. Try passing init= option to kernel

Which means very little to me.

My hunch is that there is no (or at least very little) operating system on the hard drive.
I also suspect that this must be because I constructed my Slackware CD incorrectly.

Could someone please shine some light on my ignorance?

CrazyHorse 04-19-2004 06:03 AM

still no luck
I managed to get a debian woody CD and so I made up a boot and root disk for that and did an install. This time it definitely did install a base system(took about 15 mins).
But, same result. I reboot and get a screen full of "40"s!!
So something else must be going on.
Anyone got any ideas?

jeffreybluml 04-19-2004 07:38 AM

Is there any chance you're low on / out of hard drive space?

I have seen some funky things happen when you run out of disk space, and it doesn't even tell you that is the reason...

Just a thought...

Good luck!

CrazyHorse 04-19-2004 05:00 PM

Thanks for replying.
I dont think I could have run out of harddrive space because
every install has only been a base system and the space requirements
for a base system in slackware and debian are well under the space ( ~330mb) that I have.

Any other ideas?

DB03 04-19-2004 08:09 PM

well, i really don't know but i'd guess that was error #40? maybe look it up to see what the actual error is?

good luck

edit: found this at

the following was posted by ringwraith:

You will find the following in man lilo:

The boot process takes place in two stages. The first
stage loader is a single sector, and is loaded by the BIOS
or by the loader in the MBR. It loads the multi-sector
second stage loader, but is very space limited. When the
first stage loader gets control, it types the letter "L";
when it is ready to transfer control to the second stage
loader it types the letter "I". If any error occurs, like
a disk read error, it will put out a hexadecimil error
code, and then it will re-try the operation. All hex
error codes are BIOS return values, except for the lilo-
generated 40, 99 and 9A. A partial list of error codes

00 no error
01 invalid disk command
0A bad sector flag
0B bad track flag
20 controller failure
40 seek failure (BIOS)
40 cylinder>1023 (LILO)
99 invalid second stage index sector (LILO)
9A no second stage loader signature (LILO)
AA drive not ready
FF sense operation failed

Error code 40 is generated by the BIOS, or by LILO during
the conversion of a linear (24-bit) disk address to a geo-
metric (C:H:S) address. On older systems which do not
support lba32 (32-bit) addressing, this error may also be
generated. Errors 99 and 9A usually mean the map file (-m
or map=) is not readable, likely because LILO was not re-
run after some system change, or there is a geometry mis-
match between what LILO used (lilo -v3 to display) and
what is actually being used by the BIOS (one of the lilo
diagnostic disks, available in the source distribution,
may be needed to diagnose this problem).

At this point I would boot into your system using your cd.
at the first cmd line type linux=/dev/hdxx noinitrd ro
after your system comes up, I would rerun liloconfig and install to the mbr again.

-----end ringwraith quote

i don't understand that fully as i'm also a n00b but i'd say it's due to the fact that the system if pretty old. It says some older systems don't support 32-bit addressing, so maybe this is the cause of your problem.


CrazyHorse 04-19-2004 11:28 PM

You're right, it is a lilo problem and I didnt notice earlier but there is an 'L' before all those forties.
I was concerned that maybe I had a hardware failure and so I tried installing dos 6.2 which resulted in the same L 40 40 40 40....etc.
Then I remembered the dos command to clear the master boot record:
fdisk /mbr. This worked a treat and I had dos working.

So then I tried a fresh install of debian and loaded LILO into the mbr when asked. After rebooting the system I got the dreaded L 40 thing again!
It was about this time that I checked back here and saw your post (DB03)
and so tried changing my IDE options in the BIOS which didnt do anything.
So then I booted up the system with a boot diskand ran 'liloconfig'.
One question in particular struck me as odd. The liloconfig program asked me if I would like to:
Use LBA32 for addressing big disks using new BIOS features?

I said no but it then overrid my command.

When I rebooted I got pretty much the same deal except this time it said:

L 40 40 40 40"

From what I have found out from the net I should probably try using GRUB
instead of LILO but I dont know how to get rid of LILO and replace it with GRUB. I guess that is the next thing to learn.

If anyone knows a quick sure-fire way to install grub(and/or to inform me how to get it going with LILO) I would greatly appreciate it.


Chris H 04-20-2004 05:19 AM

Can you remove the lba32 option from /etc/lilo.conf?

If you can try it without or perhaps replacing it with 'linear'.

To write lilo.conf to the mbr type /sbin/lilo


CrazyHorse 04-20-2004 07:27 AM

Thanks for the reply Chris H.

I removed lba32 from lilo.conf and i still got 'MBR L 40 40 40.."
Then I replaced it with linear. Same result.
Then I removed 'compact' from lilo.conf. Same result.
I also tried replacing 'boot=/dev/hda1' with 'boot=/de/hda'. Same result.

Here is what my lilo.conf looks like (if it helps any):










Any suggestions?

CrazyHorse 04-20-2004 07:44 AM

Am I dumb.

I wasnt doing the /sbin/lilo thing like you said Chris H.
So I went into lilo.config and changed 'lba32' to 'linear'
just as you suggested and then wrote it to the mbr and Wooohhoobabyyy
cooler than frickin sharkswithlasers ontheirfrickinheads it worked a treat!!!!!

As we say in New Zealand: You little beauty!!

Chris H you da man!

thanks very much everyone who helped me.

problem solved!


Chris H 04-20-2004 08:24 AM

Glad to hear it's working!

You just using Slack on the command line or have you got a window manager going?

CrazyHorse 04-20-2004 08:45 AM

I'm actually using Debian Woody as the slack install I tried
didnt like the CD I made up for it.

I'm running just a base install with 'x' installed as well.
I'm glad I did install x because there is no way I would have been
able to edit the lilo.config files with 'vi'.

My original goal of puttin Slack on has now been ditched and I think
I will use the Libranet 2.7 CD I have lying around. It definitely has a simpler
installation compared with Woody or Slack. If I can get the old 640MB
HDD that my friend has I am pretty sure I could set up a nice user friendly box with word processor, email, internet. (Keeping in mind this is a computer my technophobic mother-in-law will have to use).;)

I see that you use fluxbox. Is that customisable? I ask because I
would like to be able to setup a desktop for my mother in law with just a
few icons for the programs she will use and a shutdown button, nothing else.
Do you think this would be possible with fluxbox?

jolly1701 04-20-2004 08:50 AM

have u tried xandros its well worth a look at

Chris H 04-20-2004 09:10 AM


Originally posted by CrazyHorse
I see that you use fluxbox. Is that customisable? I ask because I
would like to be able to setup a desktop for my mother in law with just a
few icons for the programs she will use and a shutdown button, nothing else.
Do you think this would be possible with fluxbox?

Fluxbox is very customisable. But there's no 'start button' so may put technophobes off. Everything is right-click. Desktop icons aren'tnaturally supported but there are scripts that allow you to use desktop icons. IMO summat less geeky might be suitable for a technophobe. IceWM is nice and simple and low on resources.

All times are GMT -5. The time now is 08:49 PM.