-   Linux - Newbie (
-   -   Slackware - Running X - (EE) Screen(s) found, but none have a usable configuration. (

adchalk93 10-24-2010 09:51 AM

Slackware - Running X - (EE) Screen(s) found, but none have a usable configuration.

I'm totally new to linux and a more experienced friend advised me to install slackware if I want to get the best possible understanding of how linux works.

I've installed slackware but having logged in as root, when I type the command "startx" to load the GUI I get this error message:

(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 24 14:40:24 2010
(==) Using config file: "/etc/X11/xorg.conf"

(EE) intel(0): Given depth (4) is not supported by I830 driver
(EE) intel(1): [drm] failed to set drm interface version.
(EE) intel(1): Failed to become DRM master.
(EE) intel(1): Given depth (4) is not supported by I830 driver
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

When I try to check the log file that I am told to check, I get:
-bash: /var/log/Xorg.0.log: Permission denied "(i am logged in as root)"

I've tried running xorgsetup and changing the depth to 24,16,8,4,1 and 0, but I either get the same error message or a blank screen which forces me to reboot.

Running Xorg -configure gives the message:

(++) Using config file: "/root/"

Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Xorg has configured a multihead system, please check your config.

Your xorg.conf file is /root/

To test the server, run "X -config /root/"

When I attempt to test the server, I get a blank screen and am forced to reboot.

Running xrandr gives the message:
Can't open display

I've had a look around the forums for similar problems and someone with a similar issue was asked for the output of some code, so i'm typing my output for it here - it might save some time:

ls -l /dev/mem
crw-r----- 1 root kmem 1, 12010-10-24 15:37 /dev/mem

Any help in resolving this is much appreciated, thanks.

brianL 10-24-2010 11:47 AM

You might need to add a "normal" user, run this in the terminal:

adduser whatever name you want
Accept all the defaults (just press Enter), except when it asks about additional groups, then add lp (that's lowercase L). When it's finished, log out (exit) as root, log in as the name you chose, then run:

You can have booting into a desktop environment (KDE, or whatever) by editing /etc/inittab. Run:

kdesu kwrite /etc/inittab
Then root's password.
Change the 3 to 4 in this line:


adchalk93 10-24-2010 08:03 PM

I gave it a go logged in as a different user, but I got the same error message.

Thanks for the boot to GUI tips, I'm sure they'll have saved me some time later on.

adchalk93 10-28-2010 02:39 PM

Having searched around a bit more, it seems likely that my screen configuration might not be the issue. When I run: startx at a higher depth it could be that I am attempting to load the GUI with a screen configuration that is usable, and the blank screen I get is simply a result of x not being able to work properly - any suggestions?

adchalk93 11-01-2010 10:17 AM

Forced vesa driver on boot
I'm going to post my own solution to this:

I got X up and running by forcing the vesa driver.

I did this by running Xorg -configure which created an xconfig file at


I then ran "pico /root/" and under the section "Device" edited the following lines (Two "Device" sections appeared for some reason and I did them both):

Identifier "Configured Video Device"
Driver "vesa"

I then renamed the file to xorg.conf with the command:

mv /root/ /root/xorg.conf

Then I copied xorg.conf to /etc/X11 using:

cp /root/xorg.conf /etc/X11

Finally I hit startx and the desktop environment loaded, albeit with a few weird lines across the screen which dissappeared and only half visible commands flashing in the top section of the screen when I shut down, but it works and if what i've mentioned above are real problems, then hopefully I'll figure them out as I get a bit more experience at using linux.

I hope someone finds this helpful.

linus72 11-01-2010 10:34 AM

see this thread adchalk93

the SalixOS pkg is here

and just do "upgradepkg xf86-video-intel-2.11.0-i486-1gv.txz"
or whichever one you use? 2.91 or 2.11

then configure X again then startx

All times are GMT -5. The time now is 05:20 PM.