-   Linux - Newbie (
-   -   Slackware Internet connection problems w/ Intel 6050 Link wifi/wimax card (

milan_b 02-20-2011 10:11 PM

Slackware Internet connection problems w/ Intel 6050 Link wifi/wimax card
Hi, I'm a Linux newbie. Used to use Ubuntu, but I switched to Slackware because I want to learn how Linux works better.

On my Samsung qx410 laptop, I can't connect to the internet. I went to the System Settings -> Network Settings and all the tabs there, but it wouldn't detect any connection, wireless nor wired.

I noticed that the kernel of Slackware 13.1 is out of date, so I tried compiling a newer one, but I couldn't get that to work.

I tried downloading this file: iwlwifi-6050-ucode- but even after reading the readme, I had no clue how to go about installing it or even whether it was the right thing to install in the first place.

How can I get my internet working?

EDDY1 02-20-2011 10:20 PM

network on part5

milan_b 02-20-2011 10:32 PM

I've done the netconfig part already, I'm pretty sure its an issue with the drivers for my Ethernet card. I just have no idea which ones to install and how to install them.

EDDY1 02-20-2011 10:51 PM,122982

milan_b 02-20-2011 11:08 PM

I found the downloads that were linked to inside your link before. I tried the installation instructions on this page, but first they seem to be for an older kernel version and second, I tried it anyway and it did not work:

EDIT[Solved]: This apparently did the trick

The bottom most post

milan_b 02-21-2011 10:45 AM

Scratch that, apparently the wired network was working the whole time, but wireless still does not work.

I ran:

rmmod iwlagn
rmmod iwlcore
modprobe iwlcore
modprobe iwlagn

but wicd still doesn't find any wireless networks.

I know there must be some way to get the wireless working because it worked in the latest version of Ubuntu.

drfrostbyte 03-28-2011 03:43 PM

where did you get iwlwifi-6050.ucode?

All times are GMT -5. The time now is 09:44 PM.