-   Linux - Newbie (
-   -   Slackware Install HelpVFS: unable to mount root fs (

neo.sarcastic 03-05-2004 07:11 PM

Slackware Install HelpVFS: unable to mount root fs
The error:
Kernel Panic: VFS: unable to mount root fs on 03:01

This is what I get, sometimes there are other errors but never the less i am having some serious problems installing slackware 9.1. I have an IDE 40 GB, I am installing the default VMlinuz kernel (when asked for which kernel i chose skip, which will use default) these are my partitions, they are all setup using fdisk b4 the setup is intiated. I have a swap of 768mb, / is 5gb
/home is 5gb
and /usr is 5gb.

i am installing lilo on the root partition not the MBR, (only OS on drive) Whats the deal?

Any pointers or something in this that is wrong?

Thanks for any help,


pablob 03-06-2004 05:32 AM

Excuse me for being so obvious, but why not try another kernel and install LILO on MBR (which for me has always been healthier).
Anyway, this kind of error usually appears when you choose a kernel without support for your file-system type. I.e.: Using a old 2.2 kernel and ReiserFS type. (Or a modern kernel compiled without support for ext3 ,.....), so I'll try another kernel. Have you got a boot disk ?

320mb 03-06-2004 09:46 AM

try installing the bare.i kernel, it has generic support for all the different filesystems.........then you can re-compile it for exactly what you want.

maroonbaboon 03-06-2004 09:54 AM

Well, the kernel was found and loaded, otherwise it wouldn't be able to panic. Any more lines in the error message? Check /etc/lilo.conf and /etc/fstab to see if they agree on what the root partition should be. Maybe post these files if the answer is not obvious.

Pablob's suggestion that the kernel cannot read the filesystem is also possible, and /etc/fstab will also show the filesystem types.

nirva 03-06-2004 11:08 AM

I'm getting the same error. I chose the bare.i kernel, but I'm trying to upgrade to the 2.6.0 kernel. I go through menuconfnig and I made sure that I had support for ext3 (what I made my / partition) and I still got that message.

neo.sarcastic 03-10-2004 03:48 PM

i actually feel really stupid...but should I?

I found that i was making the first partition the swap partition and the thing would not boot, by making the first partition the root partition it worked.... duh?

All times are GMT -5. The time now is 11:11 PM.