-   Linux - Newbie (
-   -   Slackware graphics crashes on startup (

cmgeo 10-07-2011 12:35 PM

Slackware graphics crashes on startup

My system configuration is
amd athlon x2 4 core
nvidia nforce 630a/7025 geforece
monitor 1600x900 lg

i am currently trying different versions of linux and just learning them. i have basic progrmming knowledge on linux.

i had previously installed on my system the following linux distributions

knoppix: latest version to hard disk - runs perfectly
suselinux : latest version. at first i had trouble starting x but figured out that in safe mode it was logging in and i think (because i am not remembering it now) that the keyword that was requried to boot into graphical menu was 'nomodeset' on grub

all the above had been removed.

debian squeeze 64 bit: currently installed and working great.

now i installed the the Slackware on separate partition but didn't install the lilo. thought i would be able to configure grub to load it and it does load.

my problem is that i can't start X either by running xinit or startx. because they crash and hang my system

now with my suse experience i inserted nomodeset on grub line for slack; now it crashes the x server on starting it with message screens found but none usable.

well the reason i am hopping through distributions is that i want to develop a custom software that could be run on usb. I figured that i could develop the software on debian with great ease but could not give it away on usb without the users being provided an installed system. hence i googled and found that slackware can be packaged on usb and would be running my custom software.

but nog x means not good interface i would be able to provide. so please guide how should i make x run on my system.



markush 10-07-2011 12:52 PM

Hello cmgeo, welcome to LQ,

could you please provide more information? do you have a /etc/X11/xorg.conf file?

Do you know which graphicsdriver (module) there was running on Debian or Suse? Which version of Slackware do you have installed? Which kernel?

Could you please post the output of

lsmod | sort

lspci -k | grep -iA4 vga

cmgeo 10-07-2011 01:21 PM


well these are what i got from slackware


Module Size Used by
agpgart 22762 2 ttm,drm
asus_atk0110 9467 0
button 3965 1 nouveau
drm 141858 3 nouveau,ttm,drm_kms_helper
drm_kms_helper 23887 1 nouveau
evdev 7209 4
forcedeth 46885 0
fuse 56668 5
hwmon 1017 3 k10temp,asus_atk0110,thermal_sys
i2c_algo_bit 4279 1 nouveau
i2c_core 16377 5 nouveau,drm_kms_helper,drm,i2c_algo_bit,i2c_nforce2
i2c_nforce2 4440 0
ipv6 228913 17
k10temp 2123 0
lp 7073 0
nouveau 506264 1
output 1448 1 video
parport 25111 3 lp,ppdev,parport_pc
parport_pc 18186 1
ppdev 4861 0
processor 20234 0
psmouse 40978 0
rtc_cmos 7650 0
rtc_core 11475 1 rtc_cmos
rtc_lib 1494 1 rtc_core
serio_raw 3502 0
sg 20923 0
shpchp 23261 0
snd 43347 11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_via,snd_hda_intel,snd_hda _codec,snd_hwdep,snd_pcm,snd_timer
snd_hda_codec 61720 2 snd_hda_codec_via,snd_hda_intel
snd_hda_codec_via 44880 1
snd_hda_intel 18021 0
snd_hwdep 4764 1 snd_hda_codec
snd_mixer_oss 14750 1 snd_pcm_oss
snd_page_alloc 5917 2 snd_hda_intel,snd_pcm
snd_pcm 57713 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_pcm_oss 34555 0
snd_seq 39269 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 4465 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_seq_dummy 1111 0
snd_seq_midi_event 4560 1 snd_seq_oss
snd_seq_oss 25075 0
snd_timer 15225 2 snd_seq,snd_pcm
soundcore 4545 1 snd
thermal_sys 11442 2 video,processor
ttm 42352 1 nouveau
video 10442 1 nouveau


00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
Subsystem: ASUSTeK Computer Inc. Device 83a4
Kernel driver in use: nouveau
Kernel modules: nouveau, nvidiafb
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration

I do indeed have created the xorg.conf file by using the xorgsetup but to no avail.

my Slackware version is: Slackware Linux version 13.37 32-bit x86 DVD.

thanks again.


markush 10-07-2011 02:45 PM

I‘d suggest that you try the nvidiafb module, be sure to blacklist nouveau.


colorpurple21859 10-07-2011 03:09 PM

There is one of Three fixes.
1. Install 3.6.38 kernel and other packages from testing.
2. Use the nvidia driver from the nvidia web site.
3.created a nouveau-kms.conf file in /etc/modprobe.d with the following text.

options nouveau noaccel=1

cmgeo 10-08-2011 05:33 AM

Hello all,

after burning the midnight oil this is what i got, although not sure what actually worked.

i checked slackware website again and there i found to configure the X i have to use the following

X -configure
also it specified using another file saved elsewhere which it created and said should be used.

after making the changes i again googled for more information. and changed to another window manager lxde using pkgtool.

startx worked and ran perfectly. after that i tried with kde but it crashed with errors and only exited with Ctrl+C.

then shuffling through google again i found that to modify etc/inittab entry for runlevel to 4 from 3 (which was current)

okay this time user login was graphical but default window manager was kde and was not working. all other window managers including kde(failsafe) work perfect.

leaving the above small problem i think my problem is solved for now.

colorpurple21859 10-08-2011 08:34 AM

If your a gamer you would want to install the Drivers from Nvidia's website to get KDE to work.
For normal task, installing the packages from testing would be better as that will stay in line with future updates/upgrades. Creating a file in /etc/modprobe.d is a quick fix that disables acceleration on the graphics card which in effect disables 2d/3d effects. Kde failsafe I believe disables 2d/3d effects and that is why it still works versus Kde with special effects that doesn't work.

All times are GMT -5. The time now is 06:25 AM.