-   Linux - Newbie (
-   -   Slackware and XUbuntu dual boot. (

Neej Suab 12-12-2007 08:38 PM

Slackware and XUbuntu dual boot.
Ok, So i am a linux noob. But i am learning. I have been running Xubuntu on my toshiba laptop sucessfully for a 4 months. I got board and decided to dual boot with slackware so i can learn more about linux and stuff. I have run into a problem that i don't understand and don't know where to turn to find solutions. So I decided to ask. I have 4 partitions, swap, two 5 gig partitions for the distros and a 40 gig "home" partition. So during the instilation of slackware i told it to install to hda3, then it asked if i wanted any part of the os on any other partition, so i told it to put the /home mount on the 40 gig. I think that was my mistake. Now I can run slackware just fine, but if i run xubuntu i get an error during boot that says fsck.ext3 unable to resolve uuid="lots of numbers and letters"
fsck died with exit status 8
file system check failed
login as root to fix or press control-d

or something very close to that. If i press control-d it goes to gui login. i log in and it gives me a user's $Home/.dmrc file being ignored something about no one else can have rights or something close to that. But it boots normall and everything works. sorry i don't have specific error messages. I am looking to learn about this not just have a quick fix. Thank you much for your help.

My thoughts: I assigned slackware to the same home folder and xubuntu doesn't like that. But i'm not sure. I'm going to play with the install cd and see if i cant change that home folder thing in slackware then reset folder rights. Can i set up so booth can use the bigger partison as a home folder without messing eachother up?

AceofSpades19 12-12-2007 09:00 PM

Did you format the 40 gb partition?, it also might have been better to give slackware a different user name then the one you use for xubuntu

Neej Suab 12-13-2007 11:14 AM

I did not format the 40 gig. Booth xubuntu and Slackware can mount and see all information on the drive. Booth open the home folder as they should, and all data is on the drive. When installing slackware it never asked for me to add a user, only root, and i have yet to add another user.

jfxg 12-15-2007 11:02 AM

I have slackware and ubuntustudio working. If you don't know partitions are mounted at boot time from a file /etc/fstab. In fstab the first field is the device to mount. Slackware uses the device file to specify this, ubuntu and some others use the UUID. When booting ubuntu copy down the full UUID and then boot to slackware and login as root. use the following command to look at the UUID's on your machine:

ls -la /dev/drive/by-uuid
this gives you the simlink by uuid and points to the device file.
Mount the root partition for ubuntu look at fstab for the failing UUID and edit it for the correct UUID. These are changed when you mess around with the file systems. It would be helpful to know where and how you got the partition for slackware. If you don't know the messages for this we can help.

jfxg 12-15-2007 11:45 AM

About your second issue.
Slackware doesn't create a user or boot to a GUI. If you want a GUI than type 'startx' without the tic's, if KDE doesn't start than you will need some help with xorg.conf. It's not recommended that you use a GUI as root but you can use it as a short cut to create a user. To do it from the command line look at 'man useradd' If you want to learn Linux than slackware will do it. look at the following links for a start at some help:
If it becomes an issue to boot directly to a GUI then someone here can help.

Neej Suab 12-18-2007 07:02 PM

Thanks you so much for the help so far. I seemed to get the hard drives mounted properly and now don't get the fsck error. I now get an error after i log in to Xubuntu that says "User's $Home/.dmrc file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permissions. User's $Home directory must be owned by user and not writable by other users."

Also i tried to create a user in slackware, but couldn't quite figure out the useradd command. I read man useradd. I tried just useradd username. also a with a few switches but i couldn't log in as the users i would create and no folder would appear in the /home directory. I will do some reading 'bout the useradd and figure hopefully figure that out, but it's finals week so i don't know what i will have time for.

also you asked where my slackware partition came from. When i installed my Xubuntu i created 4 partitions. A swap, my xubuntu partition, a blank parition, and my home partition. I then installed xubuntu. Now a few months later i decided to install slackware so i installed root on the blankpartitions and used the home parition as booth xubuntu and slackwares home partition. I hope that answers your question.

onebuck 12-18-2007 07:32 PM


To add a user in Slackware use the 'adduser' from the cli as root.

You could create the new user that is different from the one you use for Xubuntu. That way you won't have some of the problems you have developed.

Be sure to add the new user to the proper groups.

Neej Suab 12-18-2007 07:51 PM

That was a fast Reply. I had just figured out the adduser thing. and i reset the permisions for my ubuntu users folder and it worked. Booth boot with no problems. I'm super thankfull for your help. And i'm excited to start slacking. Lol.

All times are GMT -5. The time now is 06:56 AM.