-   Linux - Newbie (
-   -   slackware 8.1 startx (

k3v0 11-09-2002 12:50 PM

slackware 8.1 startx
k im a newbie i just installed slackware 8.1 on my p4 box. since slack doesnt auto config X like mandrake and other newbie distros im kinda lost. i installed slack and it was pretty easy no problems at all. so when i boot the boxs i login as root and im stuck at CLI and not sure how to config X i tryed "X -configure" and it output a new xfree config file "/root/" then i tested the config "XFree86 -xf86config /root/"
and it worked i think the black and grayish dot screen with the X as the mouse pointer came up then i have to alt + ctrl + backspace to get back to the CLI. but now when i "startx" is gives me the error below is there anything else i should do and i forgetting anything???

root@1500p4:~# startx

XFree86 Version 4.2.0 / X Window System
(protocol Version 11, revision 0, vernder release 6600)
Release Date: 18 January 2002
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/)
Build Operating System: Linux 2.4.18 i686 [ELF]
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "var/log/XFree86.0.log", Time: Sat Nov 9 18:18:07 2002
(==) Using config file: "/etc/X11/XF86Config"
(EE) VESA(0): No matching modes
(EE) Secrren(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to

XIO: fatal IO error 104(Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

my system config:
p4 1.5ghz
256mb rdram
msi i850 mobo
gf2 mx400 <--i think not sure what ver gf2
WD 40gb
realtek chipset 10/100nic

DavidPhillips 11-09-2002 02:02 PM

are you going to use wmaker or some other window manager?

if it's wmaker then run wmaker.inst and it will put the needed files in your home folder and setup your .xinitrc file like this

# Window Maker default X session startup script


# If you login from xdm, uncomment this to make error messages appear
# in the console window.
# tail -f /root/.xsession-errors > /dev/console &

exec wmaker

You could also do it yourself using your window manager of choice.

if you want a system default for users use the /etc/X11/xinit/xinitrc file

slackware has wmconfig and xwmconfig

you can run one of them to setup your window manager or you could go into X using this...


you will be in X with an xterm but no window manager

now you can run xwmconfig

Mephisto 11-09-2002 02:41 PM

Did you remember to copy /root/ to /etc/X11/XF86Config?

k3v0 11-09-2002 11:59 PM


Did you remember to copy /root/ to /etc/X11/XF86Config?
nope i didnt copy it to /etc/X11/ lol i feel dumb o well i did now it works thanx :D

All times are GMT -5. The time now is 02:58 AM.