-   Linux - Newbie (
-   -   Slackware 13.1 32 & 64 bit Post-Install issues in VMWARE (

Slackn00ber 09-03-2012 07:53 PM

Slackware 13.1 32 & 64 bit Post-Install issues in VMWARE
First off, I tried to search EVERYWHERE on the internet for this issue but didn't find it so don't flame a n00b trying to learn :/

I installed Slack 13.1 back when when I had Win xp as the host through VMWARE with no problems but now I have Win 7.

I have tried multiple installs and configs of Slack 13.1 in Win 7 but I continue to get the same errors.

Here is the error that occurs after installation when the system asks you to change root password :

anything from a 1.5 gb swap to a 2gb swap was tried and 4gb for home and 4gb for usr and 30gb for root.

If i cancel that, exit setup, and go back to command line, the system wont reboot from command line only ctl alt del..then when I reboot..or close and start VM hangs...

Any Ideas? I tried a default install of '8 GB' from VMWARE and it worked fine with a 1gb swap, and just a root with what was left..I dont want to be limited to that small if possible since I will need multiple gb to runa bbs, and mail server, msql, website, and file storage exceeding 300gb..



Didier Spaier 09-04-2012 02:10 PM

Hello and welcome to LQ.

If anything, this looks like more as a corrupted ISO image than as a VM setting problem.

So my advise would be to check the md5sum of your ISO image(s) against one or more of the .md5sum files available here.

Also, if you use a physical media like a CD or DVD to proceed to the installation, may be you could try to re-write one at a lower speed.

As a side note, Slackware 13.37 is available and Slackware 14 will be released in few weeks at most ;)

Slackn00ber 09-04-2012 06:51 PM

Thank you for the quick response :) I never would have thought to check the MD5 as it would install fine with just a swap and root, but not with additional partitions. I figured it wouldn't have worked at all if it was corrupt. It turns out the 13.1 32 bit ISO failed the MD5 check and the 64 bit version locks up the MD5 checker for some reason. I'll go ahead and download the 13.37 versions and look forward to Slack v14.

I appreciate the help and hope to become a contributor on here one day.

Thanks again :)

Didier Spaier 09-04-2012 07:22 PM

I wish you the best experience with Slackware. Feel free to visit the Slackware forum to get help.

And yes, I'm sure you will be soon helping others as well there. :cool:

Slackn00ber 09-06-2012 05:38 AM

After downloading 13.37 32 bit, and playing around with a few things, I determined a few things and am still a little puzzled.

Back when I was first Learning Linux and everything ran fine I was only using a Swap and / partition. I tried this setup again yesterday and it worked like a charm. I booted into Slack and had my system up and running like a champ. For a deeper experience I was trying to get a little more complicated and use a Swap, / , /home, and /usr partition. (Thats what i originally tried to do when i ran into trouble and created this post.) I did some poking around and found errors relating to disk space. I decided to make my partitions 30gb each ( other than swap which I kept at 1gb). The install worked perfectly and the disk space errors went away. I figured now I could boot up and check disk space and then do a fresh install with more accurate partition sizes. Now I am left with new problems, such as commands not working and startx attempting to load and then killing its process.

Am I missing something extra I am supposed to do when creating separate partitions? I assumed the slack install would have partitions mounted automatically. Are there manual changes I need to make post-installation? I tried searching on this problem and was at a loss. I guess I'll go back to just a swap and root for now just so I have something to continue learning with.


wigry 09-06-2012 07:41 AM


As the hardrives are big enough, the partitioning is actually mor like an academic exercise - no practical reason other than learning how to do it.

If your system is on many partitions, then all those prrtitions must be mounted corrently (read-write and automoatically mounted on bootup) and must be accessable. You can see the ouput of mount command to see what is mounted where. Also give us the content of /etc/fstab file. That file controls what partitions, how and when are mounted. Also what file systems did you use for the partitions?

Slackn00ber 09-06-2012 05:14 PM

Ok here we go.

Here is the info from df command :

Filesystem 1k Blocks Used Available Use% Mounted on
/dev/root 19228308 5569464 12682092 31% /
/dev/sda3 24027656 176180 22630940 1% /usr/local
/dev/sda4 38348616 180108 36220496 1% /home
tmpfs 508984 0 508984 0% /dev/shm

Here is the info from mount :

/dev/root on / type ext4 (rw,relatime,barrier=1,data=ordered)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/sda3 on /usr/local type ext4 (rw)
/dev sda4 on /home type ext4 (rw)
tmpfs on /dev/shm type tmpfs (rw)

Here are the contents from fstab :

/dev/sda1 swap swap defaults 0 0
/dev/sda2 / ext4 defaults 1 1
/dev/sda3 /usr/local ext4 defaults 1 2
/dev/sda4 /home ext4 defaults 1 2
#/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0

It's strange how installing with just / and swap works fine but adding separate directories do not. I know separating directories isn't necessary but I wanted /home and /usr separate in case I decide to upgrade or have issues.

On a side note, I only performed the install so far and have modified nothing except creating a root password as installation asked. Upon trying to reboot as installation suggests, I get an error about have to run the shutdown command in PID 1.

Thanks in advance.

Slackn00ber 09-09-2012 06:21 PM

Ok so it seems I have solved every issue except one. STARTX crashes as the first icon is loaded on the splash screen. I have tried removing the xorgconf-vesa file and it did not help. I have searched everywhere for a solution but can not seem to find my issue. It is installed in VMWARE so I would assume the detected "hardware" would be generic.

Any ideas or default conf files that can be used?

Slackn00ber 09-09-2012 06:30 PM

Belay that.

Apparently when trying to disable composite I mistyped something. All appears to be well. Guess we can close this one out.

Thank you to the friendly community for your help :)

All times are GMT -5. The time now is 04:57 AM.