-   Linux - Newbie (
-   -   Slackware 12: KDE Font problems (

Malitz 05-05-2008 02:30 AM

Slackware 12: KDE Font problems
Hi all,

I am a Linux newbie and I'm having some serious difficulty getting KDE to behave with any sort of font consistency.

I have a 32" Sony LCD TV/Monitor that I am using in conjunction with a KVM switch to jump back and forth between my Windows box and a box running Slackware 12. The Slackware box is a Dell Optiplex GX270 and has an Integrated Intel ExtremeŽ Graphics 2 video card. My resolution is set to 1360 x 768.

When I first started up KDE with Slackware, all the fonts were tiny and illegible (forced fonts DPI off). When I tried resizing the fonts from the control center, the results were very disproportionate. For example, at the default size, the main K menu is illegible. However, if I change the size to make the K menu legible, all my application toolbars become huge and disproportionate. The same is true for the "General" font; it is too small at its default value for me to see some types of general text displays, but if I raise it, the text in applications becomes massive.

Now, if I try to turn forced fonts DPI on (96 DPI), I can adjust my fonts so that everything looks great ... until I open up any application and then everything looks oversized and distorted again. So, to summarize, here is what I've tried:

- When fonts are small, I tried turning on forced DPI and that worked for everything except my applications, in which all the fonts became massive and distorted
- When I keep forced FPI off, I can tinker with my fonts so that everything looks normal except my menus and text

I've tried messing with xorg.conf as suggested in some threads, but to no avail. Curiously, any modifications to my resolution had no effect at all, so I must not be doing something correctly. For example, I tried modifying the following line:

DisplaySize 1280 x 768 # mm
DisplaySize 359 201 # 96 DPI @ 1360 768 mm

This didn't really accomplish anything, although I'm sure its possible I botched the syntax. I also tried adding a line to the files section as suggested in other threads:

FontPath "/usr/share/fonts/100dpi/:unscaled"

... but this didn't help either.

I'm not quite sure what the root of the problem is. If anyone can help, it would be greatly appreciated. Thanks in advance!

viron 05-06-2008 03:22 PM

Have you tried going into the Control Panel -> Fonts ? Check that box that says "Adjust all fonts" and select the desired font size that looks decent. You might also need to adjust the size of the icons as well under that sub-menu.

Malitz 05-06-2008 04:06 PM


Originally Posted by viron (Post 3144892)
Have you tried going into the Control Panel -> Fonts ? Check that box that says "Adjust all fonts" and select the desired font size that looks decent. You might also need to adjust the size of the icons as well under that sub-menu.

Yes, that doesn't work. The problem remains that the fonts are disproportionate. =(

viron 05-06-2008 05:51 PM can always try adjusting the resolution.

Malitz 05-06-2008 11:04 PM


Originally Posted by viron (Post 3145034) can always try adjusting the resolution.

Currently, my font settings are all set to size 28, with forced font DPI turned off and anti-aliasing set to "system settings". Everything looks fine (Desktop, menus, etc) until I try to open an application. For example, I open up Wireshark and the fonts are so tiny that everything is illegible. Now, if I open up Wireshark on my Windows box with the same resolution settings, everything looks fine. That leads me to believe that this is not an issue of resolution or a display problem that is specific to the Wireshark software, but rather an issue of video resolution related to the Linux OS.

I can adjust the resolution on my Linux box (make it smaller), but that doesn't address the issue that I'm having. It seems this has to do with the configuration of the fonts through KDE.

Here's another thing I'm not quite understanding: I've read that the xorg.conf file can be manipulated to change display settings, yet any changes I make to that file are not reflected in the KDE output. For example, in the "Monitor" section of xorg.conf, I've chnaged the display to a bunch of different resolutions, yet the resolution in KDE always remains the same. :S

Malitz 05-07-2008 10:21 PM

Here's another display problem I'm having:

My monitor is capable of 1360x768 resolution. Vertical/Horizontal frequencies are to be respectively set at 60/47.7, according to manufacturer's specifications. Now, by default, Linux sets these frequencies to some odd ranges, and the result is these awful continuous "waves" in my KDE display. Needless to say, I have a headache after like 5 minutes of looking at it.

Now, when I try to change the refresh rates in xorg.conf to static numbers, the KDE won't even load. It totally refuses my changes. Now if I change my VF/HF to 1024x768 standards (75/60), the display is crystal clear. The point is, I don't want 1024x768. I want 1360x768 resolution. How can I achieve this and impose the correct VF/HF on the KDE?

All times are GMT -5. The time now is 06:29 AM.