-   Linux - Newbie (
-   -   slackware 12 forgot install lilo (

AerS 01-21-2008 08:28 AM

slackware 12 forgot install lilo
Hi again (:

I just install slackware 12 in my pc with windows xp...
Thinkin in have grub for boot loader i SKIP the liloconfig in slack install
to configure grub later..
BUT.. when the slack install over, it asked to reboot.. so what happen? the
the PC load windows(omg! ^^)

what can i do now? can i download files on net for lilo or grub to load it from disket ? or there is another way to configure boot ?!

thank you

cya :D

Alien Bob 01-21-2008 10:25 AM

You can install lilo by booting from the Slackware install CD (or DVD) again. You can tell the installer to start the Slackware that sits on your hard disk! There, you can run "liloconfig" and install lilo to fix your problem.

When the CD boot-up is complete you will see the message on-screen:

In a pinch, you can boot your system from here with a command like:

boot: hugesmp.s root=/dev/hda1 rdinit= ro

In the example above, /dev/hda1 is the / Linux partition.

This is what you should do. If your root linux partition is something other than /dev/hda1 you should use that device in the command of course.

Now, the Slackware that you installed on the computer will start. You log on as root, with the password you supplied during setup. Then run

and follow directions. Since you already have MS Windows installed on your PC, the best option would be to install lilo into the MBR and let "liloconfig" detect and add your Windows partition as a selection in the lilo menu.

If that scares you, you will have to install lilo into the Slackware root partition, and then adapt C:\boot.ini so that Windows adds an entry to start Slackware in the Windows bootloader menu. You will have to read a Windows/Linux dualboot howto if you do not know what is required to let Windows boot your Slackware installation. Google for "linux windows dualboot dd 512"


AerS 01-21-2008 11:56 AM

thank you Alien Bob :)
it works!
Cya =@

All times are GMT -5. The time now is 06:44 PM.