-   Linux - Newbie (
-   -   Slack problems 1)incomplete shutdown? 2)starting a service (

koodoo 06-07-2005 07:59 PM

Slack problems 1)incomplete shutdown? 2)starting a service

I recently installed Slackware 10.0

I am facing a few problems.

1) Whenever I give a command to shutdown the P.C. (init 0, poweroff, shutdown -h now)

Slack shuts down all processes and leaves me at a console saying "Power down" and the cursor blinking under it, but it does not switch off the P.C. and I have to do that manually.
How do I automate the process so that Slack completely shuts down the P.C. instead of me doing it manually all the time.

2) How do I start a service? :newbie:
In particular what do I do if I want to start the sshd daemon. (I don't want it to be started at startup --for that I'll have to edit the rc.local file.-- I just want to start it when the P.C. is already booted up).

a slocate on sshd gives :

root@knapsacker:~# slocate sshd

Thanks in anticipation.

tangle 06-07-2005 09:00 PM

Starting the apm daemon should shut the PC off completly. There should be a line that is commented in the /etc/rc.d/rc.M file. Uncomment it to start the apm daemon at boot.

To start the ssh daemon.
/etc/rc.d/rc.sshd start

There are a few startup scripts in the /etc/rc.d directory.

tw001_tw 06-07-2005 09:04 PM

1) power off
Locate and edit the file /etc/rc.d/rc.modules

UNcomment the line: /sbin/modprobe apm

If your using the default 2.4.xx kernel that comes with Slack 10, I think this will do it
(after you reboot of course).

2) Starting services

The easiest way is to type: pkgtool
then -> setup -> services
(then it'll load on every boot)

I'm going off memory (my slack is not turned on right now). Check the processes you
want to load on startup.

good luck

koodoo 06-07-2005 09:49 PM

Thanx a lot for the help.

uncommenting /sbin/modeprobe apm
worked and now the P.C. shuts down completely :D

For starting the service :

I had tried /etc/rc.d/rc.sshd start before and got an error message and so I thought I was wrong somewhere :


root@knapsacker:~# /etc/rc.d/rc.sshd start
-bash: /etc/rc.d/rc.sshd: Permission denied

But this time I figured it out. :D .Lucky me. :cool:

I was running this as root but still getting the permission denied error because the script was not executable. (wasn't it supposed to be in the first place ?)

So I did :

root@knapsacker:~# sh /etc/rc.d/rc.sshd start

and it worked!!!!.

I could also have made it executable but I didn't want to change it in any respect.

Thanx again a great deal for your help :)

tangle 06-08-2005 09:32 AM

If you do not set the service to run at boot when installing the OS. The permissions are not set to executable. Slackware does not start services unless they are neccessary. But to make it start at boot you can chmod 755 the file and it will start the next time you boot.

I hope you like Slack as much as I do.

koodoo 06-08-2005 11:22 AM

Thanx for the help.

Slackware sure "rocks". :D It's made my P.C. work faster than it had ever been. I hope to enjoy it a great deal as I spend more time with it.

Thanks again.

All times are GMT -5. The time now is 11:32 AM.