LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2005, 03:01 PM   #1
JRR883
Member
 
Registered: Aug 2005
Location: God's barf bag
Distribution: Ubuntu 7.04 (Feisty Fawn)
Posts: 86

Rep: Reputation: 15
Slack 10.1: Booting KDE


I just installed Slackware on /dev/hda5 (dual-booting with WinXP Pro). I can't get Lilo to run at boot, so I'm having to boot with the bootdisk I made during installation. I do that, login as root, and I have a prompt, something like darkstar@slackware, I'm sure you know what I'm talking about. What is the command to boot into the KDE GUI?

Also, how would I get Lilo installed? I had it installed during the installation process, but it won't load during bootup, as mentioned before.
 
Old 08-27-2005, 03:14 PM   #2
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,152

Rep: Reputation: 60
Make a regular user first with the adduser command. After that you can login as regular user. As you might know, logging in as root is not advisable for number of reasons.

After adding a regular user, you can issue the following command to start kde

Code:
startkde
For lilo, you can login as root and issue the following command

Code:
liloconfig
and don't forget to install it on /dev/hda (or whatever is your primary master hard drive)

-Tux,

You can also edit /etc/inittab file and look for line

Code:
id:3:initdefault:
Change that "3" to "4" and you will get a graphical login (like gdm, kdm or xdm). I believe you would have to configure the default graphical login.

Last edited by tuxrules; 08-27-2005 at 03:19 PM.
 
Old 08-27-2005, 04:03 PM   #3
JRR883
Member
 
Registered: Aug 2005
Location: God's barf bag
Distribution: Ubuntu 7.04 (Feisty Fawn)
Posts: 86

Original Poster
Rep: Reputation: 15
Okay, I have Lilo installed properly: thanks for that. I tried startkde and it gave me this:
Code:
kde-config: error while loading shared libraries: libart_lepl_2.so.2: cannot open shared object file: no such file or directory
/opt/kde/bin/start kde: line 138: xset: command not found
/opt/kde/bin/start kde: line 141: xset: command not found
/opt/kde/bin/start kde: line 144: xset: command not found
/opt/kde/bin/start kde: line 154: xsetroot: command not found
startkde: Starting Up...
kreadconfig: error while loading shared libraries: libart_lgpl_2.so:cannot open shared object file: no such file or directory
ksplash: error while loading shared libraries: libart_lgpl_2.so:cannot open shared object file: no such file or directory
kdeinit: error while loading shared libraries: libart_lgpl_2.so:cannot open shared object file: no such file or directory
startkde: Could not start kdeinit. Check your installation.
/opt/kde/bin/startkde: line 207: xmessage: command not found
Warning: connect() failed: : no such file or directory
ksmserver: error while loading shared libraries: libart_lgpl_2.so.2: cannot open shared object or file: no such file or directory
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
/opt/kde/bin/startkde: line 232: artsshell: command not found
startkde: running shutdown scripts...
startkde: Done
user@darkstar:~$
Any suggestions?

Last edited by JRR883; 08-27-2005 at 07:50 PM.
 
Old 08-30-2005, 12:54 AM   #4
JRR883
Member
 
Registered: Aug 2005
Location: God's barf bag
Distribution: Ubuntu 7.04 (Feisty Fawn)
Posts: 86

Original Poster
Rep: Reputation: 15
Bump, this issue is pissing me off.

Also, I cannot use the startx command. It says it's not a valid command, which is total bullshit. Should I just reinstall the packages?
 
Old 08-30-2005, 07:08 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Did you run xorgconfig after you installed Slackware?
 
Old 08-30-2005, 09:53 AM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
When you have configured your xserver, you may also need to run "xwmconfig" and select KDE as your default desktop so that an .xinitrc or .xsession file is created which will start KDE correctly.
 
Old 08-30-2005, 04:27 PM   #7
JRR883
Member
 
Registered: Aug 2005
Location: God's barf bag
Distribution: Ubuntu 7.04 (Feisty Fawn)
Posts: 86

Original Poster
Rep: Reputation: 15
I ran xorgconfig and the command was not found. I ran xwmconfig and selected KDE as default, as I had before, and when I ran startkde it gave me the same error log.
 
Old 08-30-2005, 04:52 PM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
I ran xorgconfig and the command was not found.
Were you root when you ran this command? If you didn't run it after install, you're not going to get X to work until you do. It should be in /usr/X11R6/bin.
 
Old 08-30-2005, 04:55 PM   #9
JRR883
Member
 
Registered: Aug 2005
Location: God's barf bag
Distribution: Ubuntu 7.04 (Feisty Fawn)
Posts: 86

Original Poster
Rep: Reputation: 15
Yeah, I was in root. Still didn't work.
 
Old 08-30-2005, 05:00 PM   #10
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 60
login as root and try xorgconfig again

edit: lol whoops too slow. disregard then.
 
Old 08-30-2005, 06:11 PM   #11
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,594

Rep: Reputation: 125Reputation: 125
I guess you logged in as normal user and switched then with su to become root. In this case you might not get the right PATH settings, so that commands in /usr/X11R6/bin are not found. You can either log in as root from the beginning (right after booting up when the first login appears) or you could execute the commands with the right path, for example type /usr/X11R6/bin/xorgconfig to get it started

Edit: To make it clear, xwmconfig and startx also reside in the same directory /usr/X11R6/bin, so to start them you would have to do the same and type them in with the path before them. If you cannot start the "startx" command as normal user look for "PATH" here on linuxquestions, you will find many threats on it and how to add additional directories to it. You could just look at the file /etc/profile for this. This is where the PATH is defined systemwide.

Last edited by titopoquito; 08-30-2005 at 06:18 PM.
 
Old 08-31-2005, 04:36 AM   #12
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
Quote:
Originally posted by JRR883
I ran xorgconfig and the command was not found. I ran xwmconfig and selected KDE as default, as I had before, and when I ran startkde it gave me the same error log.
You need to run "startx" and not "startkde" when you xserver has been configured and you have chosen KDE as your default desktop afer running "xwmconfig".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sLACK NOT BOOTING UP slackermike Slackware 3 10-14-2005 02:33 PM
Need help booting Slack number11 Slackware 6 04-25-2005 11:51 AM
New Slack install not booting mapesju Slackware 6 08-27-2004 04:29 AM
Problem booting Slack 9.1 from CD xbenx Linux - Newbie 2 04-14-2004 01:25 PM
Booting slack 9 errors nixnoobie Slackware 6 06-05-2003 07:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration