-   Linux - Newbie (
-   -   Skype won't install on Mandriva 2007 x86 64 (

BLACADDER 11-01-2006 06:54 PM

Skype won't install on Mandriva 2007 x86 64
I'm running Mandriva 2007 dual boot with XP, but can't install Skype.
Auto installer tells me that isn't satisfied, and manual install says no such file or directory, which isn't true. The version I'm trying to install is "Skype for Mandriva 10.1 or greater" (skype-
Can anyone please help?

albhaf 11-02-2006 07:02 AM

The problem might be that you are trying to install a pre-compiled version of Skype for i586 while you seem to be running a x86_64 version of Mandriva.
Try to find a version of Skype for x86_64 since the libraries might be differnet depending on your architecture.

Only time I installed on a x86_64 was a sloppy system with Gentoo so my knowledge in this is limited :rolleyes:

BLACADDER 11-03-2006 01:58 AM

Thanks albhaf, I rather suspected the same thing myself but where the heck do I find a x86_64 version? The name Skype doesn't appear in any rpm site that I have tried, and the only source for it seems to be the official Skype website.
By the way, my knowledge is more than just limited. It's non-existent! I've only had Linux for a week!:newbie:

albhaf 11-04-2006 05:10 AM

There might be another sollution, just found out that is a part of the xorg-x11-libs package.
Make sure that you have this one installed and try installing Skype again.

The package should be on one of your installation cd's but the name might be a
bit different since I've seen it named xorg-x11-devel and other similar names in several places.

BLACADDER 11-05-2006 01:58 AM

Thanks albhaf.
I found xorg-x11-devel on hard disk and installed it along with all its dependencies?, but the problem remains. Error message says could not install all packages, isn't satisfied.

albhaf 11-05-2006 05:18 AM

Did you install xorg-x11-devel or a package with a similar name?
There seems to also be a version of these libs for 64 bit which is named lib64xorg-x11.

Heron 11-12-2006 09:07 AM

I solved in this way...
Install libalsa2 from i586 main repository, and use skype_staticQT, available on skype website. Well, at least it works... bye!

All times are GMT -5. The time now is 05:28 AM.