LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-06-2010, 01:34 PM   #1
Johnh395
LQ Newbie
 
Registered: Jun 2010
Location: Hertfordshire/Bedfordshire border
Distribution: Currently Ubuntu 10.04 but might go back a build or two.
Posts: 2

Rep: Reputation: 0
Since Upgrade to 10.04 my Opt Drives fail to play or show Audio cds on the Desktop


First my setup:

Hardware
Genuine AMD Athlon - 512 mg Mem - Nvida card & latest drivers - 80gb & 40gb drives - dvd read only & cdrw.

OS:
Ubuntu 10.04 - tried standard desktop then the alt version now back to standard desktop.

Problem:
Both optical drives recognise data disks and show them on the desktop. The dvd drive recognises any dvd and not only shows it on the desktop but also flashes up a requester box asking me which program I would like to use to play it. Nothing happens when I insert a music cd in either drive. Rhythm Box Music Player does not show a music cd available to play but does however show my iTouch when I connect it via usb. Btw iTouch is shown on the desktop when connected.

What have I done:
Fstab had no entries for either drive so I've researched and entered a line for each. The dvd fs is entered as iso9660,udf. The cdrw is using "proc" as a file system as it's the only thing that will show as mounted in Mtab. All else fails.
Both drives show up in System/Administration/Disk Utility (irrespective of Fstab entries), therefore the system can see them. Also investigating through the Terminal shows both drives.

Could someone please tell me how to listen to music cds on ubuntu 10.04. I wish to save my music then upload the same to my iTouch. It all worked so well in 8.04. Thanks.
 
Old 08-06-2010, 05:45 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
I'm testing 10.04, gnome desktop, updated to today's date.

I also put in a music CD ( I don't tend to do this but tried it for you ) and a box pops up "Audio disk": ...[Options] .. "Open with rhythmbox".. [Eject] [Cancel] [OK]

I choose "Open with rhythmbox".

Nothing happened.

There is now an icon on my desktop: "Audio Disc".

I R-Click it and choose "Open with rhythmbox".

Nothing happened.

I repeated the above steps (apart from putting in the CD) and then it works.

So many things are broken with the 'buntu 10.04 it seems. But my iTouch works well, for the first time ever with linux. But I don't need that.

Perhaps these problems will be sorted out in due course.

Quote:
It all worked so well in 8.04. Thanks.
8.04 was OK, but many broken things are now working with 10.04. Maybe. Perhaps. Possibly. YMMV.

Good luck.

And welcome to LQ!
 
Old 08-06-2010, 05:58 PM   #3
gasdim
Member
 
Registered: Jun 2010
Location: Volos GREECE
Distribution: ubuntu derivative
Posts: 157

Rep: Reputation: 28
Logically rhythmbox should autoplay the music cd. Before other check that. Open your Home folder by clicking Places -> Home Folder on the panel at the top of the screen. Then, click Edit -> Preferences -> Media and see in the CD Audio option is Do Nothing enabled?
 
Old 08-07-2010, 06:37 AM   #4
Johnh395
LQ Newbie
 
Registered: Jun 2010
Location: Hertfordshire/Bedfordshire border
Distribution: Currently Ubuntu 10.04 but might go back a build or two.
Posts: 2

Original Poster
Rep: Reputation: 0
Hi, I checked Places/Home Folder/Edit/Preferences/media and can confirm that all options were and are set to "Ask what to do".

Looking at some error messages reported from two different audio apps, there seems to be a problem with cdda://.........it seems that those apps are looking for that "device/cd drive"?. I'm wondering if there is some broken or non-existent association/link with cdda and scd0. Perhaps some library file somewhere. Whatever it is, it will require more digging. Some audio apps work whilst others can't see the cd drives. I would appreciate any help from any of you linux/unix buffs out there.

Thanks to both tredegar and gasdim who have responded thus far.

Last edited by Johnh395; 08-10-2010 at 06:32 AM. Reason: More info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
audio cds won't mount/play but dvds in same drives play. Running SW12.2current. lestoil Slackware 6 05-28-2009 08:33 PM
Audio cds won't play after upgrade to Ubuntu 8.04 dbg Ubuntu 19 05-19-2008 05:31 PM
cannot play audio CDs adidasguy Mandriva 2 11-09-2004 07:05 PM
audio CDs fail (using audiocd:/) gavinbeatty Slackware 3 09-18-2004 04:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration