LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Since Upgrade to 10.04 my Opt Drives fail to play or show Audio cds on the Desktop (https://www.linuxquestions.org/questions/linux-newbie-8/since-upgrade-to-10-04-my-opt-drives-fail-to-play-or-show-audio-cds-on-the-desktop-824625/)

Johnh395 08-06-2010 01:34 PM

Since Upgrade to 10.04 my Opt Drives fail to play or show Audio cds on the Desktop
 
First my setup:

Hardware
Genuine AMD Athlon - 512 mg Mem - Nvida card & latest drivers - 80gb & 40gb drives - dvd read only & cdrw.

OS:
Ubuntu 10.04 - tried standard desktop then the alt version now back to standard desktop.

Problem:
Both optical drives recognise data disks and show them on the desktop. The dvd drive recognises any dvd and not only shows it on the desktop but also flashes up a requester box asking me which program I would like to use to play it. Nothing happens when I insert a music cd in either drive. Rhythm Box Music Player does not show a music cd available to play but does however show my iTouch when I connect it via usb. Btw iTouch is shown on the desktop when connected.

What have I done:
Fstab had no entries for either drive so I've researched and entered a line for each. The dvd fs is entered as iso9660,udf. The cdrw is using "proc" as a file system as it's the only thing that will show as mounted in Mtab. All else fails.
Both drives show up in System/Administration/Disk Utility (irrespective of Fstab entries), therefore the system can see them. Also investigating through the Terminal shows both drives.

Could someone please tell me how to listen to music cds on ubuntu 10.04. I wish to save my music then upload the same to my iTouch. It all worked so well in 8.04. Thanks.

tredegar 08-06-2010 05:45 PM

I'm testing 10.04, gnome desktop, updated to today's date.

I also put in a music CD ( I don't tend to do this but tried it for you ) and a box pops up "Audio disk": ...[Options] .. "Open with rhythmbox".. [Eject] [Cancel] [OK]

I choose "Open with rhythmbox".

Nothing happened.

There is now an icon on my desktop: "Audio Disc".

I R-Click it and choose "Open with rhythmbox".

Nothing happened.

I repeated the above steps (apart from putting in the CD) and then it works.

So many things are broken with the 'buntu 10.04 it seems. But my iTouch works well, for the first time ever with linux. But I don't need that.

Perhaps these problems will be sorted out in due course.

Quote:

It all worked so well in 8.04. Thanks.
8.04 was OK, but many broken things are now working with 10.04. Maybe. Perhaps. Possibly. YMMV.

Good luck.

And welcome to LQ!

gasdim 08-06-2010 05:58 PM

Logically rhythmbox should autoplay the music cd. Before other check that. Open your Home folder by clicking Places -> Home Folder on the panel at the top of the screen. Then, click Edit -> Preferences -> Media and see in the CD Audio option is Do Nothing enabled?

Johnh395 08-07-2010 06:37 AM

Hi, I checked Places/Home Folder/Edit/Preferences/media and can confirm that all options were and are set to "Ask what to do".

Looking at some error messages reported from two different audio apps, there seems to be a problem with cdda://.........it seems that those apps are looking for that "device/cd drive"?. I'm wondering if there is some broken or non-existent association/link with cdda and scd0. Perhaps some library file somewhere. Whatever it is, it will require more digging. Some audio apps work whilst others can't see the cd drives. I would appreciate any help from any of you linux/unix buffs out there.

Thanks to both tredegar and gasdim who have responded thus far.


All times are GMT -5. The time now is 03:25 PM.