LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Signal out of range when booted to runlevel 5 (https://www.linuxquestions.org/questions/linux-newbie-8/signal-out-of-range-when-booted-to-runlevel-5-a-919692/)

linuxandtsm 12-20-2011 12:18 PM

Signal out of range when booted to runlevel 5
 
HI all,

Not able to boot into runlevel 5 and monitor stucks with "input sigal out of range Please change to 1440X600 @ 60Hz" message. I am able to boot into failsafe mode but everything mounted as readonly mode. This is a SuSe linux 10.3 system. Help me to resolve this issue. Thanks!

T3RM1NVT0R 12-20-2011 01:17 PM

@ Reply
 
Hi linuxandtsm,

You can boot into run level three and then following are the commands you can try:

1. sax2 (This should launch the utility to change your screen resolution)

After making the changes as per your requirement run the following command:

2. rcxdm restart

And then try to get into run level 5.

Make sure you run the above command as root.

linuxandtsm 12-20-2011 02:01 PM

Hi T3RM1NVT0R,

I am able to login to failsafe mode and when i run "sax2" command, it throws bunch of error messages like below
Code:

/usr/sbin/sax.sh: line 482 : /var/log/SaX.log: Read-only file system
SO everything mounted as read only so i am not able to change anything and read-write mount using "mount -o rw,remount /" complains that it is already mounted or busy

when i type init 3 to login to runlevel 3, it gives me below prompt and when enter root as login, throws bunch of messages and says login incorrect.

Code:

(none) login:

T3RM1NVT0R 12-20-2011 02:13 PM

@ Reply
 
Alright. Login in failsafe mode and try to mount the file system as read/write using the following command:

mount -o remount,rw /

and then run the commands that I mentioned in my previous post.

linuxandtsm 12-20-2011 02:19 PM

Tried
"mount -o remount,rw /" but it complains that / is already mounted or busy

T3RM1NVT0R 12-20-2011 02:25 PM

@ Reply
 
But after typing this command did you check if it shows that the file system has now been mounted as read/write or not. You can check that using the following command:

Code:

mount
Let me know the output of the above command as well as the following command:

Code:

df -h

linuxandtsm 12-20-2011 02:46 PM

"mount" command shows that
Code:

/dev/mapper/system-rootlv on / type jfs (rw)
and "df -h" shows

Code:

/dev/mapper/system-rootlv 140G 24G 117G 17% /
eventhough it says it mounted / as rw, not able modify any file (for example /etc/inittab etc: it says read-only filesystem)

T3RM1NVT0R 12-20-2011 02:47 PM

@ Reply
 
/dev/mapper/system-rootlv on / type jfs (rw) shows that the filesystem is mounted as read/write. Did you try running the commands mentioned in my first post.

linuxandtsm 12-20-2011 02:57 PM

yes,

tried "sax2" and got same error messages as earlier

/usr/sbin/sax.sh: line 482 : /var/log/SaX.log: Read-only file system

T3RM1NVT0R 12-20-2011 03:07 PM

@ Reply
 
What happens if you try to boot the system in normal mode instead of failsafe? Does it hang or show you resolution error or does not boot at all? Not sure why failsafe is acting like that because if we can't make any changes then there is no point booting in failsafe.

linuxandtsm 12-20-2011 03:10 PM

when i boot into normal mode, the screen goes blank with "input signal out of range....." message and stays there forever

T3RM1NVT0R 12-20-2011 04:25 PM

@ Reply
 
The only fix that I can think for this issue now is to repair the system using your SuSE 10.03 DVD. Make sure you do not touch existing partitions.

linuxandtsm 12-21-2011 09:16 AM

Hi T3RM1NVT0R,

Could you please tell me how (and what) to repair with DVD ?
thanks in advance!

T3RM1NVT0R 12-21-2011 12:08 PM

@ Reply
 
Here is the pdf that will help you: http://www.google.co.in/url?sa=t&rct...Thtofgr_fZnkOw

Cloud9 01-19-2012 09:26 AM

Did you try using ctrl, alt and f1/2/3?! That should bring you to the CLI


All times are GMT -5. The time now is 04:06 AM.