LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2009, 11:01 AM   #1
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Shutdown problem with Ubuntu 8.10 Intrepid Ibex


Hello all,

Experiencing a problem with shutdown / halt. When shutting down the computer, the computer does not power off. Instead either of three symptoms are occuring depending how much I 'fiddle' with the kernal module options.

Symptoms:

i) Ubuntu shutdown progress bar finishes but the Ubuntu logo never disappears


OR


ii) Ubuntu shutdown progress bar finishes, the Ubuntu logo disappears and we are left with a black screen with a flashing cursor but the power light on the computer stays on.


OR


iii) Ubuntu shutdown progress bar finishes, the Ubuntu logo disappears and we are left with a black screen with a message "Unable to iterate IDE devices due to no such file or directory", but the power light on the computer stays on.
 
Old 01-12-2009, 11:08 AM   #2
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Posting this solution for posterity:

To solve the above problem, do the following:

1) Edit the /etc/modules file and add the following line:

Code:
apm power_off=1
2) Edit the /etc/rc0.d/S90halt file and remark out the following lines:

Code:
#       hddown="-h"
#       if grep -qs '^md.*active' /proc/mdstat
#       then
#               hddown=""
#       fi
and remark out...

Code:
#       netdown="-i"
#       if [ "$NETDOWN" = "no" ]; then
#               netdown=""
#       fi
3) Add the following args to the kernel line in /boot/grub/menu.lst

Code:
noacpi acpi=off pci=nopci
You may be able to omit the pci=nopci argument as I am not convinced that it is related to the problem. But the bug is solved for me so I am not going to prove or disprove that argument just yet.
 
Old 02-17-2009, 08:21 PM   #3
NewtownGal
LQ Newbie
 
Registered: Feb 2009
Posts: 7

Rep: Reputation: 0
clean shutdown from power switch still doesn't work

Hello,

The comment above said, in part:

.................

Comment out:

# netdown="-i"
# if [ "$NETDOWN" = "no" ]; then
# netdown=""
# fi

.............

I can't find this code in Ubuntu 8.04.1 server. The other code is present. Where is this code ?

How do I enable the power switch to work ? On Fedora <various>, I briefly press the power switch, and Linux does a clean shutdown. But nothing happens on Ubuntu unless I press the power switch for so long (5 seconds or so) that the system stops dead and power turns off.

And, when the machine stops dead, why doesn't Ubuntu complain when it reboots that the system was shut down uncleanly, as it would in Red Hat <various> ?

My motherboard is Intel D945GCLF2, which uses the new Intel dual-core Atom cpu.

Note: I did not add the suggested commands to the kernel startup because it still shuts down cleanly from "shutdown now -h" and I was concerned that a card I have in the pci slot that uses many IRQ's would not be handled right.

Thank you.
 
Old 05-31-2009, 01:21 AM   #4
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Quote:
Originally Posted by NewtownGal View Post
Hello,

The comment above said, in part:

.................

Comment out:

# netdown="-i"
# if [ "$NETDOWN" = "no" ]; then
# netdown=""
# fi

.............

I can't find this code in Ubuntu 8.04.1 server. The other code is present. Where is this code ?

<snip>
My example was from an Ubuntu 8.10 Desktop install. So maybe Ubuntu 8.04 did not have that inside its /etc/rc0.d/S90halt file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
okular in Ubuntu Intrepid Ibex Peter Shepard Ubuntu 1 01-06-2009 11:34 AM
Splashscreen on Ubuntu Intrepid Ibex tm2383 Ubuntu 3 12-10-2008 05:49 PM
How to install Java on Ubuntu 8.10 (Intrepid Ibex) greengrocer Linux - Newbie 12 12-08-2008 08:26 AM
LXer: The Perfect Server - Ubuntu Intrepid Ibex (Ubuntu 8.10) LXer Syndicated Linux News 0 11-02-2008 06:10 PM
LXer: Firebird 2.1 in Ubuntu 8.10 Intrepid Ibex LXer Syndicated Linux News 0 05-30-2008 08:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration