LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2004, 11:55 PM   #1
wlaw
Member
 
Registered: Jun 2004
Location: HK
Distribution: Ubuntu
Posts: 242

Rep: Reputation: 30
shutdown problem !


I am running GNOME and Redhat 9.0.

At the begining, I was running Chinese as the language, and now I changed the default language to American English, however, I could not shutdown the computer afterwards, it keeps on divert me to the login screen and asked me if I am sure to shutdown the computer.
I have to press ctrl+alt+f1 and login as root to shutdown in text mode !

What's wrong ?

Last edited by wlaw; 06-30-2004 at 11:57 PM.
 
Old 07-01-2004, 01:20 AM   #2
aeruzcar
Member
 
Registered: Jul 2003
Location: Santiago, Chile
Distribution: Gentoo
Posts: 282

Rep: Reputation: 30
You may already know this, but I believe but I am not sure that to shutdown trough a terminal you must be root or the user must have the permition to do it, if you wnat to just shutdown your computer open up a terminal and issue the command shutdown -h now
Hope this helps
 
Old 07-01-2004, 01:37 AM   #3
ujjwals
LQ Newbie
 
Registered: Jun 2004
Location: INDIA
Posts: 8

Rep: Reputation: 0
Open up a terminal at your Gnome
try using init 6 or init 0
even shutdown -t3 -r now
will work
 
Old 07-01-2004, 01:45 AM   #4
Fluffybunny
LQ Newbie
 
Registered: Sep 2002
Posts: 23

Rep: Reputation: 15
Guys,

I think he means to say that when he clicks on the RedHat button and selects shutdown, the system does not shutdown, so he has to CTL+ALT+F? to go to the virtual console and then type in shutdown -h now.

Are you sure you are selecting shutdown and not logout ?

Cheers.
 
Old 07-01-2004, 03:42 AM   #5
wlaw
Member
 
Registered: Jun 2004
Location: HK
Distribution: Ubuntu
Posts: 242

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Fluffybunny
Guys,

I think he means to say that when he clicks on the RedHat button and selects shutdown, the system does not shutdown, so he has to CTL+ALT+F? to go to the virtual console and then type in shutdown -h now.

Are you sure you are selecting shutdown and not logout ?

Cheers.
Of couse I am selecting shutdown , not logout !

 
Old 07-01-2004, 06:17 AM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
That is (ime) a login manager issue-- if I select reboot or shutdown from the GNOME menu, it returns me to the login manager (GDM), where I then must choose reboot or shutdown again.

This may have something to do with the DE or WM no longer having the rights to stop X (or the DM daemon that is now "controlling" X).

It is annoying, but not "abnormal" (insofar as I've seen this behaviour under various distros, at least under GDM, and I would assume that KDM and XDM would behave similarly). I have not tested if this behaviour persists if you run your DE from startx rather than interposing a DM between X and the DE.
 
Old 07-01-2004, 10:34 AM   #7
sbogus
Member
 
Registered: May 2004
Location: Germany, Munich
Distribution: SuSE Pro Releases 7.3, 9.0, CentOS 4.0, Kubuntu 6.0x
Posts: 103

Rep: Reputation: 15
No, XDM/KDM behave differently than GDM.
I'm using KDM with KDE and I can directly shutdown from my DE. Choosing Logout will shutdown the KDE and KDM automaticaly as the machine itself. Note I run in runlevel 5, if I choose runlevel 3 then I must start the DE with startx command and then "logout" from the DE will just set me back to the runlevel 3.

Now to the actual problem - I assume too this is an GNOME issue and is subject of proper GDM configuration. Where the configuration file for GNOME resides I couldn't say, but as hint I'd suggest you take a look at this configuration file and pay attention to any option that might have to do with startup/shutdown the GDM.
Furthermore, take look at your init.d scripts and verify that the boot process delegates proper access rights to the user who logs in via GUI Login screen (if you're using runlevel 5).

Kind regards,
sbogus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown Problem Andjeo Mandriva 5 10-21-2004 05:52 PM
Shutdown Problem Jmcatch742 Linux - General 2 08-16-2004 04:09 AM
X shutdown problem kleptophobiac Linux - Software 9 04-02-2004 08:53 AM
Shutdown problem tsitras Debian 6 10-21-2003 09:31 AM
Shutdown Problem gbj Linux - General 1 08-07-2003 09:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration