LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Sharing fat32 with Linux and Windows (https://www.linuxquestions.org/questions/linux-newbie-8/sharing-fat32-with-linux-and-windows-236087/)

TheShish 09-28-2004 12:53 AM

Sharing fat32 with Linux and Windows
 
I'm running an HD install of Knoppix 3.6. I want to share a fat32 partition between Windows and Linux so that both can read and write to it. After creating such a partition in Linux only to have Windows view it as a healthy but unknown fat32 partition (that it wouldn't assign a drive letter to), I deleted the partition and remade it in Windows.

This seemed to work, as both Windows and Linux "saw" the partition (my fstab is regenerated at each startup). However, once I wrote to the partition in Linux, Windows viewed it again as a healthy but unknown fat32 partition that it won't assign a drive to.

My fstab line generated for the fat32 partition is
Code:

/dev/hda4 /mnt/hda4 vfat auto,users,exec,umask=000 0 0
Any help regarding this issue would be appreciated.

PS: Yes, I'm a newbie to Linux (perhaps I've had it for a week or two).

320mb 09-28-2004 05:08 AM

Code:

/dev/hda4 /mnt/hda4 vfat auto,owner,users,exec,rw 0 0
you might need to edit /etc/fstab upon each reboot like this............
remake the partiton in windows and try the above line...........

Biased turkey 09-28-2004 09:05 AM

I think the fat32 partition you want to share must be created and formated with windows.
Then reboot to Linux ( as root ) then create a directory ( /mnt/windows ) where the windows partition will be mounted and mount your windows partition with:
mount -t vfat /dev/hdax /mnt/windows.
At least that's the way it worked for me.
I don't like to have my windows partition autamatically mounted that's why I don't include it in /etc/fstab.

TheShish 09-28-2004 06:57 PM

I'm fairly certain that I determined it's not a Linux problem. After deleting and recreating the partition in Windows with a drive, I decided to do some error checking. I tried restarting from Windows, back into Windows (using Lilo). However, the drive still became healthy but unknown.

Unless somehow Lilo changes the partition type from c to 1c on startup (Lilo does seem to think the partition is a bootable Windows, but I never boot into it), I suppose that Windows can be the only thing at fault.

Therefore, I guess I'm in the wrong forum. Thanks anyway.


All times are GMT -5. The time now is 06:00 AM.