Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-29-2010, 02:09 PM   #76
Senior Member
Registered: Sep 2005
Location: France
Distribution: LFS
Posts: 1,591

Rep: Reputation: 79

edit: didn't read the stuff carefully, sorry

Last edited by Agrouf; 01-29-2010 at 02:11 PM.
Old 01-29-2010, 06:43 PM   #77
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,932
Blog Entries: 28

Rep: Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226Reputation: 2226

Originally Posted by pixellany View Post

What you may have missed is that---at one point---he had a connection. Thus, drivers don't appear to be the issue.

This is why I have requested a synopsis which lists the answers ALL questions brought up in the thread.
I must have missed that post. Thought I had read the thread but may have missed some when I had to repair this laptops' hdd.

Agree, the OP needs to post requested relevant information.

Old 01-30-2010, 04:10 AM   #78
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
sudo echo "nameserver" >> /etc/resolv.conf
My only petpeeve about using sudo is the difficulty in redirecting output as root.
Use a text editor (as root) and add the line manually. That would be easiest.

Is this the address of the wireless router? Not all routers function as nameservers. If you can run "ipconfig /all" on a windows machine on the wireless network, you can learn which DNS servers it uses. Maybe is OK.

I think that your LAN is in the address space and the wireless network is in the 10. address space. They may be two totally different networks, without any connection. Perhaps they don't want computers to access the LAN via a wireless connection, but have a wireless router to enable you access to the internet. At work, in our conference room, we have a wireless router for guests, who need to have a wireless connection to the internet for demonstrations. Our work laptops have wireless disabled. And by the way, these are both private address ranges. Such addresses do not exist on the Internet.

Yes all i was given by the IP person was to use the setting :
IP address 10.1.1.(and any range 60 to 69 hear)
Subnet Mask
Assuming that is a router, this should be the address you use for the default gateway.
Three things you need to know (if not using DHCP) are
1). The IP address your network device should have.
2). The default gateway IP address. This will be the address of a router.
3). The nameserver (DNS) address. There are sometimes 2 of them if you use your ISPs DNS server.

If using doesn't work as the nameserver address, you could: find out what the IP addresses of the ISP are; use OpenDNS or google's DNS service

Before running "sudo route ..." to configure the default gateway, run "sudo route" without options so we can see what the settings were before. After configuring the default gateway, run "sudo route" again. Post your commands and output in [ code ] ... [ /code ] blocks so they are easier to read. Look at Schniedz's posts above to see what I mean.

Lastly, since there is no DHCP server on the wireless network, stop running "sudo dhclient eth1". You will configure your device manually.

Good Luck!

Last edited by jschiwal; 01-30-2010 at 04:21 AM.
Old 02-01-2010, 07:14 AM   #79
LN Smith
LQ Newbie
Registered: Jan 2010
Posts: 23

Original Poster
Rep: Reputation: 15
Sorry it took so long to get back. Hope everone had a good weekend. after running the
"sudo route" this is what i get:
smith@smith-laptop:~$ sudo route
[sudo] password for smith:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
Changing the setting to manual and running "sudo route" nothing changes?
Old 03-18-2010, 11:17 AM   #80
LQ Guru
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,199

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
sorry you cant get on your wireless network.
can you tell us the parameters of the other wireless network devices you are using (ip address, subnet mask, gateway, dns servers, ...) so we can tell you how to modify them and where to put them on your laptop.

Last edited by schneidz; 03-18-2010 at 11:19 AM.
Old 03-22-2010, 09:44 AM   #81
LN Smith
LQ Newbie
Registered: Jan 2010
Posts: 23

Original Poster
Rep: Reputation: 15
I would like to thank you all for your help in this matter, However to correct the problem i ended up re-installed the os. there were a lot of filed and programs that were corrupted and missing.

Now everything seams to be running fine! but i will not rely on updating without a hard wired connection again! lesson well learned!

Thanks again to all.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration