LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Setting up internet with wireless card (https://www.linuxquestions.org/questions/linux-newbie-8/setting-up-internet-with-wireless-card-229579/)

jedikitsune 09-12-2004 01:23 AM

Setting up internet with wireless card
 
I just recently installed Mandrake 10.0 and I find it extremely hard to start out, especially without being able to access the internet through Linux (I'm using Windows XP right now). So basically, I suppose I'l asking for help getting it set up to work, since I think I can make some big progress once I do that.

Here's what I've tried.

My wireless PCI card is an Airlink+ 802.11g, and I couldn't find it on the card list when first installing Mandrake. So I went back to windows and looks around on the internet. I found the driver loader for my kernel and tried that, but it didn't install sucessfully (said something about needing wireless-tools). I tried downloading whatever wireless tools was and that failed as well. I don't even know what to try now and I'm quite frustrated.

scuzzman 09-12-2004 06:59 AM

Post the error messages you get when trying to compile/install the drivers.

jedikitsune 09-12-2004 05:43 PM

Here was my attempt to install ndiswrapper, only to get a similar error..

Quote:

make -C driver install
make[1]: Entering directory `/home/foxboy/ndiswrapper-0.10/driver'
make -C /lib/modules/2.6.3-4mdk/build SUBDIRS=/home/foxboy/ndiswrapper-0.10/driver \
NDISWRAPPER_VERSION=0.10 \
EXTRA_VERSION= modules
make: *** /lib/modules/2.6.3-4mdk/build: No such file or directory. Stop.
make: Entering an unknown directorymake: Leaving an unknown directorymake[1]: *** [default] Error 2
make[1]: Leaving directory `/home/foxboy/ndiswrapper-0.10/driver'
make: *** [install] Error 2
I'm VERY new to Linux. I'm working straight off a fresh install of Mandrake 10.0 Community (which is or isn't a problem?). I haven't even figured out how to log in as root to do things yet.

I'm guessing this means something along the lines of me needing something to be able to build, doesn't it?

labradog 09-12-2004 10:15 PM

I had the same error. I reinstalled the kernel-source to fix this problem.

Brian

jedikitsune 09-12-2004 10:28 PM

I suppose my next question would be where to find the kernel source? I've tried searching and haven't found anything quite yet.

basd 09-13-2004 04:36 AM

You would be well advised to find yourself a cable and use your ethernet card for the "getting started" part of your endeavor, since Mandrake is very good at recognizing network cards. (Whereas modems and wireless are more problematic).

You will find the sources in usr/src -- but I think only if you installed the "development" packages when you installed Mandrake.

When you installed Mandrake, it asked you for a master password. This is how you log in as "root" -- which is the administrator. At the login screen you enter user "root" and then enter the master password you established.

You can install the source code by running the Mandrake software install under system tools, and installing the packages that contain the source for the linux kernel.

This is why it's so much easier to use RPM packages -- they don't require you to make / make install and all that. I spent a lot of time doing that in Mandrake 8.2 when I was trying to make an internal laptop modem work. But mostly I use RPMs, eg., I don't even have the source code installed in my SuSE install. It's kinda fun to build a custom kernel that leaves out what you don't need for your system, but then the next version of your linux build comes along and it's easier just to install the pre-packaged kernel than to build the custom one over again anyway.

scuzzman 09-13-2004 06:24 AM

to install the kernel sources type this:

Code:

# urpmi kernel-source-YOUR.KERNEL.VERSION
type 'uname -r' to get YOUR.KERNEL.VERSION
note the # at the front, indicating to do this as root. The way to get to root is the 'su' command. Hence, If i wanted to install my kernel sources, I'd do this.
Code:

$ uname -r
2.4.25-2mdk
$ su
Password:
# urpmi kernel-source-2.4.25-2mdk

It will then provide a status indicator, and so on
and Voila!

labradog 09-13-2004 01:33 PM

I checked. My copy of the 10 install disks. kernel source is on disk 3


All times are GMT -5. The time now is 06:30 AM.