LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2004, 02:51 AM   #1
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Rep: Reputation: 16
Setting up GNOME


Hi.
I got GNOME and installed, it howevr all manuals tell about how to use it rather than how to set it as your shell of choice? How do I turn off KDE and get GNOME running?

P.S. I know I gotta restart in runmode=3, but than what?

Thank you!
 
Old 06-14-2004, 04:31 AM   #2
miknight
Member
 
Registered: Oct 2002
Location: Sydney, Australia
Distribution: Gentoo, Ubuntu, Debian
Posts: 184

Rep: Reputation: 30
Yes, personally I much prefer runlevel 3. You should be able to get GNOME running by creating (or editing) your ~/.xinitrc file and placing the line
Code:
exec gnome-session
at the bottom. After saving that file, running
Code:
startx
at the command prompt should bring up GNOME.
 
Old 06-14-2004, 04:32 AM   #3
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
cool!
quick question -- will it make KDE go away?
 
Old 06-14-2004, 04:34 AM   #4
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
Also... which directory does .xinitrc go to?

(sorry.. imanewbie)
 
Old 06-14-2004, 05:00 AM   #5
miknight
Member
 
Registered: Oct 2002
Location: Sydney, Australia
Distribution: Gentoo, Ubuntu, Debian
Posts: 184

Rep: Reputation: 30
What do you mean by "go away"? If you mean removed from your hard drive, then no. If you mean it doesn't load automatically anymore, then yes. Also I assumed before that you have already configured your box to load up in runlevel 3. If not you can google or search this forum to figure that one out.

The .xinitrc file goes in ~ (an alias for your home directory). For me, ~ translates to /home/mike. Try going cd ~ and note that you'll end up in your home dir.
 
Old 06-14-2004, 05:17 AM   #6
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
Thanks a lot! it works now!
 
Old 06-14-2004, 05:34 AM   #7
miknight
Member
 
Registered: Oct 2002
Location: Sydney, Australia
Distribution: Gentoo, Ubuntu, Debian
Posts: 184

Rep: Reputation: 30
Pleasure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - Gnome setting error gmartin Linux - Software 0 02-09-2005 10:38 PM
Setting hostname with GNOME phatboyz Linux - Networking 4 11-02-2004 07:47 AM
broken gnome setting deamon startxxx Linux - Newbie 3 09-27-2004 10:20 AM
Setting proxy exceptions in Gnome 2.4 Wapo Linux - Networking 0 03-31-2004 10:32 AM
Setting up KDE/Gnome? pewdnet Linux - Newbie 5 10-21-2002 04:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration