-   Linux - Newbie (
-   -   setting resolution w/ Xorg or ATI driver (

skinnchip 02-06-2009 12:15 PM

setting resolution w/ Xorg or ATI driver

ive decided to post this in newbie, (because i am one!) maybe it sould be under hardware, i don't know yet, but i figure its something many people want to do after a fresh install.

ive just completed an install of slackware 12.2. I can't handle this screen resol. (im used to working on machines at 1900x1200)

ive been reading "o'reilly running linux 5th edition" and about configuring Xorg to set the resolution i want. it sounds to me i could set a resolution of 1900x1200 simply by editing the files outlined in the book.

on the second hand, i have downloaded the ati driver from their web site.
so far i have:
-used rpm2tgz to repack the file to sumthing i can use.
-untared/ungziped that package to use the files they provided
-and am now looking at various folders which don't seem to have any configure files.

(seems logical to me in hind site, it wasn't ment to be installed in this way)

heheh question is...
can i set a resolution of 1900x1200 by configuring Xorg? or will i need to get these ati drivers installed first?

i realize the ati drivers will have some benifits over just adjusting my config files, but at the moment i don't care. i just can't handle looking at my screen resolution as it is! ekkk!

pointers and advice i would be grateful for, i don't expect line fer line fixes! heheh


Didier Spaier 02-06-2009 12:58 PM

I depends on your graphical card model. So please send output of following command, typed as root:

lspci|grep VGA

skinnchip 02-06-2009 01:39 PM

humm, thanks,

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)

Didier Spaier 02-06-2009 02:01 PM

There seem to be could be unsettled issues with this card.

1) in the Graphics device section of /etc/X11/xorg.conf, replace 'Driver "vesa"' (or whatever you have) by 'Driver "radeon"' (omit the single quotes)
2) chek that the radeon module is loaded: 'lsmod|grep radeon'. If not, load it. As root: 'modprobe radeon'
3) restart X

If that works:
- to tune your card's configuration, see 'man radeon'
- if it was not loaded, ensure that the radeon module be loaded at next startup. For that you can add following line:

/sbin/modprobe radeon
to /etc/rc.d/rc.modules (more accurately, to the file to which the former links)

I cross my fingers ;)

skinnchip 02-06-2009 02:10 PM


these are things i don't yet know, and will look into them,

thank u so much, pointers are the best things for me to learn from!


skinnchip 02-10-2009 01:03 AM

well! hehe

i`ve tried out these suggestions...

...thank u very much :)

but i`m confused with one thing, maybe im missing something!

when i start X, the screen is scrambled, i figure its not setup proper still. (i do have Horizontal vertical settings from the manuel)
YET!.. my pointer (mouse curser) looks much smaller, sharp, crisp like everything is ok! but the rest is scrambled (smeared from left to right) does this make any sense...
should`t it be all scrambled too!


All times are GMT -5. The time now is 09:42 PM.