-   Linux - Newbie (
-   -   setting permissions on a file after uploading via FTP (

dgsr2002 10-20-2004 04:08 PM

setting permissions on a file after uploading via FTP
Hey everyone, first post...

I've been using linux for about a month now, still pretty new but I enjoy learning. I'm using proftpd as my ftp server(personal use)-installed from rpm, everything is working great as far as that goes. I'm also using fedora core2-if it's even relevant.

my question is...
When I upload a file from another computer to my computer, using an ftp client, everything goes good, except when I get home I can't edit the file that I uploaded. I noticed that the permissions are faded out and there's no way to change them.

What I'm wondering is...
Do I have to change the permissions on the file before I send it with the ftp client, or if that's not possible then how do I make it to where when I send a file from a computer to my home computer I'll be able to edit it.

I can't think of any config files or anything like that I need to post, but if I should please let me know..

thanks in advance

0.o 10-20-2004 04:26 PM

The files should be owned by whoever sent them there. So if you had an account named Focker, and sent the files there via Fockerís account, he should own them. That being said, I wanted a script earlier to automate permissions, and there was someone here nice enough to give me the correct command syntax for this job.

find . -type f -name ".doc" -exec chmod 777 {} \;

here is the link to that post

dgsr2002 10-20-2004 04:53 PM

thanks for such a quick response, but I don't think that's what I need(of course I'm probably wrong..)

I should have been more specific...
I logged onto a windows xp computer at our lounge at school, connected to my linux ftp server w/leechftp, uploaded a file from that winxp computer to my home computer(linux), but when I got home the file was read only. The same happened when my dad sent me an MS document from his computer;read only. So how do I make it so that when I send a file from some computer that I happened to be logged on to, say the library's computer, I can come home and pick up right where I left off; full permissions that is.

thanks in advance...

dgsr2002 10-20-2004 09:31 PM

semi-solution to permissions problem
Okay I found a solution to my problem, however it's not really the ideal solution, but anyhow.

Like i stated above, the problem was that if I was using a computer, say at the library, and I wanted to save my MS word document, or anything for that matter, by uploading to my FTP server, so that when I got home I could pick up right where I left off, the permissions were all jacked up. So I go home from the library, double-click on my file and it opens and tells me that it's read only. The permissions say that the user who uploaded the file owns it, which it should, but the options for changing view and modify are grayed out.

The solution...

I found that if I renamed the document to something other than what it was uploaded as, I could then open the file that I just renamed it to and edit it. Has anyone else had this kind of experience and if so is there an easier way to fix besides going in and renaming all the files that I want to be able to read/write to.


dgsr2002 10-21-2004 08:15 PM

Even better solution
I did a whole lot of googling on permissions via ftp and finally found some stuff about the umask command, which I just happened to stumble across by reading some random web page. The defualt in proftpd was set to umask 020 which was changing the files i uploaded to 644(rw-r-r). I went in and changed the umask, very easy using gproftpd, to 000, had a test file sent by my dad and voila-the permissions were then defaulted to 664(rw-rw-r) which is what I want seen how I'm the only person using this ftp server(well and mom and dad). If anybody sees anything seriously wrong about this please let me know. Keep in mind that I don't want anonymous users connecting or any of that...this is just a personal portable "hard drive" if you will.


All times are GMT -5. The time now is 02:08 PM.