LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   setting ethernet card to tulip??? (https://www.linuxquestions.org/questions/linux-newbie-8/setting-ethernet-card-to-tulip-96419/)

Derek-kun 09-24-2003 04:32 PM

setting ethernet card to tulip???
 
k, i've now got tulip, so how do i get my ethernet card to use it? tulip is on i restart etc and still nothing happens. i when into networkconf andsetup the ip address adn so forth. but why isn't anything happening???? >_<

ps. my ethernet card is a

ADMtek AN983B 32bit pci bus 10/100mbps fast ethernet card

please help......

trickykid 09-24-2003 07:01 PM

1. lsmod

If its listing the tulip module then skip step 2.

2. modprobe tulip

This inserts the module.

3. dmesg

See if you can find your PCI network card listed in the list, if so do next step.

4. ifconfig

This should display the output of all your network devices. You should have an lo and eth0 listed. lo is the loopback device.
If you have an eth0 listed, does it have the correct inet address and such? If not you can either set the default settings using the ifconfig eth0 command (man ifconfig for more options/details on usage) or possibly run netconfig, usually works on most distro's but you haven't provided one, so I can't be for sure.

Send us more details on what you've tried, what you get on any of this output/steps given, etc.

It could be that your NIC uses tulip but there are different versions. Some chipsets are weird and might use a different module or different version of tulip.

Derek-kun 09-24-2003 10:39 PM

well you already know what type of nic card i have. i'm using mandrake 7.1. i've tried setting up my tcp/ip in netconf-text and i've also tried editing my conf.modules file. the tulip.0 file i have i just downloaded from the net on my other computer.

Derek-kun 09-24-2003 10:45 PM

no wonder it wasn't working! my kernel is 2.2.15 and the tulip mod i downloaded was made for a 2.2.22 kernel. how could i be so stupid!?

Derek-kun 09-24-2003 11:01 PM

ok... now it says

/etc/conf.modules is more recent than /lib/module/2.2.15-4mdk/modules.dep

anyone know how to fix this?

trickykid 09-25-2003 01:51 AM

Have you thought about just updating and compiling an updated kernel? The latest kernel provides support with the latest tulip driver.


All times are GMT -5. The time now is 12:16 AM.