LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2005, 09:45 PM   #1
aducarrab
LQ Newbie
 
Registered: Jan 2005
Location: Rhode Island
Distribution: Red Hat 9
Posts: 15

Rep: Reputation: 0
setting artswrapper permissions


When logging in as anything other than root I get the "sound server can't run in real time, run artswraper as root" message. From another post I understand I need to "chmod u+s artswrapper". Apparently this file is supposed to be located a few levels down in the /opt. My opt directory is empty. Where's my artswrapper??
 
Old 01-22-2005, 10:56 AM   #2
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
You could try running 'updatedb' and then running 'locate artswrapper' (do all of this as root). That my tell you the location of artswrapper.
 
Old 01-22-2005, 07:04 PM   #3
aducarrab
LQ Newbie
 
Registered: Jan 2005
Location: Rhode Island
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
thanks, found it. I no longer get the message about sound server unable to run in realtime when non-root, but now there's a new problem. I can play mp3's sometimes. Sometimes I hit play on xmms and it plays fine, other times I get a message saying;
" couldn't open audio, please check that; 1.) you have the correct output plugin selected, 2.) no other programs is blocking the soundcard, 3.) your soundcard is configured properly

I figure if the soundcard or plugin weren't proper, it would NEVER play, not sometimes play right? And in between xmms working and not working I don't start any new apps that could grab the sound card. What am I missing here?

thks!
Jim
 
Old 01-22-2005, 11:49 PM   #4
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
hahaha, I've had this problem before.....I think it has to do with KDE error noises grabbing the sound server (arts), and not letting go for about 60 seconds. I think the way that I worked around the problem was to go into kcontrol, and turn off all sound notifications for all events (in all applications). The best way of turning them all off is to go to kcontrol --> Sound and Multimedia --> System Notifocations; check the box that says 'Apply to all applications' and then click 'Turn off all.'

Hey, I don't like it to beep at me anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to put artswrapper suid root? jayhel Slackware 2 09-19-2005 09:43 AM
how to set artswrapper suid root ? chokecherry Linux - General 3 11-27-2003 04:32 AM
artswrapper???? KoRnFan Linux - Software 2 11-08-2003 04:30 PM
Setting Permissions johnnyde Linux - Newbie 1 05-22-2003 05:37 PM
Artswrapper Problem dharries Linux - Newbie 1 04-17-2003 06:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration