-   Linux - Newbie (
-   -   Set KDE Style to GTK, Can't Log in! (

JK3mp 12-14-2009 01:40 PM

Set KDE Style to GTK, Can't Log in!
Okay so i was playing around and set style in KDE to GTK...well.. apparently thats a damn bad idea. So it immediately logged me out, and now i can't log in as my user in KDE or run K based apps from other DE (XFCE). So i guess what im wondering is how i fix this? Or more, whats the config file for kde styles i need to change the style back ?

worm5252 12-14-2009 01:50 PM

you can run this command to find the config files for a starting point


kde-config --path config

knudfl 12-14-2009 03:04 PM

.. Or just delete ..

.. log out from X .. log in again ..
And a new set of default config files will be created,
when you start KDE ( or a KDE application.)


i92guboj 12-14-2009 04:36 PM

I'd first try to find what the problem is. It's the first time I've seen this kind of problem. A lot of people use the Gtk+ kde engine without problems. Did you try changing your gtk+ style, preferably to other using a different gtk+ engine? Did you try to run a kde application in a terminal? maybe there's some useful error in there to look at.

JK3mp 12-16-2009 06:37 PM

None of that... i was running KDE and in KDE settings changed styles to GTK.... Then it just logged me out of KDE and every time i try to login it just logs me back out. Logs into XFCE just fine but can't use any KDE Apps.

i92guboj 12-16-2009 07:11 PM

I mean: try to run a kde application fron the terminal in XFCE, and see if it spits out any meaningful error.

OR, try using gtk-chtheme or lxappearance to change the gtk style, and see if that helps.

All times are GMT -5. The time now is 10:13 PM.