LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-21-2013, 10:27 AM   #1
ramseyrt
LQ Newbie
 
Registered: May 2010
Location: Virginia
Distribution: Windows 7
Posts: 12

Rep: Reputation: Disabled
service ntpd restart fails


Hello,

I have a system that reports an ntpd failure during a "service ntpd restart". It seems like everything should be working (of course). Here's the data:

Code:
[root@RHEL_Server ~]# service ntpd restart

Shutting down ntpd:                                        [  OK  ]
ntpd: Synchronizing with time server:                      [FAILED]
Starting ntpd:                                             [  OK  ]
The error messages read:
Code:
[root@RHEL_Server ~]# tail /var/log/messages| grep ntpd

Apr 21 14:11:19 RHEL_Server ntpd[1113]: ntpd exiting on signal 15
Apr 21 14:11:19 RHEL_Server ntpdate[1303]: no server suitable for synchronization found
Apr 21 14:11:19 RHEL_Server ntpd[1306]: ntpd 4.2.2p1@1.1570-o Thu Nov 26 11:35:07 UTC 2009 (1)
Apr 21 14:11:19 RHEL_Server ntpd[1307]: precision = 1.000 usec
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface wildcard, 0.0.0.0#123 Disabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface wildcard, ::#123 Disabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface lo, ::1#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface eth0, fe80::1aa9:5ff:fe3c:b7a6#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface eth1, fe80::1aa9:5ff:fe3c:374a#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface lo, 127.0.0.1#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface eth0, 192.168.6.6#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: Listening on interface eth1, 10.6.0.4#123 Enabled
Apr 21 14:11:19 RHEL_Server ntpd[1307]: kernel time sync status 0040
Apr 21 14:11:19 RHEL_Server ntpd[1307]: frequency initialized 21.183 PPM from /var/lib/ntp/drift
My ntp.conf file looks similar to other working ntp.conf files on RHEL boxes on my network:
Code:
[root@RHEL_Server ~]# grep -v ^# /etc/ntp.conf

restrict default kod nomodify notrap nopeer noquery
restrict 127.0.0.1 
restrict -6 ::1
fudge   127.127.1.0 stratum 10
driftfile /var/lib/ntp/drift
keys /etc/ntp/keys
server 192.168.6.15
restrict 192.168.6.15 mask 255.255.255.255 nomodify notrap noquery
The service looks good in chkconfig (default runlevel is 5)
Code:
[root@RHEL_Server ~]# chkconfig --list | grep ^ntpd

ntpd            0:off   1:off   2:off   3:on    4:off   5:on    6:off
I'm not running any kind of firewall (closed network)
Code:
[root@RHEL_Server ~]# chkconfig --list | grep ^iptables

iptables        0:off   1:off   2:off   3:off   4:off   5:off   6:off

[root@RHEL_Server ~]# iptables --list

Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
I can talk to the time server
Code:
[root@RHEL_Server ~]# ntpdate -d 192.168.6.15

21 Apr 14:12:14 ntpdate[1377]: ntpdate 4.2.2p1@1.1570-o Thu Nov 26 11:35:07 UTC 2009 (1)
Looking for host 192.168.6.15 and service ntp
host found : Cisco_Router
transmit(192.168.6.15)
receive(192.168.6.15)
transmit(192.168.6.15)
receive(192.168.6.15)
transmit(192.168.6.15)
receive(192.168.6.15)
transmit(192.168.6.15)
receive(192.168.6.15)
transmit(192.168.6.15)
server 192.168.6.15, port 123
stratum 3, precision -32, leap 00, trust 000
refid [192.168.6.15], delay 1.02580, dispersion 0.00000
transmitted 4, in filter 4
reference time:    d51e7100.b0fa7b0a  Sun, Apr 21 2013 14:06:56.691
originate timestamp: d51e7238.45614c17  Sun, Apr 21 2013 14:12:08.271
transmit timestamp:  d51e723e.c3b5286b  Sun, Apr 21 2013 14:12:14.764
filter delay:  1.02585  1.02582  1.02580  1.02580 
         0.00000  0.00000  0.00000  0.00000 
filter offset: -6.49356 -6.49357 -6.49357 -6.49357
         0.000000 0.000000 0.000000 0.000000
delay 1.02580, dispersion 0.00000
offset -6.493570

21 Apr 14:12:14 ntpdate[1377]: step time server 192.168.6.15 offset -6.493570 sec
It even looks like NTP might be running
Code:
[root@RHEL_Server ~]# ntpdc -p
     remote           local      st poll reach  delay   offset    disp
=======================================================================
=  Cisco_Router  192.168.6.6      3   64   77 0.00023 -6.492943 1.08420
Quote:
The character in the left margin indicates the mode this peer entry is operating in. A + denotes symmetric active, a - indicates symmetric passive, a = means the remote server is being polled in client mode, a ^ indicates that the server is broadcasting to this address, a ~ denotes that the remote peer is sending broadcasts and a * marks the peer the server is currently synchronizing to.
http://doc.ntp.org/4.1.1/ntpdc.htm

I know the NTP server, a Cisco 3945, is serving NTP properly because other devices are properly slaved to it.

Any ideas?

Thanks in advance,

Rob

Last edited by ramseyrt; 04-21-2013 at 10:29 AM.
 
Old 04-22-2013, 03:13 AM   #2
roger_heslop
Member
 
Registered: Oct 2009
Location: Leander, TX
Distribution: Fedora 20
Posts: 89

Rep: Reputation: 32
I can't remember if this affects NTP on Linux specifically, but I've seen cases where a client wouldn't sync with a time server if the time were too far off, greater than 4 or 5 minutes for example.

Can you manually set your time to be no more than a few minutes off and double check?
 
Old 04-23-2013, 07:25 AM   #3
ramseyrt
LQ Newbie
 
Registered: May 2010
Location: Virginia
Distribution: Windows 7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hello,

I performed a quick 'while true;do;date;sleep 1;done' loop while typing "show date" on my NTP server (Cisco router). The RHEL system and router are within 10 seconds of each other.

Any other ideas?

Thanks in advance,

Rob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTPD service is deleting and enabling the network Iyyappan Linux - Server 3 08-13-2012 04:12 AM
Cron service and oracle service stopped unexpectedly. Can't restart oracle. camron Linux - Newbie 6 06-10-2010 06:00 PM
Disabling ntpd service v_fone Linux - Newbie 8 02-22-2009 10:14 AM
How do I set the regulatory daemon to restart when I restart the network service? zahadumy Linux - Networking 0 11-05-2006 11:24 AM
ntpd time synchonization fails ... shamilson Linux - Networking 9 08-11-2006 01:17 AM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration